summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Bracht Laumann Jespersen <t@laumann.xyz>2022-03-25 16:10:45 +0100
committerSam James <sam@gentoo.org>2022-04-21 20:54:32 +0100
commit68b51f9a0551ab8eb4a4690f613f2550558eedcc (patch)
treea8a1c15521d1a05dbb88baa65736bf6a94519359 /x11-plugins
parentx11-plugins/gkrellm-mailwatch: update EAPI 6 -> 8 (diff)
downloadgentoo-68b51f9a0551ab8eb4a4690f613f2550558eedcc.tar.gz
gentoo-68b51f9a0551ab8eb4a4690f613f2550558eedcc.tar.bz2
gentoo-68b51f9a0551ab8eb4a4690f613f2550558eedcc.zip
x11-plugins/gkrellm-trayicons: update EAPI 6 -> 8
Add patch to respect PKG_CONFIG. Signed-off-by: Thomas Bracht Laumann Jespersen <t@laumann.xyz> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/gkrellm-trayicons/files/gkrellm-trayicons-1.03-pkgconfig.patch18
-rw-r--r--x11-plugins/gkrellm-trayicons/gkrellm-trayicons-1.03-r2.ebuild33
2 files changed, 51 insertions, 0 deletions
diff --git a/x11-plugins/gkrellm-trayicons/files/gkrellm-trayicons-1.03-pkgconfig.patch b/x11-plugins/gkrellm-trayicons/files/gkrellm-trayicons-1.03-pkgconfig.patch
new file mode 100644
index 000000000000..02d4c150dd3e
--- /dev/null
+++ b/x11-plugins/gkrellm-trayicons/files/gkrellm-trayicons-1.03-pkgconfig.patch
@@ -0,0 +1,18 @@
+Have Makefile respect user-configured pkg-config
+--- a/Makefile
++++ b/Makefile
+@@ -1,11 +1,11 @@
+
+ VERSION = `cat VERSION`
+ PREFIX ?= /usr/local
+-GTK_CONFIG = pkg-config gtk+-2.0
++PKG_CONFIG ?= pkg-config
+ PLUGIN_DIR ?= $(PREFIX)/lib/gkrellm2/plugins
+ GKRELLM_INCLUDE = -I$(PREFIX)/include
+-GTK_CFLAGS = `$(GTK_CONFIG) --cflags`
+-GTK_LIB = `$(GTK_CONFIG) --libs`
++GTK_CFLAGS = $(shell ${PKG_CONFIG} gtk+-2.0 --cflags)
++GTK_LIB = $(shell ${PKG_CONFIG} gtk+-2.0 --libs)
+ FLAGS = -fPIC $(GTK_CFLAGS) $(GKRELLM_INCLUDE)
+ CFLAGS += $(FLAGS)
+ CFLAGS += -DVERSION=\"$(VERSION)\"
diff --git a/x11-plugins/gkrellm-trayicons/gkrellm-trayicons-1.03-r2.ebuild b/x11-plugins/gkrellm-trayicons/gkrellm-trayicons-1.03-r2.ebuild
new file mode 100644
index 000000000000..7cd6220fe5a7
--- /dev/null
+++ b/x11-plugins/gkrellm-trayicons/gkrellm-trayicons-1.03-r2.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gkrellm-plugin toolchain-funcs
+
+DESCRIPTION="Configurable Tray Icons for GKrellM"
+HOMEPAGE="http://gkrellm.srcbox.net/Plugins.html"
+SRC_URI="mirror://gentoo/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+RDEPEND="app-admin/gkrellm:2[X]"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-ldflags.patch
+ "${FILESDIR}"/${P}-pkgconfig.patch
+)
+
+src_configure() {
+ PLUGIN_SO=( trayicons$(get_modname) )
+ default
+}
+
+src_compile() {
+ tc-export PKG_CONFIG
+ emake CC="$(tc-getCC)" LDFLAGS="${LDFLAGS}"
+}