summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-04-20 02:37:55 +0100
committerSam James <sam@gentoo.org>2021-04-20 02:42:26 +0100
commit6c408ec4cba6795b779b5a84de96f887ee3705b7 (patch)
treef98444d233834a240d7dbb7f6234a9de0f7da7db /x11-plugins
parentx11-plugins/wmSpaceWeather: epatch->eapply (diff)
downloadgentoo-6c408ec4cba6795b779b5a84de96f887ee3705b7.tar.gz
gentoo-6c408ec4cba6795b779b5a84de96f887ee3705b7.tar.bz2
gentoo-6c408ec4cba6795b779b5a84de96f887ee3705b7.zip
x11-plugins/asapm: port to EAPI 7
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/asapm/asapm-3.1-r1.ebuild22
1 files changed, 15 insertions, 7 deletions
diff --git a/x11-plugins/asapm/asapm-3.1-r1.ebuild b/x11-plugins/asapm/asapm-3.1-r1.ebuild
index e0d99b379ad6..538bca9b0512 100644
--- a/x11-plugins/asapm/asapm-3.1-r1.ebuild
+++ b/x11-plugins/asapm/asapm-3.1-r1.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=7
-inherit autotools epatch toolchain-funcs
+inherit autotools toolchain-funcs
DESCRIPTION="APM monitor for AfterStep"
HOMEPAGE="http://tigr.net/afterstep/applets/"
@@ -12,19 +12,27 @@ SRC_URI="http://www.tigr.net/afterstep/download/asapm/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ppc -sparc ~x86"
-IUSE=""
RDEPEND="x11-libs/libX11
x11-libs/libXpm"
-
DEPEND="${RDEPEND}
x11-base/xorg-proto"
+PATCHES=(
+ "${FILESDIR}"/${P}-ldflags.patch
+ "${FILESDIR}"/${P}-include.patch
+ "${FILESDIR}"/${P}-autoconf.patch
+)
+
src_prepare() {
- epatch "${FILESDIR}"/${P}-{ldflags,include,autoconf}.patch
- cp autoconf/configure.in . || die
- AT_M4DIR=autoconf eautoconf
+ default
+
tc-export CC
+
+ cp autoconf/configure.in . || die
+ mv configure.{in,ac} || die
+
+ AT_M4DIR=autoconf eautoreconf
}
src_install() {