summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2022-07-09 14:28:55 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2022-07-09 17:40:53 +0200
commita52d11eee7e36e00c77191fd7e70ffdac436e107 (patch)
treea480be1f3cbfb40e3a7c40c41c36c797802ad419 /x11-plugins
parentx11-plugins/wmbio: respect CC (diff)
downloadgentoo-a52d11eee7e36e00c77191fd7e70ffdac436e107.tar.gz
gentoo-a52d11eee7e36e00c77191fd7e70ffdac436e107.tar.bz2
gentoo-a52d11eee7e36e00c77191fd7e70ffdac436e107.zip
x11-plugins/wmcdplay: fix C++11 string literal
Closes: https://bugs.gentoo.org/732416 Signed-off-by: Bernard Cafarelli <voyageur@gentoo.org>
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmcdplay/files/wmcdplay-1.1-cpp11.patch30
-rw-r--r--x11-plugins/wmcdplay/wmcdplay-1.1-r1.ebuild3
2 files changed, 32 insertions, 1 deletions
diff --git a/x11-plugins/wmcdplay/files/wmcdplay-1.1-cpp11.patch b/x11-plugins/wmcdplay/files/wmcdplay-1.1-cpp11.patch
new file mode 100644
index 000000000000..7fdd1021dab3
--- /dev/null
+++ b/x11-plugins/wmcdplay/files/wmcdplay-1.1-cpp11.patch
@@ -0,0 +1,30 @@
+From bd69f80f597ca589683d6f606e979b8f77e9e0a4 Mon Sep 17 00:00:00 2001
+From: Doug Torrance <dtorrance@piedmont.edu>
+Date: Wed, 29 Apr 2020 11:01:30 -0400
+Subject: [PATCH] wmcdplay: Add spaces between macro and string literals for
+ C++11
+
+We may get compile errors (e.g., [1]) otherwise.
+
+[1] https://clang.debian.net/logs/2020-02-24-9.0.1/
+ wmcdplay_1.1-2_unstable_clang9.0.1.log
+---
+ wmcdplay.cc | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/wmcdplay.cc b/wmcdplay.cc
+index 46ae03a..675b5dc 100644
+--- a/wmcdplay.cc
++++ b/wmcdplay.cc
+@@ -353,7 +353,7 @@ unsigned long mixColor(char *colorname1, int prop1, char *colorname2, int prop2)
+ void scanArgs(int argc, char **argv){
+ for(int i=1;i<argc;i++){
+ if(strcmp(argv[i], "-h")==0 || strcmp(argv[i], "-help")==0 || strcmp(argv[i], "--help")==0){
+- fprintf(stderr, "wmcdplay - A cd player designed for WindowMaker\nRelease "VERSION"\n");
++ fprintf(stderr, "wmcdplay - A cd player designed for WindowMaker\nRelease " VERSION "\n");
+ fprintf(stderr, "Copyright (C) 1998 Sam Hawker <shawkie@geocities.com>\n");
+ fprintf(stderr, "This software comes with ABSOLUTELY NO WARRANTY\n");
+ fprintf(stderr, "This software is free software, and you are welcome to redistribute it\n");
+--
+2.11.4.GIT
+
diff --git a/x11-plugins/wmcdplay/wmcdplay-1.1-r1.ebuild b/x11-plugins/wmcdplay/wmcdplay-1.1-r1.ebuild
index 4751907aadbf..47fa6c9faf43 100644
--- a/x11-plugins/wmcdplay/wmcdplay-1.1-r1.ebuild
+++ b/x11-plugins/wmcdplay/wmcdplay-1.1-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -20,6 +20,7 @@ DEPEND="${RDEPEND}
S="${WORKDIR}/dockapps"
+PATCHES=( ${FILESDIR}/${P}-cpp11.patch )
DOCS=( ARTWORK README )
src_prepare() {