summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2018-06-01 16:20:03 +0200
committerLars Wendler <polynomial-c@gentoo.org>2018-06-01 16:20:03 +0200
commitc423e0accff8ecf64926257e1eddc965c606a1a9 (patch)
treef39b98b7887352e7f8ce6e69fd2c146f33d7980c /x11-plugins
parentmedia-video/smplayer: Bump to version 18.5.0 (diff)
downloadgentoo-c423e0accff8ecf64926257e1eddc965c606a1a9.tar.gz
gentoo-c423e0accff8ecf64926257e1eddc965c606a1a9.tar.bz2
gentoo-c423e0accff8ecf64926257e1eddc965c606a1a9.zip
x11-plugins/enigmail: Security bump to version 2.0.6
Bug: https://bugs.gentoo.org/656790 Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/enigmail/Manifest1
-rw-r--r--x11-plugins/enigmail/enigmail-2.0.6.ebuild83
2 files changed, 84 insertions, 0 deletions
diff --git a/x11-plugins/enigmail/Manifest b/x11-plugins/enigmail/Manifest
index eef68644a12a..b6100d708f37 100644
--- a/x11-plugins/enigmail/Manifest
+++ b/x11-plugins/enigmail/Manifest
@@ -1,3 +1,4 @@
DIST enigmail-1.9.9.tar.gz 1787556 BLAKE2B 729cf7e404b4cc5d964df476e627b476916cd6c834ce5f220a26738bc32eabbd9fd2c4c3cbaccef6e1d8c4b5b7313b54278a4170808f8b722443b338fda87b55 SHA512 39b37305362c88527d897ed95aa9d8457137d5f026359d19b838ab9df531c14099e157afdc8fefae78a6fa2ddded8dbfbeaf84eb91ac6cfbb05ae808731da2cb
DIST enigmail-2.0.4.tar.gz 2533719 BLAKE2B 9c3a38233df2c05e4bbbdfa2fd762b6362cc0bbc143b7a417cdabee44b3873bd73747a7b8d50317987f5d1750acf7badfae631cc2827718ed5702c5df2d10709 SHA512 eadcd6bfe42c43d8dd569a8085d82b7acf94f77e5fc2c7632e4148b9cc21389552de687a81a3e88e9b2639adad677c85d6db9b14a39f994f79c0524500de0b3b
DIST enigmail-2.0.5.tar.gz 2534693 BLAKE2B ad5984b74df2bd1c563f89a23136d9c9742aa7ba94d5683b9046f93eb11c5f729231497e5bb6e8c002c03feb55f2e2a07b43063bc63de3c7c578ea5b4b136fd1 SHA512 9edf78f38dbdb73f16190cc6b08eb02dcc199c41026003d19ce302a48fb4d9a6be6e765bbb7a8ef7f1bc3eea1065182437850da23c3ef5b89d1d5c66c602480b
+DIST enigmail-2.0.6.tar.gz 2535125 BLAKE2B 1fd0d220f7f1020bac9487a7b6ed234e2b3b9b5929a7997954e735e2aee08ab6276c58790b57d7f7cb29e284e9a1e50ca50a373ed4e75524fbd85349a31f8667 SHA512 d2d5b1a5d2ca99735ad40532a04a935235bb62b5eb2494ec5c5f2e17b271b40d43552895bb977e892d0a226cd3514c4314f541ac8eb1d610c3b20b183b18f229
diff --git a/x11-plugins/enigmail/enigmail-2.0.6.ebuild b/x11-plugins/enigmail/enigmail-2.0.6.ebuild
new file mode 100644
index 000000000000..9e8d0cbb3958
--- /dev/null
+++ b/x11-plugins/enigmail/enigmail-2.0.6.ebuild
@@ -0,0 +1,83 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit python-any-r1
+
+DESCRIPTION="Mozilla extension to provide GPG support in mail clients"
+HOMEPAGE="http://www.enigmail.net/"
+
+SLOT="0"
+LICENSE="MPL-2.0 GPL-3"
+IUSE=""
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.code.sf.net/p/enigmail/source"
+ S="${WORKDIR}/${P}"
+else
+ if [[ ${PV} = *_beta* ]] ; then
+ SRC_URI="http://www.enigmail.net/download/beta/${P/_/-}.tar.gz"
+ else
+ SRC_URI="http://www.enigmail.net/download/source/${P}.tar.gz"
+ KEYWORDS="~alpha ~amd64 ~arm ~ppc ~ppc64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+ fi
+ S="${WORKDIR}/${PN}"
+fi
+
+RDEPEND="|| (
+ ( >=app-crypt/gnupg-2.0
+ || (
+ app-crypt/pinentry[gtk(-)]
+ app-crypt/pinentry[qt4(-)]
+ app-crypt/pinentry[qt5(-)]
+ )
+ )
+ =app-crypt/gnupg-1.4*
+ )
+ !<mail-client/thunderbird-52.5.0
+ !<www-client/seamonkey-2.49.5.0_p0
+"
+DEPEND="${RDEPEND}
+ ${PYTHON_DEPS}
+ app-arch/zip
+ dev-lang/perl
+ "
+
+src_compile() {
+ emake ipc public ui package lang stdlib
+ emake xpi
+
+}
+
+src_install() {
+ local emid=$(sed -n '/<em:id>/!d; s/.*\({.*}\).*/\1/; p; q' build/dist/install.rdf)
+ [[ -n ${emid} ]] || die "Could not scrape EM:ID from install.rdf"
+
+ mv build/enigmail*.xpi build/"${emid}.xpi" || die 'Could not rename XPI to match EM:ID'
+
+ # thunderbird
+ insinto "/usr/share/mozilla/extensions/{3550f703-e582-4d05-9a08-453d09bdfdc6}"
+ doins build/"${emid}.xpi"
+
+ # seamonkey
+ insinto "/usr/share/mozilla/extensions/{92650c4d-4b8e-4d2a-b7eb-24ecf4f6b63a}"
+ doins build/"${emid}.xpi"
+}
+
+pkg_postinst() {
+ local peimpl=$(eselect --brief --colour=no pinentry show)
+ case "${peimpl}" in
+ *gtk*|*qt*) ;;
+ *) ewarn "The pinentry front-end currently selected is not one supported by thunderbird."
+ ewarn "You may be prompted for your password in an inaccessible shell!!"
+ ewarn "Please use 'eselect pinentry' to select either the gtk or qt front-end"
+ ;;
+ esac
+ if [[ -n ${REPLACING_VERSIONS} ]]; then
+ elog
+ elog "Please restart thunderbird and/or seamonkey in order for them to use"
+ elog "the newly installed version of enigmail."
+ fi
+}