summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Bauman <bman@gentoo.org>2018-05-30 19:43:04 -0400
committerAaron Bauman <bman@gentoo.org>2018-05-31 08:57:04 -0400
commitd6a404124be5939ff1cf99150d22ce3104005b54 (patch)
treef6d7c5e143bdaa2a48670fc5b267c78f97a404c3 /x11-plugins
parentx11-plugins/pidgin-libnotify: bump EAPI and drop eutils (diff)
downloadgentoo-d6a404124be5939ff1cf99150d22ce3104005b54.tar.gz
gentoo-d6a404124be5939ff1cf99150d22ce3104005b54.tar.bz2
gentoo-d6a404124be5939ff1cf99150d22ce3104005b54.zip
x11-plugins/pidgin-mbpurple: bump EAPI and drop base eclass
Package-Manager: Portage-2.3.40, Repoman-2.3.9
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/pidgin-mbpurple/pidgin-mbpurple-0.3.0-r2.ebuild19
1 files changed, 10 insertions, 9 deletions
diff --git a/x11-plugins/pidgin-mbpurple/pidgin-mbpurple-0.3.0-r2.ebuild b/x11-plugins/pidgin-mbpurple/pidgin-mbpurple-0.3.0-r2.ebuild
index 7a7eeeed84eb..9e38de55cc19 100644
--- a/x11-plugins/pidgin-mbpurple/pidgin-mbpurple-0.3.0-r2.ebuild
+++ b/x11-plugins/pidgin-mbpurple/pidgin-mbpurple-0.3.0-r2.ebuild
@@ -1,13 +1,14 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=2
+EAPI=6
-inherit base toolchain-funcs
+inherit toolchain-funcs
+
+MY_P="${P/pidgin-/}"
DESCRIPTION="Pidgin plug-in supporting microblog services like Twitter or identi.ca"
HOMEPAGE="https://code.google.com/p/microblog-purple/"
-MY_P="${P/pidgin-/}"
SRC_URI="https://microblog-purple.googlecode.com/files/${MY_P}.tar.gz"
LICENSE="GPL-3"
@@ -21,16 +22,16 @@ DEPEND="${RDEPEND}
virtual/pkgconfig"
S=${WORKDIR}/${MY_P}
-pkg_setup() {
+src_prepare() {
+ default
+
tc-export CC
-}
-src_prepare() {
# upstream Issue 226 (Respect LDFLAGS)
- sed -i "/^LDFLAGS/d" global.mak || die
+ sed -i "/^LDFLAGS/d" global.mak || die "sed for LDFLAGS failed"
# upstream Issue 225 (Warnings during compilation using make -j2)
- sed -i "s/make /\$(MAKE) /g" Makefile || die
+ sed -i "s/make /\$(MAKE) /g" Makefile || die "sed #2 failed"
# upstream Issue 224 (configurable twitgin)
if ! use twitgin; then