summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBernard Cafarelli <voyageur@gentoo.org>2017-02-13 00:29:43 +0100
committerBernard Cafarelli <voyageur@gentoo.org>2017-02-13 00:35:21 +0100
commiteb063b6fd0705db524b5b7bbba25a3259049af85 (patch)
tree6b0ef6992a0cadca71555e8a23e82608bbda8d8f /x11-plugins
parentRevert "x11-plugins/wmudmount: Depend on virtual/imagemagick-tools" (diff)
downloadgentoo-eb063b6fd0705db524b5b7bbba25a3259049af85.tar.gz
gentoo-eb063b6fd0705db524b5b7bbba25a3259049af85.tar.bz2
gentoo-eb063b6fd0705db524b5b7bbba25a3259049af85.zip
x11-plugins/wmudmount: depend on virtual/imagemagick-tools
Previous commit messed with stable version and last changes Bug 587870 Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmudmount/wmudmount-2.2-r2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/x11-plugins/wmudmount/wmudmount-2.2-r2.ebuild b/x11-plugins/wmudmount/wmudmount-2.2-r2.ebuild
new file mode 100644
index 000000000000..32e4f34064bd
--- /dev/null
+++ b/x11-plugins/wmudmount/wmudmount-2.2-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit eutils gnome2-utils xdg
+
+DESCRIPTION="A filesystem mounter that uses udisks to handle notification and mounting"
+HOMEPAGE="https://sourceforge.net/projects/wmudmount/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="gnome-keyring libnotify"
+
+RDEPEND="sys-fs/udisks:2
+ >=x11-libs/gtk+-3.8.0:3
+ gnome-keyring? ( gnome-base/libgnome-keyring )
+ libnotify? ( >=x11-libs/libnotify-0.7 )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ virtual/imagemagick-tools[png]"
+
+DOCS="ChangeLog"
+
+src_configure() {
+ econf \
+ $(use_with libnotify) \
+ $(use_with gnome-keyring)
+}
+
+pkg_preinst() { gnome2_icon_savelist; }
+pkg_postinst() { gnome2_icon_cache_update; }
+pkg_postrm() { gnome2_icon_cache_update; }