summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Bracht Laumann Jespersen <t@laumann.xyz>2022-03-24 21:27:53 +0100
committerSam James <sam@gentoo.org>2022-04-21 20:54:30 +0100
commitf3d3d5dc446095b19e64d78284804501f9ae335c (patch)
tree829bb928b48294783b21e16c61645ce25d4f86ed /x11-plugins
parentx11-plugins/gkrellshoot: update EAPI 6 -> 8 (diff)
downloadgentoo-f3d3d5dc446095b19e64d78284804501f9ae335c.tar.gz
gentoo-f3d3d5dc446095b19e64d78284804501f9ae335c.tar.bz2
gentoo-f3d3d5dc446095b19e64d78284804501f9ae335c.zip
x11-plugins/gkrellm-countdown: update EAPI 6 -> 8
Signed-off-by: Thomas Bracht Laumann Jespersen <t@laumann.xyz> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/gkrellm-countdown/files/gkrellm-countdown-0.1.2-r2-pkgconfig.patch16
-rw-r--r--x11-plugins/gkrellm-countdown/gkrellm-countdown-0.1.2-r2.ebuild29
2 files changed, 45 insertions, 0 deletions
diff --git a/x11-plugins/gkrellm-countdown/files/gkrellm-countdown-0.1.2-r2-pkgconfig.patch b/x11-plugins/gkrellm-countdown/files/gkrellm-countdown-0.1.2-r2-pkgconfig.patch
new file mode 100644
index 000000000000..a8af1562391c
--- /dev/null
+++ b/x11-plugins/gkrellm-countdown/files/gkrellm-countdown-0.1.2-r2-pkgconfig.patch
@@ -0,0 +1,16 @@
+Have Makefile respect user chosen PKG_CONFIG
+--- a/Makefile
++++ b/Makefile
+@@ -3,8 +3,10 @@
+ # You may want to rename the binary-file.
+ BIN_FILENAME = gkrellm-countdown
+
+-GTK_INCLUDE ?= `pkg-config gtk+-2.0 --cflags`
+-GTK_LIB ?= `pkg-config gtk+-2.0 --libs`
++PKG_CONFIG ?= pkg-config
++
++GTK_INCLUDE ?= $(shell ${PKG_CONFIG} gtk+-2.0 --cflags)
++GTK_LIB ?= $(shell ${PKG_CONFIG} gtk+-2.0 --libs)
+ IMLIB_INCLUDE ?=
+ IMLIB_LIB ?=
+ PLUGIN_DIR ?= /usr/local/lib/gkrellm2/plugins
diff --git a/x11-plugins/gkrellm-countdown/gkrellm-countdown-0.1.2-r2.ebuild b/x11-plugins/gkrellm-countdown/gkrellm-countdown-0.1.2-r2.ebuild
new file mode 100644
index 000000000000..29c9fb53247e
--- /dev/null
+++ b/x11-plugins/gkrellm-countdown/gkrellm-countdown-0.1.2-r2.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit gkrellm-plugin toolchain-funcs
+
+DESCRIPTION="A simple countdown clock for GKrellM2"
+HOMEPAGE="http://freshmeat.sourceforge.net/projects/gkrellm-countdown"
+SRC_URI="http://oss.pugsplace.net/${P}.tar.gz"
+S="${WORKDIR}/${PN}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+
+RDEPEND="app-admin/gkrellm:2[X]"
+DEPEND="${RDEPEND}"
+BDPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-makefile.patch
+ "${FILESDIR}"/${P}-r2-pkgconfig.patch
+)
+
+src_compile() {
+ tc-export PKG_CONFIG
+ emake CC="$(tc-getCC)" LDFLAGS="${LDFLAGS}"
+}