summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Mair-Keimberger <m.mairkeimberger@gmail.com>2018-06-12 19:52:50 +0200
committerBernard Cafarelli <voyageur@gentoo.org>2018-06-12 23:37:26 +0200
commitf448a41b22fab9ad8d98526ab205c8623e3941b8 (patch)
treef082064c51b64d95cc54cdfcb81960ddc7b6adf4 /x11-plugins
parentx11-plugins/wmnet: use HTTPs (diff)
downloadgentoo-f448a41b22fab9ad8d98526ab205c8623e3941b8.tar.gz
gentoo-f448a41b22fab9ad8d98526ab205c8623e3941b8.tar.bz2
gentoo-f448a41b22fab9ad8d98526ab205c8623e3941b8.zip
x11-plugins/wmnet: EAPI7, improve ebuild, use HTTPs
Diffstat (limited to 'x11-plugins')
-rw-r--r--x11-plugins/wmnet/wmnet-1.06-r2.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/x11-plugins/wmnet/wmnet-1.06-r2.ebuild b/x11-plugins/wmnet/wmnet-1.06-r2.ebuild
new file mode 100644
index 000000000000..f55209896cb8
--- /dev/null
+++ b/x11-plugins/wmnet/wmnet-1.06-r2.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="WMnet is a dock.app network monitor"
+HOMEPAGE="https://www.dockapps.net/wmnet"
+SRC_URI="https://www.dockapps.net/download/${P}.tar.gz
+ mirror://gentoo/${P}-misc.patch.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~sparc ~alpha ~amd64 ~ppc"
+IUSE=""
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXext"
+DEPEND="${RDEPEND}
+ x11-base/xorg-proto
+ x11-misc/imake
+ app-text/rman"
+
+PATCHES=( "${WORKDIR}"/${P}-misc.patch )
+
+src_compile() {
+ xmkmf || die "xmkmf failed."
+ emake CDEBUGFLAGS="${CFLAGS}" LDOPTIONS="${LDFLAGS}"
+}
+
+src_install() {
+ dobin wmnet
+ newman wmnet.man wmnet.1
+ dodoc README Changelog
+}