summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-terms/eterm/eterm-0.9.5.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-terms/eterm/eterm-0.9.5.ebuild')
-rw-r--r--x11-terms/eterm/eterm-0.9.5.ebuild79
1 files changed, 79 insertions, 0 deletions
diff --git a/x11-terms/eterm/eterm-0.9.5.ebuild b/x11-terms/eterm/eterm-0.9.5.ebuild
new file mode 100644
index 000000000000..68d8b95583e3
--- /dev/null
+++ b/x11-terms/eterm/eterm-0.9.5.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="2"
+inherit eutils autotools
+
+MY_P=Eterm-${PV}
+
+if [[ ${PV} == "9999" ]] ; then
+ ESVN_REPO_URI="http://svn.enlightenment.org/svn/e/trunk/eterm/Eterm"
+ inherit subversion
+ SRC_URI=""
+ KEYWORDS=""
+else
+ SRC_URI="http://www.eterm.org/download/${MY_P}.tar.gz
+ !minimal? ( http://www.eterm.org/download/Eterm-bg-${PV}.tar.gz )
+ mirror://sourceforge/eterm/${MY_P}.tar.gz
+ !minimal? ( mirror://sourceforge/eterm/Eterm-bg-${PV}.tar.gz )"
+ KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 sh sparc x86 ~x86-fbsd"
+fi
+
+DESCRIPTION="A vt102 terminal emulator for X"
+HOMEPAGE="http://www.eterm.org/"
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="escreen minimal cpu_flags_x86_mmx cpu_flags_x86_sse2 unicode"
+
+RDEPEND="x11-libs/libX11
+ x11-libs/libXmu
+ x11-libs/libXt
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-proto/xextproto
+ x11-proto/xproto
+ >=x11-libs/libast-0.6.1
+ media-libs/imlib2[X]
+ media-fonts/font-misc-misc
+ escreen? ( app-misc/screen )"
+DEPEND="${RDEPEND}"
+
+if [[ ${PV} == "9999" ]] ; then
+ S=${WORKDIR}/${ECVS_MODULE}
+else
+ S=${WORKDIR}/${MY_P}
+fi
+
+src_unpack() {
+ if [[ ${PV} == "9999" ]] ; then
+ subversion_src_unpack
+ cd "${S}"
+ eautoreconf
+ else
+ unpack ${MY_P}.tar.gz
+ cd "${S}"
+ use minimal || unpack Eterm-bg-${PV}.tar.gz
+ fi
+}
+
+src_configure() {
+ export TIC="true"
+ econf \
+ $(use_enable escreen) \
+ --with-imlib \
+ --enable-trans \
+ $(use_enable cpu_flags_x86_mmx mmx) \
+ $(use_enable cpu_flags_x86_sse2 sse2) \
+ $(use_enable unicode multi-charset) \
+ --with-delete=execute \
+ --with-backspace=auto
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+ dodoc ChangeLog README ReleaseNotes
+ use escreen && dodoc doc/README.Escreen
+ dodoc bg/README.backgrounds
+}