summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPablo <pord@tuta.io>2019-12-03 10:31:33 +0100
committerJoonas Niilola <juippis@gentoo.org>2019-12-03 15:13:51 +0200
commit108de5ce4949383ae17a140e658fdb61013f07a1 (patch)
tree77413fa23a05f0c0cc7705b8ee477fef61b4a0dd /x11-terms/kitty/kitty-0.15.0.ebuild
parentmail-client/clawsker: add dep version req & xdg_icon_cache_update (diff)
downloadgentoo-108de5ce4949383ae17a140e658fdb61013f07a1.tar.gz
gentoo-108de5ce4949383ae17a140e658fdb61013f07a1.tar.bz2
gentoo-108de5ce4949383ae17a140e658fdb61013f07a1.zip
x11-terms/kitty: bump to 0.15.0, improve ebuilds and add myself as a Proxy-Maintainer
Signed-off-by: Pablo Orduna <pabloorduna98@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/13769 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'x11-terms/kitty/kitty-0.15.0.ebuild')
-rw-r--r--x11-terms/kitty/kitty-0.15.0.ebuild101
1 files changed, 101 insertions, 0 deletions
diff --git a/x11-terms/kitty/kitty-0.15.0.ebuild b/x11-terms/kitty/kitty-0.15.0.ebuild
new file mode 100644
index 000000000000..5e7043b85fbb
--- /dev/null
+++ b/x11-terms/kitty/kitty-0.15.0.ebuild
@@ -0,0 +1,101 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7} )
+
+inherit python-single-r1 toolchain-funcs xdg
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/kovidgoyal/kitty.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/kovidgoyal/kitty/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="A modern, hackable, featureful, OpenGL-based terminal emulator"
+HOMEPAGE="https://github.com/kovidgoyal/kitty"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="debug imagemagick wayland"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ media-libs/fontconfig
+ media-libs/freetype:2
+ >=media-libs/harfbuzz-1.5.0:=
+ media-libs/libcanberra
+ media-libs/libpng:0=
+ x11-libs/libxcb[xkb]
+ x11-libs/libXcursor
+ x11-libs/libXi
+ x11-libs/libXinerama
+ x11-libs/libxkbcommon[X]
+ x11-libs/libXrandr
+ sys-apps/dbus
+ sys-libs/zlib
+ imagemagick? ( virtual/imagemagick-tools )
+ wayland? (
+ dev-libs/wayland
+ >=dev-libs/wayland-protocols-1.17
+ )
+"
+
+DEPEND="${RDEPEND}
+ media-libs/mesa[X(+)]
+ sys-libs/ncurses
+"
+
+BDEPEND="virtual/pkgconfig"
+
+[[ ${PV} == *9999 ]] && BDEPEND+=" >=dev-python/sphinx-1.7"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-flags.patch
+ "${FILESDIR}"/${PN}-0.14.4-svg-icon.patch
+)
+
+src_prepare() {
+ default
+
+ # disable wayland as required
+ if ! use wayland; then
+ sed -i "/'x11 wayland'/s/ wayland//" setup.py || die
+ fi
+
+ # respect doc dir
+ sed -i "/htmldir =/s/appname/'${PF}'/" setup.py || die
+
+ tc-export CC
+}
+
+src_compile() {
+ "${EPYTHON}" setup.py \
+ --verbose $(usex debug --debug "") \
+ --libdir-name $(get_libdir) \
+ linux-package
+}
+
+src_test() {
+ export KITTY_CONFIG_DIRECTORY=${T}
+ "${EPYTHON}" test.py || die
+}
+
+src_install() {
+ insinto /usr
+ doins -r linux-package/*
+ dobin linux-package/bin/kitty
+ python_fix_shebang "${ED}"
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}