summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2021-02-27 14:51:06 -0500
committerMatt Turner <mattst88@gentoo.org>2021-02-27 14:55:43 -0500
commit44f5f1e32e0d2e88e1f0fb693b7b1561de0ca3c7 (patch)
treef3c25f5f4f0dc073c2b62d71b4b64e1e4c63885e /x11-terms
parentx11-libs/vte: Version bump to 0.62.3 (diff)
downloadgentoo-44f5f1e32e0d2e88e1f0fb693b7b1561de0ca3c7.tar.gz
gentoo-44f5f1e32e0d2e88e1f0fb693b7b1561de0ca3c7.tar.bz2
gentoo-44f5f1e32e0d2e88e1f0fb693b7b1561de0ca3c7.zip
x11-terms/gnome-terminal: Version bump to 3.38.3
Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/gnome-terminal/Manifest1
-rw-r--r--x11-terms/gnome-terminal/gnome-terminal-3.38.3.ebuild85
2 files changed, 86 insertions, 0 deletions
diff --git a/x11-terms/gnome-terminal/Manifest b/x11-terms/gnome-terminal/Manifest
index 0a9b71fba530..a08c02ee4ec1 100644
--- a/x11-terms/gnome-terminal/Manifest
+++ b/x11-terms/gnome-terminal/Manifest
@@ -3,3 +3,4 @@ DIST gnome-terminal-3.36.2.tar.xz 2528492 BLAKE2B a303c5c9d053ef9f320dee84efa7fe
DIST gnome-terminal-3.38.1-cntr-ntfy-autottl-ts.patch.xz 34100 BLAKE2B 7ae126b93e63bc40ec4b0482c66d1b9be77939553df42948ce92b62cd42e8bf12a453540d90176f00cc545ce3a42ec5fc2e10fa248be641c64fc02611c61ee64 SHA512 6fe4fb80d968ecb036dd24c06e869b754b6634e25168d84a509ad91a510170fc8da368f37f7dec78ef1d11bb9f08ddd2a97c7407275116687639fb00f218553d
DIST gnome-terminal-3.38.1.tar.xz 2558708 BLAKE2B 5ae73123d4e53f6f4ffe83c2ad1d12bf0ac87ad5d62d7d28a55439e4e969985cd15d91aa6673a505b69f5d194aef2f8aa6346d41201262d39e4a196b48d69c19 SHA512 99d1e87a56dd5ce0c421f8b1ab197f25d8e878cbf1166786263cc9bf85b28eba327b0228a4ec35b8f656bdc3c5d7d48c5aca1768148fc5f324ff3f1c70983993
DIST gnome-terminal-3.38.2.tar.xz 2575228 BLAKE2B 4a8b2505b7448c6227961cb396050bd778550cf5e8e12b89af378e6d949ee4a4e65501c838ade2b89a22d5cea0a6c82921cd6cb8d72544263eda0acdd751746a SHA512 6d630dacc50b2107a125fe2691222d860fda7d25679ca28163953c1e310a29f6b6c1504d88edd128ee4e073fc1d0ca1039d0130fdd13f3b92e98ee17db67be61
+DIST gnome-terminal-3.38.3.tar.xz 2574916 BLAKE2B c7bc17da2be607d15437b5f2965901f034e13fe5e5a7db03a3af6aaa67643e52a13a23aa3cc379c11387d158815a09a2edd09cbe6a983f243394746f3ada66ca SHA512 1dc418faaafce019be75173ad035f2536bfec7fea179ecf76f054a62651137339a018198cd6a0cfd63a7a15a1dcf803b62d19a48545a06a133fde186bfbf88ca
diff --git a/x11-terms/gnome-terminal/gnome-terminal-3.38.3.ebuild b/x11-terms/gnome-terminal/gnome-terminal-3.38.3.ebuild
new file mode 100644
index 000000000000..8d0bfaf9d0af
--- /dev/null
+++ b/x11-terms/gnome-terminal/gnome-terminal-3.38.3.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit gnome2 readme.gentoo-r1
+
+DESCRIPTION="The Gnome Terminal"
+HOMEPAGE="https://wiki.gnome.org/Apps/Terminal/"
+
+LICENSE="GPL-3+"
+SLOT="0"
+IUSE="debug +gnome-shell +nautilus vanilla"
+SRC_URI+=" !vanilla? ( https://dev.gentoo.org/~mattst88/distfiles/${PN}-3.38.1-cntr-ntfy-autottl-ts.patch.xz )"
+
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux"
+
+# FIXME: automagic dependency on gtk+[X], just transitive but needs proper control, bug 624960
+RDEPEND="
+ >=dev-libs/glib-2.52:2
+ >=x11-libs/gtk+-3.22.27:3
+ >=x11-libs/vte-0.62.1:2.91[!vanilla?]
+ >=dev-libs/libpcre2-10
+ >=gnome-base/dconf-0.14
+ >=gnome-base/gsettings-desktop-schemas-0.1.0
+ sys-apps/util-linux
+ gnome-shell? ( gnome-base/gnome-shell )
+ nautilus? ( >=gnome-base/nautilus-3.28.0 )
+"
+DEPEND="${RDEPEND}"
+# itstool required for help/* with non-en LINGUAS, see bug #549358
+# xmllint required for glib-compile-resources, see bug #549304
+BDEPEND="
+ dev-libs/libxml2:2
+ dev-libs/libxslt
+ dev-util/gdbus-codegen
+ dev-util/glib-utils
+ dev-util/itstool
+ >=sys-devel/gettext-0.19.8
+ virtual/pkgconfig
+"
+
+DOC_CONTENTS="To get previous working directory inherited in new opened tab, or
+ notifications of long-running commands finishing, you will need
+ to add the following line to your ~/.bashrc:\n
+ . /etc/profile.d/vte-2.91.sh"
+
+src_prepare() {
+ if ! use vanilla; then
+ # https://bugzilla.gnome.org/show_bug.cgi?id=695371
+ # Fedora patches:
+ # Restore transparency support (with compositing WMs only)
+ # OSC 777 desktop notification support (notifications on tabs for long-running commands completing)
+ # Restore "Set title" support
+ # Automatic title updating based on currently running foreground process
+ # https://src.fedoraproject.org/rpms/gnome-terminal/raw/f31/f/gnome-terminal-cntr-ntfy-autottl-ts.patch
+ # Depends on vte[-vanilla] for OSC 777 and the preexec/precmd/etc patches in VTE
+ eapply "${WORKDIR}"/${PN}-3.38.1-cntr-ntfy-autottl-ts.patch
+ fi
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ --disable-static \
+ $(use_enable debug) \
+ $(use_enable gnome-shell search-provider) \
+ $(use_with nautilus nautilus-extension)
+}
+
+src_install() {
+ DOCS=( AUTHORS ChangeLog HACKING NEWS )
+ gnome2_src_install
+ if ! use vanilla; then
+ # Separate "New Window/Tab" menu entries by default, instead of unified "New Terminal"
+ insinto /usr/share/glib-2.0/schemas
+ newins "${FILESDIR}"/separate-new-tab-window.gschema.override org.gnome.Terminal.gschema.override
+ fi
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ gnome2_pkg_postinst
+ readme.gentoo_print_elog
+}