summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2019-09-26 20:52:16 -0600
committerTim Harder <radhermit@gentoo.org>2019-09-26 20:52:16 -0600
commit57f2d2e48e13220efd0b4143914be5e226a6988b (patch)
tree6487f7a8472d4ee1db6a2f7e48430146fbd55464 /x11-terms
parentx11-terms/kitty: version bump to 0.14.6 (diff)
downloadgentoo-57f2d2e48e13220efd0b4143914be5e226a6988b.tar.gz
gentoo-57f2d2e48e13220efd0b4143914be5e226a6988b.tar.bz2
gentoo-57f2d2e48e13220efd0b4143914be5e226a6988b.zip
x11-terms/kitty: remove old
Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/kitty/Manifest1
-rw-r--r--x11-terms/kitty/kitty-0.14.2.ebuild107
2 files changed, 0 insertions, 108 deletions
diff --git a/x11-terms/kitty/Manifest b/x11-terms/kitty/Manifest
index 7185f445baeb..8aa1f415c4d3 100644
--- a/x11-terms/kitty/Manifest
+++ b/x11-terms/kitty/Manifest
@@ -1,3 +1,2 @@
-DIST kitty-0.14.2.tar.xz 2867116 BLAKE2B 20f3d66caa5242502f2699d4a5e8364eda357b00c72d50650ab0d03fbbb552152a2d4447e37ce20660d6d8f9ffc285aee057f6adf7a03ac57fa8ab6d1da61013 SHA512 191a37424c51776d271008c6b4b0cb43b60cd2abea3ea7b2a08cca9a8d44c4932ca11470f3efb8debc0e2ef3641bb68c05374401073b23cf81042af467b1dbf4
DIST kitty-0.14.4.tar.xz 2946268 BLAKE2B e06cdb1081d821bd65190ec7526482f7471f7a04c8a559e48465b602559079c10d220024ac521d2fce34e0eb90af7bee01d1da408082bfa724ac61e59709a860 SHA512 1550883232bff21217fc0d294598d6d828e67a944fc69b324079e87bf2505344c58ade75cec8bff1dca7821c4f490c066f2645281cee0e71792d317ef7df3779
DIST kitty-0.14.6.tar.xz 2970008 BLAKE2B e4f64051aebcc5d5aa1956351acb5564815e65c7c8435cac3c7960c5096fbeb5f0e98e3bdf92e750e8d70d6b0124b081bbb5d38a589c3dc5cf74642c3eaf83c9 SHA512 889bfce732f2a36d338c9c41b28e0770d98c15530b56a9f037cef610593b50453f1bde60e89560472035fc250dec0431a9776de1449f77e4c6988aca157eea12
diff --git a/x11-terms/kitty/kitty-0.14.2.ebuild b/x11-terms/kitty/kitty-0.14.2.ebuild
deleted file mode 100644
index 9973e320b0b7..000000000000
--- a/x11-terms/kitty/kitty-0.14.2.ebuild
+++ /dev/null
@@ -1,107 +0,0 @@
-# Copyright 1999-2019 Gentoo Authors
-# Distributed under the terms of the GNU General Public License v2
-
-EAPI=6
-PYTHON_COMPAT=( python3_{6,7} )
-
-inherit python-single-r1 toolchain-funcs gnome2-utils
-
-if [[ ${PV} == "9999" ]] ; then
- EGIT_REPO_URI="https://github.com/kovidgoyal/kitty.git"
- inherit git-r3
-else
- SRC_URI="https://github.com/kovidgoyal/kitty/releases/download/v${PV}/${P}.tar.xz"
- KEYWORDS="~amd64 ~x86"
-fi
-
-DESCRIPTION="A modern, hackable, featureful, OpenGL-based terminal emulator"
-HOMEPAGE="https://github.com/kovidgoyal/kitty"
-
-LICENSE="GPL-3"
-SLOT="0"
-IUSE="debug doc imagemagick wayland"
-REQUIRED_USE="${PYTHON_REQUIRED_USE}"
-
-COMMON_DEPS="
- ${PYTHON_DEPS}
- >=media-libs/harfbuzz-1.5.0:=
- sys-apps/dbus
- sys-libs/zlib
- media-libs/libpng:0=
- media-libs/freetype:2
- media-libs/fontconfig
- x11-libs/libXcursor
- x11-libs/libXrandr
- x11-libs/libXi
- x11-libs/libXinerama
- x11-libs/libxkbcommon[X]
- x11-libs/libxcb[xkb]
- wayland? (
- dev-libs/wayland
- >=dev-libs/wayland-protocols-1.17
- )
-"
-RDEPEND="
- ${COMMON_DEPS}
- imagemagick? ( virtual/imagemagick-tools )
-"
-DEPEND="${RDEPEND}
- media-libs/mesa[X(+)]
- sys-libs/ncurses
- virtual/pkgconfig
-"
-[[ ${PV} == *9999 ]] && DEPEND+=" >=dev-python/sphinx-1.7[${PYTHON_USEDEP}]"
-
-PATCHES=(
- "${FILESDIR}"/${PN}-0.14.2-flags.patch
- "${FILESDIR}"/${PN}-0.11.0-svg-icon.patch
-)
-
-src_prepare() {
- default
-
- # disable wayland as required
- if ! use wayland; then
- sed -i "/'x11 wayland'/s/ wayland//" setup.py || die
- fi
-
- # respect doc dir
- sed -i "/htmldir =/s/appname/'${PF}'/" setup.py
-
- tc-export CC
-}
-
-doecho() {
- echo "$@"
- "$@" || die
-}
-
-src_compile() {
- doecho "${EPYTHON}" setup.py \
- --verbose $(usex debug --debug "") \
- --libdir-name $(get_libdir) \
- linux-package
-}
-
-src_test() {
- export KITTY_CONFIG_DIRECTORY=${T}
- "${EPYTHON}" test.py || die
-}
-
-src_install() {
- mkdir -p "${ED}"usr || die
- cp -r linux-package/* "${ED}usr" || die
- python_fix_shebang "${ED}"
-
- if ! use doc; then
- rm -r "${ED}"/usr/share/doc || die
- fi
-}
-
-pkg_postinst() {
- gnome2_icon_cache_update
-}
-
-pkg_postrm() {
- gnome2_icon_cache_update
-}