summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-09-05 02:54:43 -0400
committerIonen Wolkens <ionen@gentoo.org>2022-09-05 02:58:36 -0400
commit623ffd15805dd8f97716c16f2039297c1d548a50 (patch)
tree526dc7654bceeda45eb5f84cbb5c5ebbfa9cc2a6 /x11-terms
parentx11-terms/kitty-shell-integration: add 0.26.2 (diff)
downloadgentoo-623ffd15805dd8f97716c16f2039297c1d548a50.tar.gz
gentoo-623ffd15805dd8f97716c16f2039297c1d548a50.tar.bz2
gentoo-623ffd15805dd8f97716c16f2039297c1d548a50.zip
x11-terms/kitty-terminfo: add 0.26.2
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/kitty-terminfo/Manifest1
-rw-r--r--x11-terms/kitty-terminfo/kitty-terminfo-0.26.2.ebuild23
2 files changed, 24 insertions, 0 deletions
diff --git a/x11-terms/kitty-terminfo/Manifest b/x11-terms/kitty-terminfo/Manifest
index 7aad4eb0c34b..dff417b1881c 100644
--- a/x11-terms/kitty-terminfo/Manifest
+++ b/x11-terms/kitty-terminfo/Manifest
@@ -1,2 +1,3 @@
DIST kitty-0.25.2.tar.xz 4681940 BLAKE2B 9aa43711c833541f364100465dfd1c13251ed59d5777634a5f193cc0544743295a772de85c64b4657e2cbca3d88f77019b0fe26b25c8b0908c1cc108b480ecf6 SHA512 ac858b525abbdeb137989a7971c51651d46bffedde048ed572bbb4c31119a4e0f9f424edbdbfd14fe2e043b4a7c8a1a1f8ee6591906e40a655d9f783b21f31a6
DIST kitty-0.26.1.tar.xz 4716836 BLAKE2B 1369fe3bb13fc5fb134c5b45f179ddd60b4edb61243d88aa08d8b414b4153b17e5c739859c9ed2db366e096db1b07e207cbef715d95787722037ddf5854582e1 SHA512 ed270c84078acb33921506296c476ada5f19fb33344047c7dad5b2d7b697c2111e2925dc391eb4927a05ef82ae583b35db5eee53e148e3e4d71ce942a1deade2
+DIST kitty-0.26.2.tar.xz 4716932 BLAKE2B fbbd1bbeb42bfb5be1348ead4605d45f93a90e31e707444c901b9f4c20b42d470c1e3cec9e0f135f04ad49bb472824fb7445932403127e8cbc639b5dac6ee982 SHA512 4bfb3d9438bb018dc10503be610df4e6e8bb1f9459b5131f46fde6279ba5423e44dbbcb86a2dc2602ee208266edc78074f6496e99761cf43f7081ea9e88175f7
diff --git a/x11-terms/kitty-terminfo/kitty-terminfo-0.26.2.ebuild b/x11-terms/kitty-terminfo/kitty-terminfo-0.26.2.ebuild
new file mode 100644
index 000000000000..35ff98034a87
--- /dev/null
+++ b/x11-terms/kitty-terminfo/kitty-terminfo-0.26.2.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Terminfo for kitty, a GPU-based terminal emulator"
+HOMEPAGE="https://sw.kovidgoyal.net/kitty/"
+SRC_URI="https://github.com/kovidgoyal/kitty/releases/download/v${PV}/kitty-${PV}.tar.xz"
+S="${WORKDIR}/kitty-${PV}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+RESTRICT="test" # intended to be ran on the full kitty package
+
+BDEPEND="sys-libs/ncurses"
+
+src_compile() { :; }
+
+src_install() {
+ dodir /usr/share/terminfo
+ tic -xo "${ED}"/usr/share/terminfo terminfo/kitty.terminfo || die
+}