summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2021-10-27 03:32:14 -0400
committerIonen Wolkens <ionen@gentoo.org>2021-11-03 02:36:50 -0400
commit6e53715787c0e45d593029ae388501df6d13e7ef (patch)
tree127decbd246e7d0f6bf825464d7747a12f820d6d /x11-terms
parentx11-terms/kitty-terminfo: mark ALLARCHES (diff)
downloadgentoo-6e53715787c0e45d593029ae388501df6d13e7ef.tar.gz
gentoo-6e53715787c0e45d593029ae388501df6d13e7ef.tar.bz2
gentoo-6e53715787c0e45d593029ae388501df6d13e7ef.zip
x11-terms/kitty-terminfo: simplify ebuild, skip private terminfo
There's no need to use setup.py, patch, and handle python deps just to run a single tic command (does emit a "new" warning because build-terminfo formerly expected and silenced it). This formerly installed in both /usr/share/terminfo and /usr/lib64/kitty. The latter does not make sense on a system where kitty is not installed, i.e. where terminfo is being installed for using kitty over ssh or similar. Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/kitty-terminfo/kitty-terminfo-0.23.1-r1.ebuild23
1 files changed, 23 insertions, 0 deletions
diff --git a/x11-terms/kitty-terminfo/kitty-terminfo-0.23.1-r1.ebuild b/x11-terms/kitty-terminfo/kitty-terminfo-0.23.1-r1.ebuild
new file mode 100644
index 000000000000..1a17886e2a00
--- /dev/null
+++ b/x11-terms/kitty-terminfo/kitty-terminfo-0.23.1-r1.ebuild
@@ -0,0 +1,23 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Terminfo for kitty, a GPU-based terminal emulator"
+HOMEPAGE="https://sw.kovidgoyal.net/kitty/"
+SRC_URI="https://github.com/kovidgoyal/kitty/releases/download/v${PV}/kitty-${PV}.tar.xz"
+S="${WORKDIR}/kitty-${PV}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test" # intended to be ran on the full kitty package
+
+BDEPEND="sys-libs/ncurses"
+
+src_compile() { :; }
+
+src_install() {
+ dodir /usr/share/terminfo
+ tic -xo "${ED}"/usr/share/terminfo terminfo/kitty.terminfo || die
+}