summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-02-27 23:59:20 -0500
committerIonen Wolkens <ionen@gentoo.org>2022-02-28 03:25:48 -0500
commit8bfd2f82b8ab2389fdb94d359a4b27f392b994b7 (patch)
treeedd33e8b48344bb77572088da9632b6ac132a43e /x11-terms
parentdev-db/qt5-sqlcipher: Drop an upstream warning message (diff)
downloadgentoo-8bfd2f82b8ab2389fdb94d359a4b27f392b994b7.tar.gz
gentoo-8bfd2f82b8ab2389fdb94d359a4b27f392b994b7.tar.bz2
gentoo-8bfd2f82b8ab2389fdb94d359a4b27f392b994b7.zip
x11-terms/kitty-shell-integration: add 0.24.3
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/kitty-shell-integration/Manifest1
-rw-r--r--x11-terms/kitty-shell-integration/kitty-shell-integration-0.24.3.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/x11-terms/kitty-shell-integration/Manifest b/x11-terms/kitty-shell-integration/Manifest
index 5980c6630eec..bc771a54cde8 100644
--- a/x11-terms/kitty-shell-integration/Manifest
+++ b/x11-terms/kitty-shell-integration/Manifest
@@ -1 +1,2 @@
DIST kitty-0.24.2.tar.xz 4601672 BLAKE2B 6e253863d81f2ef04f5d185cfe4379fe08818992a12a06da2ce2b0958912c4a0dc164b2ac6e8e74e383716e7040b2390bd1123ab4d8d282ede602dfea5cc756f SHA512 6d49b20dbd96ed0a1ed49a4523b65593c547ea2fec46f4c2557e26cdb5048ebaadb2c2118c7a2dd346f83ecab2d0a341d2322ae37ebe49184e22055581c631e7
+DIST kitty-0.24.3.tar.xz 4614252 BLAKE2B 04c9904e20aae0ed12d41dc01ea4fbb5e36430e50087821845c0bd3e6d8dd0ab2a090f8ebff8fd66fe9f2b0a3efe52f0434008b4484cbe27a58b05c6e4f56d73 SHA512 2b1482164fb1aabfa2f775f24d0ffbbbd1e8a85cf114a2daa411379ea8dbcea6ae5f361997132fb4d773fed8adeec4c04ffb4e615a470cefeb794d8a39c94c0a
diff --git a/x11-terms/kitty-shell-integration/kitty-shell-integration-0.24.3.ebuild b/x11-terms/kitty-shell-integration/kitty-shell-integration-0.24.3.ebuild
new file mode 100644
index 000000000000..80e3667e6412
--- /dev/null
+++ b/x11-terms/kitty-shell-integration/kitty-shell-integration-0.24.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Shell integration scripts for kitty, a GPU-based terminal emulator"
+HOMEPAGE="https://sw.kovidgoyal.net/kitty/"
+SRC_URI="https://github.com/kovidgoyal/kitty/releases/download/v${PV}/kitty-${PV}.tar.xz"
+S="${WORKDIR}/kitty-${PV}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+RESTRICT="test" # intended to be ran on the full kitty package
+
+src_compile() { :; }
+
+src_install() {
+ # install the whole directory in the upstream suggested location
+ # for consistency (i.e. less variation between distros if someone
+ # ssh into Gentoo), then set symlinks to autoload where possible
+ # (these exit immediately if KITTY_SHELL_INTEGRATION is unset)
+ insinto /usr/share/kitty
+ doins -r shell-integration
+
+ dosym -r {/usr/share/kitty/shell-integration/bash,/etc/bash/bashrc.d}/kitty.bash
+
+ dosym -r /usr/share/{kitty/shell-integration/fish,fish}/vendor_completions.d/kitty.fish
+ dosym -r /usr/share/{kitty/shell-integration/fish,fish}/vendor_conf.d/kitty-shell-integration.fish
+
+ dosym -r /usr/share/{kitty/shell-integration/zsh/completions,zsh/site-functions}/_kitty
+ # zsh integration is handled automatically without needing to modify rc files,
+ # but may require user intervention depending on zsh invocation or if remote
+}