summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDennis Eisele <kernlpanic@dennis-eisele.de>2022-01-16 20:36:00 +0100
committerSam James <sam@gentoo.org>2022-01-20 14:29:50 +0000
commit8f320df4d0f9df3318006c4b6aef49bb7805a87e (patch)
tree6b91efad021b8ad8d394b41e19eff3d7ffacbb11 /x11-terms
parentmedia-sound/flacon: fix virtx call (diff)
downloadgentoo-8f320df4d0f9df3318006c4b6aef49bb7805a87e.tar.gz
gentoo-8f320df4d0f9df3318006c4b6aef49bb7805a87e.tar.bz2
gentoo-8f320df4d0f9df3318006c4b6aef49bb7805a87e.zip
x11-terms/tilda: bump to version 1.5.4
Closes: https://bugs.gentoo.org/767235 Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Dennis Eisele <kernlpanic@dennis-eisele.de> Closes: https://github.com/gentoo/gentoo/pull/23820 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/tilda/Manifest1
-rw-r--r--x11-terms/tilda/tilda-1.5.4.ebuild32
2 files changed, 33 insertions, 0 deletions
diff --git a/x11-terms/tilda/Manifest b/x11-terms/tilda/Manifest
index d3c3f650a476..61d79a84567e 100644
--- a/x11-terms/tilda/Manifest
+++ b/x11-terms/tilda/Manifest
@@ -1 +1,2 @@
DIST tilda-1.5.2.tar.gz 485261 BLAKE2B 2ce0059ad695ac3e920cf8e40841b850967ff1e05b88a1c527b7154112c88a3435b66d0f31b882b6fdaf0dee038b7a7e6ab0401184ab701bed8d23d44a2856d8 SHA512 5f950696626005d6f8711fe1403313b36f065796ac07946e9782997aaf67a4bfdb3bfa5e37889bff95d77655d3546100a48327bfa175aa24c39a28685ee0306a
+DIST tilda-1.5.4.tar.gz 485611 BLAKE2B beced68e0712fdc3f4f46a1d839a87e91ecf7e84dec500908efa510d7b43d0c0bf6b5e296c3df255ea462cf08f5107aa324d5a0a6abb134917a054366912a068 SHA512 6982a14a89d148c04e08df0c7566ea7b3e340252fa1a3e434450443f7464e6805caee46afda9b385633a4b9c22d2f2d283641082a1e009f301c3a1bf508c3b29
diff --git a/x11-terms/tilda/tilda-1.5.4.ebuild b/x11-terms/tilda/tilda-1.5.4.ebuild
new file mode 100644
index 000000000000..8a62f1c1038e
--- /dev/null
+++ b/x11-terms/tilda/tilda-1.5.4.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools flag-o-matic
+
+DESCRIPTION="A drop down terminal, similar to the consoles found in first person shooters"
+HOMEPAGE="https://github.com/lanoxx/tilda"
+SRC_URI="https://github.com/lanoxx/tilda/archive/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~ppc ~ppc64 ~x86 ~amd64-linux ~x86-linux"
+
+RDEPEND="x11-libs/vte:2.91
+ >=dev-libs/glib-2.8.4:2
+ dev-libs/confuse:=
+ gnome-base/libglade
+ x11-libs/gtk+:3
+ x11-libs/libX11"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig
+ sys-devel/gettext"
+
+S="${WORKDIR}/${PN}-${P}"
+
+src_prepare() {
+ default
+ append-cflags -std=c99
+ eautoreconf
+}