summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIonen Wolkens <ionen@gentoo.org>2022-01-06 03:59:20 -0500
committerIonen Wolkens <ionen@gentoo.org>2022-01-06 04:10:03 -0500
commit8f9042abd1306c20fa7c33090af24d483ad7488c (patch)
tree557d8316cbc3b640396428f034fab1537ebf4a4e /x11-terms
parentx11-terms/kitty-terminfo: add 0.24.1 (diff)
downloadgentoo-8f9042abd1306c20fa7c33090af24d483ad7488c.tar.gz
gentoo-8f9042abd1306c20fa7c33090af24d483ad7488c.tar.bz2
gentoo-8f9042abd1306c20fa7c33090af24d483ad7488c.zip
x11-terms/kitty-shell-integration: add 0.24.1
Signed-off-by: Ionen Wolkens <ionen@gentoo.org>
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/kitty-shell-integration/Manifest1
-rw-r--r--x11-terms/kitty-shell-integration/kitty-shell-integration-0.24.1.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/x11-terms/kitty-shell-integration/Manifest b/x11-terms/kitty-shell-integration/Manifest
index 23dfe1ff9b95..3e9d8a94f3a8 100644
--- a/x11-terms/kitty-shell-integration/Manifest
+++ b/x11-terms/kitty-shell-integration/Manifest
@@ -1 +1,2 @@
DIST kitty-0.24.0.tar.xz 4503616 BLAKE2B 5a42b4815d25ff9e3a1f9fb6673e4e58ec3b59b5f81dc4098ef24408580d070e92a181e84167f5a343ffc3a9af33556823153d463eaa8e406f31c032ed8bab37 SHA512 b851ed56d16f9a39d47810bf27c2bc8cbb52d476376c4090045db90c1ad0bc7db6fd9e97edd6ce50a6d69e716671e1e909aab889ecac368857ad5c07f68a76af
+DIST kitty-0.24.1.tar.xz 4512652 BLAKE2B ea1bf4911a744fb5aaa5fe3d9fc4821880e78c60a0a89ecba12c73623b9b537c2d9d4e494da125669f2fc36f273f49a00cc5825f56184c1b0c69f4c570b2226d SHA512 e590a3abd4ed38ce956ee1e1b9d3679150c83b80df5ed9daf9773d7a278f63dc8a3a563058906d322f9186bece7d479036a502864fd80f45593c4970c056f389
diff --git a/x11-terms/kitty-shell-integration/kitty-shell-integration-0.24.1.ebuild b/x11-terms/kitty-shell-integration/kitty-shell-integration-0.24.1.ebuild
new file mode 100644
index 000000000000..fc3c61131372
--- /dev/null
+++ b/x11-terms/kitty-shell-integration/kitty-shell-integration-0.24.1.ebuild
@@ -0,0 +1,34 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="Shell integration scripts for kitty, a GPU-based terminal emulator"
+HOMEPAGE="https://sw.kovidgoyal.net/kitty/"
+SRC_URI="https://github.com/kovidgoyal/kitty/releases/download/v${PV}/kitty-${PV}.tar.xz"
+S="${WORKDIR}/kitty-${PV}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+RESTRICT="test" # intended to be ran on the full kitty package
+
+src_compile() { :; }
+
+src_install() {
+ # install the whole directory in the upstream suggested location
+ # for consistency (i.e. less variation between distros if someone
+ # ssh into Gentoo), then set symlinks to autoload where possible
+ # (these exit immediately if KITTY_SHELL_INTEGRATION is unset)
+ insinto /usr/share/kitty
+ doins -r shell-integration
+
+ dosym -r {/usr/share/kitty/shell-integration/bash,/etc/bash/bashrc.d}/kitty.bash
+
+ dosym -r /usr/share/{kitty/shell-integration/fish,fish}/vendor_completions.d/kitty.fish
+ dosym -r /usr/share/{kitty/shell-integration/fish,fish}/vendor_conf.d/kitty-shell-integration.fish
+
+ dosym -r /usr/share/{kitty/shell-integration/zsh/completions,zsh/site-functions}/_kitty
+ # zsh integration is handled automatically without needing to modify rc files,
+ # but may require user intervention depending on zsh invocation or if remote
+}