summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPablo <pord@tuta.io>2021-05-01 00:04:08 +0200
committerJoonas Niilola <juippis@gentoo.org>2021-05-10 11:06:32 +0300
commit9ba7d97069506167cef06c7a1f1ff4054f69e536 (patch)
tree23c784105d3c5299268a39872eec328984c1a0c7 /x11-terms
parentx11-terms/kitty: bump to 0.20.1 (diff)
downloadgentoo-9ba7d97069506167cef06c7a1f1ff4054f69e536.tar.gz
gentoo-9ba7d97069506167cef06c7a1f1ff4054f69e536.tar.bz2
gentoo-9ba7d97069506167cef06c7a1f1ff4054f69e536.zip
x11-terms/kitty-terminfo: bump to 0.20.1
Signed-off-by: Pablo Orduna <pabloorduna98@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/20478 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/kitty-terminfo/Manifest1
-rw-r--r--x11-terms/kitty-terminfo/files/kitty-terminfo-setup-0.20.1.patch (renamed from x11-terms/kitty-terminfo/files/kitty-terminfo-setup-9999.patch)0
-rw-r--r--x11-terms/kitty-terminfo/kitty-terminfo-0.20.1.ebuild41
-rw-r--r--x11-terms/kitty-terminfo/kitty-terminfo-9999.ebuild2
4 files changed, 43 insertions, 1 deletions
diff --git a/x11-terms/kitty-terminfo/Manifest b/x11-terms/kitty-terminfo/Manifest
index 5a886b4a8f4b..68abc25bf932 100644
--- a/x11-terms/kitty-terminfo/Manifest
+++ b/x11-terms/kitty-terminfo/Manifest
@@ -1 +1,2 @@
DIST kitty-0.19.3.tar.xz 3269628 BLAKE2B b3b673f8ad06baf770b03bcee87b2f405e1ff09d0fa5c6a232fd8df651351a428c8fbd9e2d0dc90ed44a0d6632192bea83650388ee73ebc3b523f51e51168006 SHA512 d1eea7f909c9492542650a83a149fd279c44380cf10387759f10caad57cd4dbabeac1ce84e8142bfa47266ec2562dfa3766ce08e2aee4d8e0ebacea165f101e4
+DIST kitty-0.20.1.tar.xz 3449932 BLAKE2B aed9a250fbc7005cd67fd22bfc33de845bea7e39a5561e6957b744f03a5438945f9739ca7066a93889144a5d0289185f337ef4d487c754cba37f242030f1c46a SHA512 19dfa66eb2a2115877b25fbff0ba7a81071bff00c732236f20342aeb619cca88ae4a4e8ce4e73908ac7d7d12fca5232a76e0167754f2e658af02e442cf5ba0cd
diff --git a/x11-terms/kitty-terminfo/files/kitty-terminfo-setup-9999.patch b/x11-terms/kitty-terminfo/files/kitty-terminfo-setup-0.20.1.patch
index 67772bfae03d..67772bfae03d 100644
--- a/x11-terms/kitty-terminfo/files/kitty-terminfo-setup-9999.patch
+++ b/x11-terms/kitty-terminfo/files/kitty-terminfo-setup-0.20.1.patch
diff --git a/x11-terms/kitty-terminfo/kitty-terminfo-0.20.1.ebuild b/x11-terms/kitty-terminfo/kitty-terminfo-0.20.1.ebuild
new file mode 100644
index 000000000000..aa1dee870988
--- /dev/null
+++ b/x11-terms/kitty-terminfo/kitty-terminfo-0.20.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{7,8} )
+
+inherit python-any-r1 toolchain-funcs xdg
+
+DESCRIPTION="Terminfo for kitty, an OpenGL-based terminal emulator"
+HOMEPAGE="https://github.com/kovidgoyal/kitty"
+SRC_URI="https://github.com/kovidgoyal/kitty/releases/download/v${PV}/kitty-${PV}.tar.xz"
+S="${WORKDIR}/kitty-${PV}"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="debug"
+
+DEPEND="${PYTHON_DEPS}"
+
+PATCHES=(
+ "${FILESDIR}"/kitty-terminfo-setup-0.20.1.patch
+)
+
+# kitty-terminfo is a split package from kitty that only installs the terminfo
+# file. As tests are designed to be run with the whole package compiled they
+# would fail in this case.
+RESTRICT="test"
+
+src_compile() {
+ "${EPYTHON}" setup.py \
+ --verbose $(usex debug --debug "") \
+ --libdir-name $(get_libdir) \
+ linux-terminfo || die "Failed to compile kitty."
+}
+
+src_install() {
+ insinto /usr
+ doins -r linux-package/*
+}
diff --git a/x11-terms/kitty-terminfo/kitty-terminfo-9999.ebuild b/x11-terms/kitty-terminfo/kitty-terminfo-9999.ebuild
index 29e70470581c..4a33e547ef85 100644
--- a/x11-terms/kitty-terminfo/kitty-terminfo-9999.ebuild
+++ b/x11-terms/kitty-terminfo/kitty-terminfo-9999.ebuild
@@ -18,7 +18,7 @@ IUSE="debug"
DEPEND="${PYTHON_DEPS}"
PATCHES=(
- "${FILESDIR}"/kitty-terminfo-setup-9999.patch
+ "${FILESDIR}"/kitty-terminfo-setup-0.20.1.patch
)
# kitty-terminfo is a split package from kitty that only installs the terminfo