summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gmail.com>2018-05-09 13:15:01 +0300
committerMichał Górny <mgorny@gentoo.org>2018-05-13 09:22:47 +0200
commit9caa16aecb15727af775e250abaf5b1595ba4e5b (patch)
treed4b7a144792205bb0964ca0ea589adfebe916ee1 /x11-terms
parentapp-backup/bareos: Drop Qt4-based (diff)
downloadgentoo-9caa16aecb15727af775e250abaf5b1595ba4e5b.tar.gz
gentoo-9caa16aecb15727af775e250abaf5b1595ba4e5b.tar.bz2
gentoo-9caa16aecb15727af775e250abaf5b1595ba4e5b.zip
x11-terms/terminology: bump to 1.2.0
Added myself as proxy-maintainer for this package. Added nls use flag. Updated HOMEPAGE. Closes: https://bugs.gentoo.org/631580 Closes: https://github.com/gentoo/gentoo/pull/8326
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/terminology/Manifest1
-rw-r--r--x11-terms/terminology/metadata.xml8
-rw-r--r--x11-terms/terminology/terminology-1.2.0.ebuild30
3 files changed, 38 insertions, 1 deletions
diff --git a/x11-terms/terminology/Manifest b/x11-terms/terminology/Manifest
index e322ba7d3ad8..8233d7b6ceb9 100644
--- a/x11-terms/terminology/Manifest
+++ b/x11-terms/terminology/Manifest
@@ -1,2 +1,3 @@
DIST terminology-0.9.1.tar.xz 4961876 BLAKE2B 03aab7c5c0740bede4c06b90721d96c121500009b6dd939387e8bd3dae160b4c705cf95a724dd8cc404badc9b9d5f22a5321312f229dd488331e4c4c1e2b0844 SHA512 c6db9fa62f3f168be635da1e3ed7a13deba13cbfa5bed75e3f97ee6e13837ca9cb5facab48c44f200baed34b8f32f852eadd9844de648795733602602fae32fd
DIST terminology-1.0.0.tar.xz 4979420 BLAKE2B cbc78b751a2e6812ab31c69a62ea4abe2bb53f12b647cea7adae03e54fe0a238c56c5c029c43057c3a1326c7c8af0412574a85a404896554a142ed068ab581ab SHA512 5c99e1e1eea0de24d67779059d3ba65a8fbd1fdf63d9f22099e38defc11fdc8923fbe50a7276bc483ce5ee7527f665e3f2c48358d85c3a06f33e551bd8ef2320
+DIST terminology-1.2.0.tar.xz 4858040 BLAKE2B 831ea173fcf8d0327e5ea6a64a827e221eeef5125a7ed6722cc479ff1e3649b653908f97dd5478b24e13463b53634aba14786f9d39da6ad8ba64b982f28f2d7c SHA512 3f017d4706de0de7de5800adad39b5d168f4447279942a452b98529044d3c5e88fc00aa96078420829283ddc454d85d7e5b1d8b557a38d5be8ad266020a3f40b
diff --git a/x11-terms/terminology/metadata.xml b/x11-terms/terminology/metadata.xml
index 6f49eba8f496..d9a6217dd22d 100644
--- a/x11-terms/terminology/metadata.xml
+++ b/x11-terms/terminology/metadata.xml
@@ -1,5 +1,11 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<!-- maintainer-needed -->
+ <maintainer type="person">
+ <email>juippis@gmail.com</email>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
</pkgmetadata>
diff --git a/x11-terms/terminology/terminology-1.2.0.ebuild b/x11-terms/terminology/terminology-1.2.0.ebuild
new file mode 100644
index 000000000000..30208be73e72
--- /dev/null
+++ b/x11-terms/terminology/terminology-1.2.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit meson
+
+DESCRIPTION="Feature rich terminal emulator using the Enlightenment Foundation Libraries"
+HOMEPAGE="https://www.enlightenment.org/about-terminology"
+SRC_URI="https://download.enlightenment.org/rel/apps/${PN}/${P}.tar.xz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="nls"
+
+RDEPEND=">=dev-libs/efl-1.20.0[eet,fontconfig,opengl,X]"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+"
+
+src_configure() {
+ local emesonargs=(
+ -D nls=$(usex nls true false)
+ )
+
+ meson_src_configure
+}