summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Coppens <coppens.matthias.abc@gmail.com>2021-01-29 16:26:10 +0100
committerJoonas Niilola <juippis@gentoo.org>2021-02-02 14:47:49 +0200
commita3b7507dd5e7dde6c5ea7fb61920ee9e91ea9576 (patch)
tree5b5c52d1e8f170556fafd10c205bbf76db8080fb /x11-terms
parentapp-emulation/crun: drop 0.15 (diff)
downloadgentoo-a3b7507dd5e7dde6c5ea7fb61920ee9e91ea9576.tar.gz
gentoo-a3b7507dd5e7dde6c5ea7fb61920ee9e91ea9576.tar.bz2
gentoo-a3b7507dd5e7dde6c5ea7fb61920ee9e91ea9576.zip
x11-terms/kitty: Fix broken patch for -9999
Closes: https://bugs.gentoo.org/767457 Package-Manager: Portage-3.0.14, Repoman-3.0.2 Signed-off-by: Matthias Coppens <coppens.matthias.abc@gmail.com> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/kitty/files/kitty-9999-remove-terminfo.patch16
-rw-r--r--x11-terms/kitty/kitty-9999.ebuild4
2 files changed, 18 insertions, 2 deletions
diff --git a/x11-terms/kitty/files/kitty-9999-remove-terminfo.patch b/x11-terms/kitty/files/kitty-9999-remove-terminfo.patch
new file mode 100644
index 000000000000..aeb40e601185
--- /dev/null
+++ b/x11-terms/kitty/files/kitty-9999-remove-terminfo.patch
@@ -0,0 +1,16 @@
+diff --git a/setup.py b/setup.py
+index ce5309ee..02f38c61 100755
+--- a/setup.py
++++ b/setup.py
+@@ -1028,11 +1028,6 @@ def package(args: Options, bundle_type: str) -> None:
+ safe_makedirs(launcher_dir)
+ build_launcher(args, launcher_dir, bundle_type)
+ os.makedirs(os.path.join(libdir, 'logo'))
+- build_terminfo = runpy.run_path('build-terminfo', run_name='import_build') # type: ignore
+- for x in (libdir, os.path.join(ddir, 'share')):
+- odir = os.path.join(x, 'terminfo')
+- safe_makedirs(odir)
+- build_terminfo['compile_terminfo'](odir)
+ shutil.copy2('__main__.py', libdir)
+ shutil.copy2('logo/kitty-128.png', os.path.join(libdir, 'logo'))
+ shutil.copy2('logo/kitty.png', os.path.join(libdir, 'logo'))
diff --git a/x11-terms/kitty/kitty-9999.ebuild b/x11-terms/kitty/kitty-9999.ebuild
index 9b101e5a8027..caaf77a28e9f 100644
--- a/x11-terms/kitty/kitty-9999.ebuild
+++ b/x11-terms/kitty/kitty-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -57,7 +57,7 @@ BDEPEND="virtual/pkgconfig"
PATCHES=(
"${FILESDIR}"/kitty-0.17.2-flags.patch
- "${FILESDIR}"/kitty-0.16.0-remove-terminfo.patch
+ "${FILESDIR}"/${P}-remove-terminfo.patch
"${FILESDIR}"/${PN}-0.14.4-svg-icon.patch
)