summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-06-08 09:06:59 +0000
committerSam James <sam@gentoo.org>2021-06-08 09:07:05 +0000
commitb5be58aef6a85bf3ef6d7d54189aa0dd4d4b322a (patch)
treee705b1b5779965b4bef0908fb6393673cfa6eefc /x11-terms
parentmedia-sound/awesfx: bump to 0.5.2 (diff)
downloadgentoo-b5be58aef6a85bf3ef6d7d54189aa0dd4d4b322a.tar.gz
gentoo-b5be58aef6a85bf3ef6d7d54189aa0dd4d4b322a.tar.bz2
gentoo-b5be58aef6a85bf3ef6d7d54189aa0dd4d4b322a.zip
x11-terms/xterm: add 368
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/xterm/Manifest1
-rw-r--r--x11-terms/xterm/xterm-368.ebuild99
2 files changed, 100 insertions, 0 deletions
diff --git a/x11-terms/xterm/Manifest b/x11-terms/xterm/Manifest
index 990bc7177909..f71b6dbca56c 100644
--- a/x11-terms/xterm/Manifest
+++ b/x11-terms/xterm/Manifest
@@ -1,2 +1,3 @@
DIST xterm-366.tgz 1445992 BLAKE2B 4724851b84ae0682b39e5f1b070ba9f04c627511aa20a5b1c76e740666e14436a0095d8a1be4f6ad54eb1e5d841ef766b0bf4d840ebddcaea0889285f1377900 SHA512 ffab7e0970b92a25488bd57da2dfe2856279208c489a632e0e92788deec2a4f99510f76e1c88e55f389dfe984c323add0fab31b04d2a1d774ce6d3b2c9c642ef
DIST xterm-367.tgz 1448562 BLAKE2B 29b38ba3b48c843ecbf22d209a05afb4e9a6d52cf8f14efa18ed5dd02b26cc11c107bfb17260cb62f68fc318cb08e5147b5f12e8779ca63151c7b712ada60b7e SHA512 86fd6ed4e4aa0201349edd67d8bf00d3b93a19640307372011f9bdcd26fdb453267d1ab092a0639902e419b00c175d793b196884b6e65e546650e1b83a4461c4
+DIST xterm-368.tgz 1451700 BLAKE2B 3fe939b8248e8839ba8b73b0971ab380e5f6528f51bd1993cc26d53755177fd5537cdbf2044f7fedad20663b3a7b42bc7f8b1c138233d44eb91472840f8448e1 SHA512 ea2f27722795c47a406cf4956ecdd05bae19aee621a0183aa167d188a90767a859ce41c6d1b1352b5ebd94d920360d3f26248ec0bb2068c253583d460baeafda
diff --git a/x11-terms/xterm/xterm-368.ebuild b/x11-terms/xterm/xterm-368.ebuild
new file mode 100644
index 000000000000..360ff3a47763
--- /dev/null
+++ b/x11-terms/xterm/xterm-368.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop flag-o-matic toolchain-funcs
+
+DESCRIPTION="Terminal Emulator for X Windows"
+HOMEPAGE="https://invisible-island.net/xterm/"
+SRC_URI="ftp://ftp.invisible-island.net/${PN}/${P}.tgz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="+openpty sixel toolbar truetype unicode Xaw3d xinerama"
+
+BDEPEND="virtual/pkgconfig
+ x11-base/xorg-proto"
+DEPEND="kernel_linux? ( sys-libs/libutempter )
+ kernel_FreeBSD? ( sys-libs/libutempter )
+ media-libs/fontconfig:1.0
+ >=sys-libs/ncurses-5.7-r7:0=
+ x11-apps/xmessage
+ x11-libs/libICE
+ x11-libs/libX11
+ x11-libs/libXaw
+ x11-libs/libXft
+ x11-libs/libxkbfile
+ x11-libs/libXmu
+ x11-libs/libXrender
+ x11-libs/libXt
+ unicode? ( x11-apps/luit )
+ Xaw3d? ( x11-libs/libXaw3d )
+ xinerama? ( x11-libs/libXinerama )"
+RDEPEND="${DEPEND}
+ media-fonts/font-misc-misc
+ x11-apps/rgb"
+
+DOCS=( README{,.i18n} ctlseqs.txt )
+
+pkg_setup() {
+ DEFAULTS_DIR="${EPREFIX}"/usr/share/X11/app-defaults
+}
+
+src_configure() {
+ # 454736
+ # Workaround for ncurses[tinfo] until upstream fixes their buildsystem using
+ # something sane like pkg-config or ncurses5-config and stops guessing libs
+ # Everything gets linked against ncurses anyways, so don't shout
+ append-libs $($(tc-getPKG_CONFIG) --libs ncurses)
+
+ local myeconfargs=(
+ --disable-full-tgetent
+ --disable-imake
+ --disable-setgid
+ --disable-setuid
+ --enable-256-color
+ --enable-broken-osc
+ --enable-broken-st
+ --enable-dabbrev
+ --enable-exec-xterm
+ --enable-i18n
+ --enable-load-vt-fonts
+ --enable-logging
+ --enable-screen-dumps
+ --enable-warnings
+ --enable-wide-chars
+ --libdir="${EPREFIX}"/etc
+ --with-app-defaults="${DEFAULTS_DIR}"
+ --with-utempter
+ --with-x
+ $(use_enable openpty)
+ $(use_enable sixel sixel-graphics)
+ $(use_enable toolbar)
+ $(use_enable truetype freetype)
+ $(use_enable unicode luit)
+ $(use_enable unicode mini-luit)
+ $(use_with Xaw3d)
+ $(use_with xinerama)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ docinto html
+ dodoc xterm.log.html
+ domenu *.desktop
+
+ # Fix permissions -- it grabs them from live system, and they can
+ # be suid or sgid like they were in pre-unix98 pty or pre-utempter days,
+ # respectively (#69510).
+ # (info from Thomas Dickey) - Donnie Berkholz <spyderous@gentoo.org>
+ fperms 0755 /usr/bin/xterm
+
+ # restore the navy blue
+ sed -i -e 's:blue2$:blue:' "${D}${DEFAULTS_DIR}"/XTerm-color || die
+}