summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJoonas Niilola <juippis@gentoo.org>2019-11-17 08:43:40 +0200
committerJoonas Niilola <juippis@gentoo.org>2019-11-17 09:45:46 +0200
commitbf796bde235b823ff0c9174c08d169b3131bb835 (patch)
tree938df84ec31c421cdeed1a59a56cdc9f75fbfc6e /x11-terms
parentapp-admin/fluentd: add ruby26 (diff)
downloadgentoo-bf796bde235b823ff0c9174c08d169b3131bb835.tar.gz
gentoo-bf796bde235b823ff0c9174c08d169b3131bb835.tar.bz2
gentoo-bf796bde235b823ff0c9174c08d169b3131bb835.zip
x11-terms/terminology: bump to 1.6.0
Package-Manager: Portage-2.3.79, Repoman-2.3.17 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/terminology/Manifest1
-rw-r--r--x11-terms/terminology/terminology-1.6.0.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/x11-terms/terminology/Manifest b/x11-terms/terminology/Manifest
index 3ccfc33bec1c..be7e637d77a7 100644
--- a/x11-terms/terminology/Manifest
+++ b/x11-terms/terminology/Manifest
@@ -1 +1,2 @@
DIST terminology-1.5.0.tar.xz 4884284 BLAKE2B fff45958207bd6e06b8685ebe42ca734b183da9042940b773e15308200c27307f417a930a687c187a5f24f1eab9d1b7a518314b3cd919d260bb05369a2f2236c SHA512 ade2363e0a834b25a67157d0cfa946b3b09d8a2941fd7da9dd3792cf8d201f218c7723b691eab325d9bdadeefddfea56c19e562ebc37466cb3a9b3b45c9f708b
+DIST terminology-1.6.0.tar.xz 4893348 BLAKE2B 20c9b8a916a4cd48055839266a157d5d8fca70557f7fb8b61696ceeaf4bc0fd93ea5abc0930d1c552a816e3fa3e455624f62d4adbad7feacc9cd0e874a91feec SHA512 ef95a5d128736a2e6b3b9e48a3f32a8e3a1f19ccabcb9fa429ed777ee201ba16fa431a61edafaebc018567f4a3657d81551407cf0449f58b416aa1e6077afec1
diff --git a/x11-terms/terminology/terminology-1.6.0.ebuild b/x11-terms/terminology/terminology-1.6.0.ebuild
new file mode 100644
index 000000000000..65b045e742ae
--- /dev/null
+++ b/x11-terms/terminology/terminology-1.6.0.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson xdg-utils
+
+DESCRIPTION="Feature rich terminal emulator using the Enlightenment Foundation Libraries"
+HOMEPAGE="https://www.enlightenment.org/about-terminology"
+SRC_URI="https://download.enlightenment.org/rel/apps/${PN}/${P}.tar.xz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="extras nls"
+
+RDEPEND="
+ || ( dev-libs/efl[gles2] dev-libs/efl[opengl] )
+ || ( dev-libs/efl[X] dev-libs/efl[wayland] )
+ app-arch/lz4
+ dev-libs/efl[eet,fontconfig]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )
+"
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use nls)
+ $(meson_use extras tests)
+ )
+
+ meson_src_configure
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}