summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthew Smith <matt@offtopica.uk>2022-01-01 15:11:03 +0000
committerJoonas Niilola <juippis@gentoo.org>2022-01-21 08:33:25 +0200
commitc7b5d731d1f75172fd49b838e3b29a51b17b7e5a (patch)
tree3f8daca28e227219d13d6e69f8b0c31290c82fda /x11-terms
parentdev-python/sqlalchemy: Bump to 1.4.31 (diff)
downloadgentoo-c7b5d731d1f75172fd49b838e3b29a51b17b7e5a.tar.gz
gentoo-c7b5d731d1f75172fd49b838e3b29a51b17b7e5a.tar.bz2
gentoo-c7b5d731d1f75172fd49b838e3b29a51b17b7e5a.zip
x11-terms/zutty: add 0.11
- Add a comment on why we don't run the tests. - Remove default CXXFLAGS/LDFLAGS from wscript. Closes: https://bugs.gentoo.org/830405 Signed-off-by: Matthew Smith <matt@offtopica.uk> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/zutty/Manifest1
-rw-r--r--x11-terms/zutty/zutty-0.11-cxxflags.patch27
-rw-r--r--x11-terms/zutty/zutty-0.11.ebuild41
3 files changed, 69 insertions, 0 deletions
diff --git a/x11-terms/zutty/Manifest b/x11-terms/zutty/Manifest
index 6c7979a79c56..82bcff18958f 100644
--- a/x11-terms/zutty/Manifest
+++ b/x11-terms/zutty/Manifest
@@ -1,2 +1,3 @@
DIST zutty-0.10.tar.gz 336599 BLAKE2B 0041bbbc268ff042bac6bea1984ebf05d958f622b4c2e736bfe3d18e3a224238f27a7ef9920b8f7bc820705ce7560f20819650ec27fb3e5fc13dbef76fc6d0af SHA512 f499fb499779f8b5936a03c48e3c042f5fa0f0c99d3b24a4c9b963c2df8151561ac82456625d768e65f75aea641539a036300f1f99404eecfd15a0a25aeb6779
+DIST zutty-0.11.tar.gz 343469 BLAKE2B 9cd040e72d0ea76a526d099265b3a0974d40b1b8b679ff3baafc47f827b140943ac8bc13676831245e219ca1335ded7aca1e7826baf175fc63e88012791785e1 SHA512 84e8402a310adc80c698ded38fa3eb8ba44034f391e2538bccbdbc4082e239dc0d6ceb20504eeab4e5d2499ded55ef0941ae2e5d07eeb809d1059e5449cdb708
DIST zutty-0.9.tar.gz 336534 BLAKE2B 61d2ae02e2c0b08a9c536190f61f14300b0cd1bacb83f5da33e92a6c8502df6adda72805e58f3d679c7258c30338178b4488c0f7bfbfaf8b5e922401e6442427 SHA512 590cf090c0d80e683d4473828cdb8bbe4f60bc5bc3c5e9e63039a59757e281ecefc774709f08777fe36ab596fb102f392c8bf643449e62914e5b88d0ebc728c0
diff --git a/x11-terms/zutty/zutty-0.11-cxxflags.patch b/x11-terms/zutty/zutty-0.11-cxxflags.patch
new file mode 100644
index 000000000000..19b6649bb561
--- /dev/null
+++ b/x11-terms/zutty/zutty-0.11-cxxflags.patch
@@ -0,0 +1,27 @@
+From 06927a1f2f88bd9d5f4bb8056661ffbc4a0aeb77 Mon Sep 17 00:00:00 2001
+From: Matthew Smith <matt@offtopica.uk>
+Date: Wed, 19 Jan 2022 18:07:55 +0000
+Subject: [PATCH] Remove default CXXFLAGS and LINKFLAGS
+
+---
+ wscript | 4 ----
+ 1 file changed, 4 deletions(-)
+
+diff --git a/wscript b/wscript
+index d2bfbc8..b38b50b 100644
+--- a/wscript
++++ b/wscript
+@@ -69,10 +69,6 @@ def configure(cfg):
+ ['-DDEBUG', '-Og', '-g', '-ggdb'])
+ else:
+ cfg.env.target = 'zutty'
+- cfg.env.append_value('CXXFLAGS',
+- ['-Werror', '-O3', '-march=native', '-mtune=native', '-flto'])
+- cfg.env.append_value('LINKFLAGS',
+- ['-flto'])
+
+ cfg.check_cfg(package='freetype2', args=['--cflags', '--libs'],
+ uselib_store='FT')
+--
+2.34.1
+
diff --git a/x11-terms/zutty/zutty-0.11.ebuild b/x11-terms/zutty/zutty-0.11.ebuild
new file mode 100644
index 000000000000..9363c3151d1b
--- /dev/null
+++ b/x11-terms/zutty/zutty-0.11.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{8,9,10} )
+PYTHON_REQ_USE="threads(+)"
+
+inherit python-any-r1 waf-utils
+
+DESCRIPTION="X terminal emulator rendering through OpenGL ES Compute Shaders"
+HOMEPAGE="https://tomscii.sig7.se/zutty/ https://github.com/tomszilagyi/zutty"
+SRC_URI="https://github.com/tomszilagyi/zutty/archive/refs/tags/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# It is possible to run the tests using virtualx, but it seems to take
+# screenshots of the terminal window, and compares checksums that never
+# seem to match.
+RESTRICT="test"
+
+RDEPEND="
+ media-libs/freetype:2
+ virtual/opengl
+ x11-libs/libX11
+ x11-libs/libXmu
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ ${PYTHON_DEPS}
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ # Remove default CXX/LDFLAGS, bug #830405.
+ "${FILESDIR}"/${PN}-0.11-cxxflags.patch
+)
+
+DOCS=( doc/KEYS.org doc/USAGE.org )