summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPablo <pord@tuta.io>2021-01-10 22:31:38 +0100
committerSam James <sam@gentoo.org>2021-01-24 01:48:03 +0000
commitde469ed0fcba7a16cb84bf519650bfea6efb33ae (patch)
treef23f26bfc0bac23938df9ef1cd1d8fd07e2bb5be /x11-terms
parentnet-nntp/tin: security bump to 2.4.5 (diff)
downloadgentoo-de469ed0fcba7a16cb84bf519650bfea6efb33ae.tar.gz
gentoo-de469ed0fcba7a16cb84bf519650bfea6efb33ae.tar.bz2
gentoo-de469ed0fcba7a16cb84bf519650bfea6efb33ae.zip
x11-terms/kitty: bump to 0.19.3
Signed-off-by: Pablo Orduna <pabloorduna98@gmail.com> Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'x11-terms')
-rw-r--r--x11-terms/kitty/Manifest1
-rw-r--r--x11-terms/kitty/kitty-0.19.3.ebuild107
2 files changed, 108 insertions, 0 deletions
diff --git a/x11-terms/kitty/Manifest b/x11-terms/kitty/Manifest
index b600f93893c6..03046d626343 100644
--- a/x11-terms/kitty/Manifest
+++ b/x11-terms/kitty/Manifest
@@ -1,2 +1,3 @@
DIST kitty-0.19.1.tar.xz 3262516 BLAKE2B 82520e79125483a9e3b6592bdf38e782231934214a989fe44ad6c587a025338a98f1d09219a315dfbffc8264be5f5b2352db457b5e11edc2d08af594989a8092 SHA512 3a61d15598f32634646cbf0be596e9023420452130be1b9a718d2ce7daf3edeee6d2ba3abfe91c768758b043ed46423a2382680f9dd65fd6a6c57dbcd0fc1fd3
DIST kitty-0.19.2.tar.xz 3259928 BLAKE2B c6060a098df53e53cfd56f680f0972ee2a116c0d9ae8eabd2f087540f5f181a5980e2d963d27f24df5c57f6e81327591531397341e33b3d9bb4a2420138aa473 SHA512 86b6a08c7f5282587967ff7e3509d6ac4ef556b3bbeae1a9529a584f804f204d54f5031a90dcd08af735eb16a283938fa9e49c8d767dca12e945b7493f0e76da
+DIST kitty-0.19.3.tar.xz 3269628 BLAKE2B b3b673f8ad06baf770b03bcee87b2f405e1ff09d0fa5c6a232fd8df651351a428c8fbd9e2d0dc90ed44a0d6632192bea83650388ee73ebc3b523f51e51168006 SHA512 d1eea7f909c9492542650a83a149fd279c44380cf10387759f10caad57cd4dbabeac1ce84e8142bfa47266ec2562dfa3766ce08e2aee4d8e0ebacea165f101e4
diff --git a/x11-terms/kitty/kitty-0.19.3.ebuild b/x11-terms/kitty/kitty-0.19.3.ebuild
new file mode 100644
index 000000000000..ceb22a4934d6
--- /dev/null
+++ b/x11-terms/kitty/kitty-0.19.3.ebuild
@@ -0,0 +1,107 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6,7,8} )
+
+inherit optfeature python-single-r1 toolchain-funcs xdg
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/kovidgoyal/kitty.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/kovidgoyal/kitty/releases/download/v${PV}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="A modern, hackable, featureful, OpenGL-based terminal emulator"
+HOMEPAGE="https://github.com/kovidgoyal/kitty"
+
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="debug wayland"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ media-libs/fontconfig
+ media-libs/freetype:2
+ >=media-libs/harfbuzz-1.5.0:=
+ media-libs/lcms
+ media-libs/libcanberra
+ media-libs/libpng:0=
+ sys-apps/dbus
+ sys-libs/zlib
+ x11-libs/libxcb[xkb]
+ x11-libs/libXcursor
+ x11-libs/libXi
+ x11-libs/libXinerama
+ x11-libs/libxkbcommon[X]
+ x11-libs/libXrandr
+ x11-terms/kitty-terminfo
+ wayland? (
+ dev-libs/wayland
+ >=dev-libs/wayland-protocols-1.17
+ )
+ $(python_gen_cond_dep 'dev-python/importlib_resources[${PYTHON_USEDEP}]' python3_6)
+"
+
+DEPEND="${RDEPEND}
+ media-libs/mesa[X]
+ sys-libs/ncurses
+"
+
+BDEPEND="virtual/pkgconfig"
+
+[[ ${PV} == *9999 ]] && BDEPEND+=" >=dev-python/sphinx-1.7"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.17.2-flags.patch
+ "${FILESDIR}"/${PN}-0.14.4-svg-icon.patch
+ "${FILESDIR}"/${PN}-0.16.0-remove-terminfo.patch
+ "${FILESDIR}"/${PN}-0.19.1-tests.patch
+)
+
+src_prepare() {
+ default
+
+ # disable wayland as required
+ if ! use wayland; then
+ sed -i "/'x11 wayland'/s/ wayland//" setup.py || die
+ fi
+
+ # respect doc dir
+ sed -i "/htmldir =/s/appname/'${PF}'/" setup.py || die
+
+ tc-export CC
+}
+
+src_compile() {
+ "${EPYTHON}" setup.py \
+ --verbose $(usex debug --debug "") \
+ --libdir-name $(get_libdir) \
+ --update-check-interval=0 \
+ linux-package || die "Failed to compile kitty."
+}
+
+src_test() {
+ export KITTY_CONFIG_DIRECTORY=${T}
+ "${EPYTHON}" test.py || die
+}
+
+src_install() {
+ insinto /usr
+ doins -r linux-package/*
+ dobin linux-package/bin/kitty
+ python_fix_shebang "${ED}"
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ optfeature "Displaying images in the terminal" virtual/imagemagick-tools
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+}