summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJames Le Cuirot <chewi@gentoo.org>2021-10-23 09:11:01 +0100
committerJames Le Cuirot <chewi@gentoo.org>2021-10-23 09:11:01 +0100
commit10fcf2292113b898fa7396ea25423a85313eaba8 (patch)
tree08ef73e0017b0c6f874a96915ceefa9dea7bb9ef /x11-themes/arc-theme
parentwww-client/chromium: dev channel bump to 97.0.4676.0 (diff)
downloadgentoo-10fcf2292113b898fa7396ea25423a85313eaba8.tar.gz
gentoo-10fcf2292113b898fa7396ea25423a85313eaba8.tar.bz2
gentoo-10fcf2292113b898fa7396ea25423a85313eaba8.zip
x11-themes/arc-theme: Version bump to 20211018
This version supports GTK 4. Signed-off-by: James Le Cuirot <chewi@gentoo.org>
Diffstat (limited to 'x11-themes/arc-theme')
-rw-r--r--x11-themes/arc-theme/Manifest2
-rw-r--r--x11-themes/arc-theme/arc-theme-20211018.ebuild112
-rw-r--r--x11-themes/arc-theme/metadata.xml1
3 files changed, 115 insertions, 0 deletions
diff --git a/x11-themes/arc-theme/Manifest b/x11-themes/arc-theme/Manifest
index 256eebbbd470..ca8cccb0d922 100644
--- a/x11-themes/arc-theme/Manifest
+++ b/x11-themes/arc-theme/Manifest
@@ -1,2 +1,4 @@
DIST arc-theme-20210412-pngs.tar.xz 159340 BLAKE2B 40027335b8b44ae38bfadfa52e08858cf09646ed9c3e2fcddece8959d2f35845c4924002f36cea65cb27ecf61fdb3dffbf0d5c01024c34d16c31e21bf69b5a72 SHA512 85bdcd1fb81a5c33b479123bad178b1833a95ecf09310fa3b754c25f753ec10a7cada14983014b090c4a86d7a8497ac881fee9576737be29f4f772ccb59a8f1e
DIST arc-theme-20210412.tar.xz 257248 BLAKE2B c525c3632670d8aa6b640baa8b3dddca6c5dd5f087734604c68d9140f810fc595f73db06f93b6193ba1c59a8cd85b87f5f6fda9777940adf36f3c436a8426810 SHA512 d3064546301e013a1e5a8db735346d74c73f37cbf808b7afeee6f88c820cea58ba6458fa63e1213377cdd33c8347167242e6f8f1eacf85ce212f3b2508c0bb80
+DIST arc-theme-20211018-pngs.tar.xz 160836 BLAKE2B 4c2882ce03724c7abd8d4db31da82355d28b792a16648e010eca033f77d3ad6da8f7026e2562249caa993f2e8549191b6ec8d4473fbcab084ae3d91c468956c5 SHA512 6ac7bf27ebc258d0e2c2102ed286ba196d6f9c8343e1885d77d8f29cda0f8c247926003bd8c40165e08b9b3987f8a2f82800d509b78dd598d2e7ff8bea964831
+DIST arc-theme-20211018.tar.xz 271084 BLAKE2B dc8808a5c7a0444d5ac11fa213b99b9633691ad920a07820752974f98febd8bc112a34568c38d354558e7876182278603ab66ebf8e50aa51f5eba431bd6b3433 SHA512 da46efc0e38efb7f1d0cd9a5d2c4e8f00f3b8d408ec50c54d89ef67fc3bb5ea253b5fb890b0cb8e82cafebd44a599d0de2369272ed88da73dd979052b130bd55
diff --git a/x11-themes/arc-theme/arc-theme-20211018.ebuild b/x11-themes/arc-theme/arc-theme-20211018.ebuild
new file mode 100644
index 000000000000..3ea22d4a35e8
--- /dev/null
+++ b/x11-themes/arc-theme/arc-theme-20211018.ebuild
@@ -0,0 +1,112 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+# USE="-* gtk2 gtk3 gtk4 xfce" ebuild ${P}.ebuild clean compile
+# cd $(portageq envvar PORTAGE_TMPDIR)/portage/x11-themes/${P}/work
+# find ${P}-build/ -name "*.png" | xargs tar Jcvf /usr/portage/distfiles/${P}-pngs.tar.xz --owner=root --group=root
+
+inherit meson toolchain-funcs
+
+DESCRIPTION="A flat theme with transparent elements for GTK+3, GTK+2 and GNOME Shell"
+HOMEPAGE="https://github.com/jnsh/arc-theme"
+SRC_URI="https://github.com/jnsh/${PN}/releases/download/${PV}/arc-theme-${PV}.tar.xz
+ pre-rendered? ( https://dev.gentoo.org/~chewi/distfiles/${P}-pngs.tar.xz )"
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+IUSE="cinnamon gnome-shell +gtk2 +gtk3 +gtk4 mate +pre-rendered xfce"
+
+SASSC_DEPEND="
+ dev-lang/sassc
+"
+
+SVG_DEPEND="
+ !pre-rendered? (
+ media-gfx/inkscape
+ media-gfx/optipng
+ )
+"
+
+# Supports various GTK+3, GNOME Shell, and Cinnamon versions and uses
+# pkg-config to determine which set of files to build. Updates will
+# therefore break existing installs but there's no way around this. At
+# least GTK+3 is unlikely to see a release beyond 3.24.
+BDEPEND="
+ >=dev-util/meson-0.56.0
+ cinnamon? (
+ ${SASSC_DEPEND}
+ gnome-extra/cinnamon
+ )
+ gnome-shell? (
+ ${SASSC_DEPEND}
+ >=gnome-base/gnome-shell-3.18
+ )
+ gtk2? (
+ ${SVG_DEPEND}
+ )
+ gtk3? (
+ ${SASSC_DEPEND}
+ ${SVG_DEPEND}
+ virtual/pkgconfig
+ =x11-libs/gtk+-3.24*:3
+ )
+ gtk4? (
+ ${SASSC_DEPEND}
+ ${SVG_DEPEND}
+ )
+ xfce? (
+ ${SVG_DEPEND}
+ )
+"
+
+# gnome-themes-standard is only needed by GTK+2 for the Adwaita
+# engine. This engine is built into GTK+3.
+RDEPEND="
+ gtk2? (
+ x11-themes/gnome-themes-standard
+ x11-themes/gtk-engines-murrine
+ )
+"
+
+src_configure() {
+ local themes=$(
+ printf "%s," \
+ $(usev cinnamon) \
+ $(usev gnome-shell) \
+ $(usev gtk2) \
+ $(usev gtk3) \
+ $(usev gtk4) \
+ $(usex mate metacity "") \
+ $(usex xfce xfwm "")
+ )
+
+ local emesonargs=(
+ -Dthemes="${themes%,}"
+ -Dgtk3_version=3.24
+ -Dgtk4_version=4.2 # 4.0 dropped in Gentoo, works with 4.4.
+ )
+
+ if use pre-rendered; then
+ emesonargs+=(
+ $(if tc-is-cross-compiler; then
+ echo --cross-file
+ else
+ echo --native-file
+ fi)
+ "${FILESDIR}"/pre-rendered.ini
+ )
+ fi
+
+ meson_src_configure
+}
+
+src_compile() {
+ # fontconfig issue?
+ # https://bugs.gentoo.org/666418#c28
+ use pre-rendered ||
+ addpredict "${BROOT}"/usr/share/inkscape/fonts/.uuid.TMP-XXXXXX
+
+ meson_src_compile
+}
diff --git a/x11-themes/arc-theme/metadata.xml b/x11-themes/arc-theme/metadata.xml
index 25d3932c367d..c54d3e049299 100644
--- a/x11-themes/arc-theme/metadata.xml
+++ b/x11-themes/arc-theme/metadata.xml
@@ -12,6 +12,7 @@
<flag name="cinnamon">Install theme for <pkg>gnome-extra/cinnamon</pkg></flag>
<flag name="gtk2">Install GTK+2 theme</flag>
<flag name="gtk3">Install GTK+3 theme</flag>
+ <flag name="gtk4">Install GTK+4 theme</flag>
<flag name="mate">Install Metacity theme for <pkg>mate-base/mate</pkg></flag>
<flag name="gnome-shell">Install theme for <pkg>gnome-base/gnome-shell</pkg></flag>
<flag name="pre-rendered">Avoid <pkg>media-gfx/inkscape</pkg> and <pkg>media-gfx/optipng</pkg> dependencies by using pre-rendered PNGs</flag>