summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-themes/gnome-icon-theme-symbolic
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-themes/gnome-icon-theme-symbolic')
-rw-r--r--x11-themes/gnome-icon-theme-symbolic/Manifest2
-rw-r--r--x11-themes/gnome-icon-theme-symbolic/gnome-icon-theme-symbolic-3.10.1.ebuild41
-rw-r--r--x11-themes/gnome-icon-theme-symbolic/gnome-icon-theme-symbolic-3.12.0.ebuild41
-rw-r--r--x11-themes/gnome-icon-theme-symbolic/metadata.xml5
4 files changed, 89 insertions, 0 deletions
diff --git a/x11-themes/gnome-icon-theme-symbolic/Manifest b/x11-themes/gnome-icon-theme-symbolic/Manifest
new file mode 100644
index 000000000000..96f2ef397d62
--- /dev/null
+++ b/x11-themes/gnome-icon-theme-symbolic/Manifest
@@ -0,0 +1,2 @@
+DIST gnome-icon-theme-symbolic-3.10.1.tar.xz 225380 SHA256 344e88e5f9dac3184bf012d9bac972110df2133b93d76f2ad128d4c9cbf41412 SHA512 2168f5c8fa3718f76b0ec1b485ef986c9314ba91d03f9ba6f1b9b5af3e25ced5721f899b308bc5abefb98fc86312bbba2c622ecd9b505c10e24d438c14283587 WHIRLPOOL 4461b82297fb028996be9c998664db6d8f3fb7f75e45db18e59d7aa83517609f32e7a09b24e9348ac056cb746488d1ffe179477e45d69982b93b6e907916dd07
+DIST gnome-icon-theme-symbolic-3.12.0.tar.xz 230420 SHA256 851a4c9d8e8cb0000c9e5e78259ab8b8e67c5334e4250ebcc8dfdaa33520068b SHA512 e2a662d38c5c1328f384d9bdd73ce54f4e1174a1d88763e4a5f772c2479081f11c81937ba2dc159ce250e433762f14de824516fc68209200d95dc47790471eda WHIRLPOOL 563058e336105e531400221ba228bdcfb23605e09ec06cd679773a14584d20bb3c2ae179025ce6f02c3887aa71c8872854464f6b51834f579ddb58294271ce92
diff --git a/x11-themes/gnome-icon-theme-symbolic/gnome-icon-theme-symbolic-3.10.1.ebuild b/x11-themes/gnome-icon-theme-symbolic/gnome-icon-theme-symbolic-3.10.1.ebuild
new file mode 100644
index 000000000000..effa5fdfe67e
--- /dev/null
+++ b/x11-themes/gnome-icon-theme-symbolic/gnome-icon-theme-symbolic-3.10.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit gnome2
+
+DESCRIPTION="Symbolic icons for GNOME default icon theme"
+HOMEPAGE="https://git.gnome.org/browse/gnome-icon-theme-symbolic/"
+
+LICENSE="CC-BY-SA-3.0"
+SLOT="0"
+IUSE=""
+KEYWORDS="~alpha amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux"
+
+COMMON_DEPEND=">=x11-themes/hicolor-icon-theme-0.10"
+
+# gnome-base/librsvg will be needed by apps using this icons, bug #508210
+RDEPEND="${COMMON_DEPEND}
+ gnome-base/librsvg
+ !=gnome-extra/gnome-power-manager-3.0*
+"
+# Matches 3.10
+# !=gnome-extra/gnome-power-manager-3.1*
+
+# keyboard-brightness icon file collision with old gnome-power-manager
+DEPEND="${COMMON_DEPEND}
+ >=x11-misc/icon-naming-utils-0.8.7
+ virtual/pkgconfig
+"
+
+# This ebuild does not install any binaries
+RESTRICT="binchecks strip"
+
+src_configure() {
+ gnome2_src_configure \
+ --enable-icon-mapping \
+ GTK_UPDATE_ICON_CACHE=$(type -P true)
+}
diff --git a/x11-themes/gnome-icon-theme-symbolic/gnome-icon-theme-symbolic-3.12.0.ebuild b/x11-themes/gnome-icon-theme-symbolic/gnome-icon-theme-symbolic-3.12.0.ebuild
new file mode 100644
index 000000000000..effa5fdfe67e
--- /dev/null
+++ b/x11-themes/gnome-icon-theme-symbolic/gnome-icon-theme-symbolic-3.12.0.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+GCONF_DEBUG="no"
+
+inherit gnome2
+
+DESCRIPTION="Symbolic icons for GNOME default icon theme"
+HOMEPAGE="https://git.gnome.org/browse/gnome-icon-theme-symbolic/"
+
+LICENSE="CC-BY-SA-3.0"
+SLOT="0"
+IUSE=""
+KEYWORDS="~alpha amd64 ~arm ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc x86 ~amd64-fbsd ~x86-fbsd ~x86-interix ~amd64-linux ~arm-linux ~x86-linux"
+
+COMMON_DEPEND=">=x11-themes/hicolor-icon-theme-0.10"
+
+# gnome-base/librsvg will be needed by apps using this icons, bug #508210
+RDEPEND="${COMMON_DEPEND}
+ gnome-base/librsvg
+ !=gnome-extra/gnome-power-manager-3.0*
+"
+# Matches 3.10
+# !=gnome-extra/gnome-power-manager-3.1*
+
+# keyboard-brightness icon file collision with old gnome-power-manager
+DEPEND="${COMMON_DEPEND}
+ >=x11-misc/icon-naming-utils-0.8.7
+ virtual/pkgconfig
+"
+
+# This ebuild does not install any binaries
+RESTRICT="binchecks strip"
+
+src_configure() {
+ gnome2_src_configure \
+ --enable-icon-mapping \
+ GTK_UPDATE_ICON_CACHE=$(type -P true)
+}
diff --git a/x11-themes/gnome-icon-theme-symbolic/metadata.xml b/x11-themes/gnome-icon-theme-symbolic/metadata.xml
new file mode 100644
index 000000000000..da6fd63d0085
--- /dev/null
+++ b/x11-themes/gnome-icon-theme-symbolic/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>gnome</herd>
+</pkgmetadata>