summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGilles Dartiguelongue <eva@gentoo.org>2016-10-31 23:05:23 +0100
committerGilles Dartiguelongue <eva@gentoo.org>2016-11-01 12:18:11 +0100
commit8dc59f314801c6a91ede2f37c0c9f3ee1e1f8716 (patch)
treeff2679cca27b8989a3c7915d709d8a13203960b6 /x11-themes/gnome-themes-standard/gnome-themes-standard-3.22.2.ebuild
parentx11-themes/gnome-backgrounds: cleanup old revision (diff)
downloadgentoo-8dc59f314801c6a91ede2f37c0c9f3ee1e1f8716.tar.gz
gentoo-8dc59f314801c6a91ede2f37c0c9f3ee1e1f8716.tar.bz2
gentoo-8dc59f314801c6a91ede2f37c0c9f3ee1e1f8716.zip
x11-themes/gnome-themes-standard: version bump 3.20.2-r1 → 3.22.2
Package-Manager: portage-2.3.2
Diffstat (limited to 'x11-themes/gnome-themes-standard/gnome-themes-standard-3.22.2.ebuild')
-rw-r--r--x11-themes/gnome-themes-standard/gnome-themes-standard-3.22.2.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/x11-themes/gnome-themes-standard/gnome-themes-standard-3.22.2.ebuild b/x11-themes/gnome-themes-standard/gnome-themes-standard-3.22.2.ebuild
new file mode 100644
index 000000000000..e1845b238c16
--- /dev/null
+++ b/x11-themes/gnome-themes-standard/gnome-themes-standard-3.22.2.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit autotools gnome.org
+
+DESCRIPTION="Standard Themes for GNOME Applications"
+HOMEPAGE="https://git.gnome.org/browse/gnome-themes-standard/"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+IUSE=""
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~arm-linux ~x86-linux ~x64-solaris ~x86-solaris"
+
+# Depend on gsettings-desktop-schemas-3.4 to make sure 3.2 users don't lose
+# their default background image
+RDEPEND="
+ >=gnome-base/gsettings-desktop-schemas-3.4
+"
+DEPEND="
+ >=dev-util/intltool-0.40
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ # https://bugzilla.gnome.org/show_bug.cgi?id=746920
+ "${FILESDIR}"/${PN}-3.14.2.3-srcdir.patch
+ # Leave build of gtk+:2 engine to x11-themes/gtk-engines-adwaita
+ "${FILESDIR}"/${PN}-3.22.2-exclude-engine.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ --disable-static \
+ --disable-gtk2-engine \
+ --disable-gtk3-engine \
+ GTK_UPDATE_ICON_CACHE=$(type -P true)
+}