summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2017-03-23 07:42:08 +0200
committerMart Raudsepp <leio@gentoo.org>2017-03-23 07:46:58 +0200
commitc4facba91482b26eb70248d3b7b52b0e066df2da (patch)
tree3a7f5a955c32e0fe1d52fa917d8817689ee65653 /x11-themes/gnome-themes-standard/gnome-themes-standard-3.22.3.ebuild
parentdev-python/pbr: 2.0.0 bup (diff)
downloadgentoo-c4facba91482b26eb70248d3b7b52b0e066df2da.tar.gz
gentoo-c4facba91482b26eb70248d3b7b52b0e066df2da.tar.bz2
gentoo-c4facba91482b26eb70248d3b7b52b0e066df2da.zip
x11-themes/gnome-themes-standard: bump to 3.22.3; fixes dark theme handling and gtk2 shadow none
Package-Manager: Portage-2.3.4, Repoman-2.3.1
Diffstat (limited to 'x11-themes/gnome-themes-standard/gnome-themes-standard-3.22.3.ebuild')
-rw-r--r--x11-themes/gnome-themes-standard/gnome-themes-standard-3.22.3.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/x11-themes/gnome-themes-standard/gnome-themes-standard-3.22.3.ebuild b/x11-themes/gnome-themes-standard/gnome-themes-standard-3.22.3.ebuild
new file mode 100644
index 000000000000..4cfd7c5694a2
--- /dev/null
+++ b/x11-themes/gnome-themes-standard/gnome-themes-standard-3.22.3.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools gnome.org
+
+DESCRIPTION="Standard Themes for GNOME Applications"
+HOMEPAGE="https://git.gnome.org/browse/gnome-themes-standard/"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+IUSE=""
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~arm-linux ~x86-linux ~x64-solaris ~x86-solaris"
+
+# Depend on gsettings-desktop-schemas-3.4 to make sure 3.2 users don't lose
+# their default background image
+RDEPEND="
+ >=gnome-base/gsettings-desktop-schemas-3.4
+"
+DEPEND="
+ >=dev-util/intltool-0.40
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ # https://bugzilla.gnome.org/show_bug.cgi?id=746920
+ "${FILESDIR}"/${PN}-3.14.2.3-srcdir.patch
+ # Leave build of gtk+:2 engine to x11-themes/gtk-engines-adwaita
+ "${FILESDIR}"/${PN}-3.22.2-exclude-engine.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ --disable-static \
+ --disable-gtk2-engine \
+ --disable-gtk3-engine \
+ GTK_UPDATE_ICON_CACHE=$(type -P true)
+}