summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Stakenvicius <axs@gentoo.org>2016-10-12 10:13:39 -0400
committerIan Stakenvicius <axs@gentoo.org>2016-10-12 10:20:11 -0400
commit4040a498dacedda8e9d618b5a51ad6746fffa136 (patch)
tree9f6a9b51ec197ae0e2297e4a71fe326844b0ceb8 /x11-themes/greybird/greybird-3.20.1-r2.ebuild
parentdev-python/bpython: cleaning old (diff)
downloadgentoo-4040a498dacedda8e9d618b5a51ad6746fffa136.tar.gz
gentoo-4040a498dacedda8e9d618b5a51ad6746fffa136.tar.bz2
gentoo-4040a498dacedda8e9d618b5a51ad6746fffa136.zip
x11-themes/greybird: add slot to gtk+3 dependency atom
Package-Manager: portage-2.3.0
Diffstat (limited to 'x11-themes/greybird/greybird-3.20.1-r2.ebuild')
-rw-r--r--x11-themes/greybird/greybird-3.20.1-r2.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/x11-themes/greybird/greybird-3.20.1-r2.ebuild b/x11-themes/greybird/greybird-3.20.1-r2.ebuild
new file mode 100644
index 000000000000..33cb11c4822a
--- /dev/null
+++ b/x11-themes/greybird/greybird-3.20.1-r2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit autotools
+
+MY_PN=${PN/g/G}
+
+DESCRIPTION="The default theme from Xubuntu"
+HOMEPAGE="http://shimmerproject.org/project/greybird/ https://github.com/shimmerproject/Greybird"
+SRC_URI="https://github.com/shimmerproject/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+# README says "dual-licensed as GPLv2 or later and CC-BY-SA 3.0 or later"
+LICENSE="CC-BY-SA-3.0 GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+IUSE="ayatana gnome"
+
+RDEPEND="
+ >=x11-themes/gtk-engines-murrine-0.90
+ >=x11-libs/gtk+-3.20.0:3
+"
+DEPEND="${RDEPEND}
+ dev-ruby/sass
+ dev-libs/glib:2
+"
+
+S=${WORKDIR}/${MY_PN}-${PV}
+#RESTRICT="binchecks strip"
+
+src_prepare() {
+ eapply_user
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ pushd "${ED}"usr/share/themes/${MY_PN} > /dev/null || die
+ use ayatana || rm -rf unity
+ use gnome || rm -rf metacity-1
+ popd > /dev/null || die
+}
+
+pkg_postinst() {
+ if ! has_version x11-themes/elementary-xfce-icon-theme ; then
+ elog "For upstream's default icon theme, please emerge"
+ elog "x11-themes/elementary-xfce-icon-theme"
+ fi
+ if ! has_version x11-themes/vanilla-dmz-xcursors ; then
+ elog "For upstream's default cursor theme, please emerge"
+ elog "x11-themes/vanilla-dmz-xcursors"
+ fi
+}