summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas K. Hüttel <dilfridge@gentoo.org>2017-07-30 08:56:21 +0200
committerAndreas K. Hüttel <dilfridge@gentoo.org>2017-07-30 09:26:53 +0200
commit29d348ab6b3552954688908e9740d71e37f92e17 (patch)
tree8677b5376b7ee671987ecae35ac3543159e03b25 /x11-themes/gtk-chtheme
parentapp-eselect/eselect-bashcomp: Remove last-rited pkg (diff)
downloadgentoo-29d348ab6b3552954688908e9740d71e37f92e17.tar.gz
gentoo-29d348ab6b3552954688908e9740d71e37f92e17.tar.bz2
gentoo-29d348ab6b3552954688908e9740d71e37f92e17.zip
x11-themes/gtk-chtheme: EAPI bump, bug 605728
Package-Manager: Portage-2.3.6, Repoman-2.3.3
Diffstat (limited to 'x11-themes/gtk-chtheme')
-rw-r--r--x11-themes/gtk-chtheme/gtk-chtheme-0.3.1-r3.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/x11-themes/gtk-chtheme/gtk-chtheme-0.3.1-r3.ebuild b/x11-themes/gtk-chtheme/gtk-chtheme-0.3.1-r3.ebuild
new file mode 100644
index 000000000000..2adbbc6017e9
--- /dev/null
+++ b/x11-themes/gtk-chtheme/gtk-chtheme-0.3.1-r3.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils toolchain-funcs
+
+DESCRIPTION="GTK-2.0 Theme Switcher"
+HOMEPAGE="http://plasmasturm.org/programs/gtk-chtheme/"
+SRC_URI="http://plasmasturm.org/programs/gtk-chtheme/${P}.tar.bz2"
+
+IUSE=""
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x86-macos"
+LICENSE="GPL-2"
+
+RDEPEND="x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-implicit.patch
+ "${FILESDIR}/${P}-asneeded.patch" # Fix forced as-needed, bug #248655
+ "${FILESDIR}/${P}-qgtkstyle.patch" # Make it work with qgtkstyle, bug #250504
+)
+
+src_prepare() {
+ # QA: stop Makefile from stripping the binaries
+ sed -i -e "s:strip:true:" "${S}"/Makefile || die "sed failed"
+
+ default
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ emake DESTDIR="${ED}" install
+}