summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIlya Tumaykin <itumaykin@gmail.com>2016-05-17 13:41:57 +0300
committerSam Jorna <wraeth@gentoo.org>2016-05-18 23:29:50 +1000
commit9a134b0b76486030aadc146b56139f7afcc85dcc (patch)
tree9404249786d147d0138d9d70af3eaeb21dfca887 /x11-themes/neutral-xcursors
parentdev-util/boost-build: Don't use python3 (bug #583406). (diff)
downloadgentoo-9a134b0b76486030aadc146b56139f7afcc85dcc.tar.gz
gentoo-9a134b0b76486030aadc146b56139f7afcc85dcc.tar.bz2
gentoo-9a134b0b76486030aadc146b56139f7afcc85dcc.zip
x11-themes/xcursor-neutral: renamed to x11-themes/neutral-xcursors
Rationale: - follows the naming convention used for other cursor themes in tree; - there will be more than one theme installed after the next verbump. https://devmanual.gentoo.org/ebuild-maintenance/index.html#moving-a-package: 1. `git mv xcursor-neutral/ neutral-xcursors/' ✓ 2. Add entry to profile/updates/2Q-2016 ✓ 3. Update reverse dependencies (there's none) ✓ 4. Update entries in profiles/ (there's none) ✓ 5. Update eclasses that reference the package (there's none) ✓ 6. Update metadata.xml entries that reference the package (there's none) ✓ 7,8. Stage and commit changes ✓ 9. Update open bug reports related to the package (there's none) ✓ Signed-off-by: Sam Jorna <wraeth@gentoo.org>
Diffstat (limited to 'x11-themes/neutral-xcursors')
-rw-r--r--x11-themes/neutral-xcursors/Manifest1
-rw-r--r--x11-themes/neutral-xcursors/metadata.xml13
-rw-r--r--x11-themes/neutral-xcursors/neutral-xcursors-1.20.ebuild33
3 files changed, 47 insertions, 0 deletions
diff --git a/x11-themes/neutral-xcursors/Manifest b/x11-themes/neutral-xcursors/Manifest
new file mode 100644
index 000000000000..134e7875c9af
--- /dev/null
+++ b/x11-themes/neutral-xcursors/Manifest
@@ -0,0 +1 @@
+DIST 48837-Neutral_Plus_1.2.tar.bz2 61354 SHA256 6b496406128fb3effd4e87159a29811d12a1b2f071e1341e67a6744c57d206dd SHA512 e20b4aa172561b04d39a3209a0977d6d7d8f1956fb4d60f7dd022b7ae6195890956b76facbe58fe3d5fd6a4b844f0c14da5d09f7f82379048c610e41133a713d WHIRLPOOL 86aa0ead57c70d947dbd62a457067f7d8fd468ebdb3b5b52e67abe0b0278256557b83f861aa95e5b29d0e42459dd66f78cb5563772ac1238b9e41751876ae489
diff --git a/x11-themes/neutral-xcursors/metadata.xml b/x11-themes/neutral-xcursors/metadata.xml
new file mode 100644
index 000000000000..27f226d3cf30
--- /dev/null
+++ b/x11-themes/neutral-xcursors/metadata.xml
@@ -0,0 +1,13 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>itumaykin+gentoo@gmail.com</email>
+ <name>Coacher</name>
+ <description>Proxied maintainer - set to assignee on bugs</description>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+</pkgmetadata>
diff --git a/x11-themes/neutral-xcursors/neutral-xcursors-1.20.ebuild b/x11-themes/neutral-xcursors/neutral-xcursors-1.20.ebuild
new file mode 100644
index 000000000000..dcf360c469e0
--- /dev/null
+++ b/x11-themes/neutral-xcursors/neutral-xcursors-1.20.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+MY_P="48837-Neutral_Plus_1.2.tar.bz2"
+MY_PN="Neutral_Plus"
+
+DESCRIPTION="\"Neutral_Plus\", the standard X.Org mouse cursor with shadows and animations"
+HOMEPAGE="http://kde-look.org/content/show.php/show.php?content=48837"
+SRC_URI="http://kde-look.org/CONTENT/content-files/${MY_P}"
+
+LICENSE="Artistic-2"
+SLOT="0"
+KEYWORDS="amd64 ~arm ~arm64 sparc x86 ~x86-fbsd"
+IUSE="examples"
+RDEPEND="x11-libs/libX11
+ x11-libs/libXcursor
+ >=media-libs/libpng-1.2"
+DEPEND="${RDEPEND}
+ x11-apps/xcursorgen"
+S="${WORKDIR}/Neutral_Plus"
+
+src_install(){
+ insinto /usr/share/cursors/xorg-x11/${MY_PN}/
+
+ doins -r "${S}"/cursors/
+ doins "${S}"/index.theme
+
+ ## install additional cursor source files?
+ if use examples; then
+ doins -r "${S}"/source/
+ fi
+}