summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-themes/nimbus/nimbus-0.1.7-r1.ebuild
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-themes/nimbus/nimbus-0.1.7-r1.ebuild')
-rw-r--r--x11-themes/nimbus/nimbus-0.1.7-r1.ebuild61
1 files changed, 61 insertions, 0 deletions
diff --git a/x11-themes/nimbus/nimbus-0.1.7-r1.ebuild b/x11-themes/nimbus/nimbus-0.1.7-r1.ebuild
new file mode 100644
index 000000000000..d3370413fa61
--- /dev/null
+++ b/x11-themes/nimbus/nimbus-0.1.7-r1.ebuild
@@ -0,0 +1,61 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+AUTOTOOLS_AUTO_DEPEND=no
+inherit autotools gnome2-utils
+
+DESCRIPTION="The default OpenSolaris theme (GTK+ 2.x engine, icon- and metacity theme)"
+HOMEPAGE="http://dlc.sun.com/osol/jds/downloads/extras/nimbus/"
+SRC_URI="http://dlc.sun.com/osol/jds/downloads/extras/${PN}/${P}.tar.bz2"
+
+LICENSE="LGPL-2"
+SLOT="0"
+KEYWORDS="amd64 x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux"
+IUSE="gtk minimal"
+
+COMMON_DEPEND="gtk? ( x11-libs/gtk+:2 )"
+RDEPEND="${COMMON_DEPEND}
+ !minimal? ( || ( x11-themes/gnome-icon-theme x11-themes/tango-icon-theme ) )"
+DEPEND="${COMMON_DEPEND}
+ dev-util/intltool
+ virtual/pkgconfig
+ >=x11-misc/icon-naming-utils-0.8.90
+ !gtk? ( ${AUTOTOOLS_DEPEND} )
+ elibc_Interix? ( ${AUTOTOOLS_DEPEND} )"
+
+src_prepare() {
+ # Tango is deprecated
+ sed -i -e '/^Inherits/s:Tango:gnome,&:' icons/index.theme.in || die
+
+ # Encoding= key is obsolete
+ sed -i -e '/^Encoding/d' *.theme.in || die
+
+ use gtk || { sed -i \
+ -e '/^gtk-engine/d' -e '/GTK2/d' -e '/^SUBDIRS/s:gtk-engine ::' \
+ configure.in Makefile.am || die; }
+
+ local f=po/POTFILES.skip
+ echo light-index.theme.in >> ${f}
+ echo dark-index.theme.in >> ${f}
+
+ if [[ ${CHOST} == *-interix* ]] || ! use gtk; then
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ econf $(use gtk && echo --disable-static)
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog
+
+ use gtk && find "${ED}"/usr -name libnimbus.la -exec rm -f {} +
+}
+
+pkg_preinst() { gnome2_icon_savelist; }
+pkg_postinst() { gnome2_icon_cache_update; }
+pkg_postrm() { gnome2_icon_cache_update; }