summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2016-11-11 21:06:40 +0100
committerLars Wendler <polynomial-c@gentoo.org>2016-11-11 21:06:58 +0100
commit007835f10f1c35e9da072186b5fca6f20560eb3d (patch)
tree1402bc88e851bc66d42417ce5a2606c554b5c615 /x11-themes/qtcurve
parentsys-apps/openrc: remove 0.22.3 (diff)
downloadgentoo-007835f10f1c35e9da072186b5fca6f20560eb3d.tar.gz
gentoo-007835f10f1c35e9da072186b5fca6f20560eb3d.tar.bz2
gentoo-007835f10f1c35e9da072186b5fca6f20560eb3d.zip
x11-themes/qtcurve: Added live ebuild based on work from seden overlay.
Package-Manager: portage-2.3.2
Diffstat (limited to 'x11-themes/qtcurve')
-rw-r--r--x11-themes/qtcurve/files/qtcurve-9999-add_utils_include.patch10
-rw-r--r--x11-themes/qtcurve/qtcurve-9999.ebuild94
2 files changed, 104 insertions, 0 deletions
diff --git a/x11-themes/qtcurve/files/qtcurve-9999-add_utils_include.patch b/x11-themes/qtcurve/files/qtcurve-9999-add_utils_include.patch
new file mode 100644
index 000000000000..5536937f9b18
--- /dev/null
+++ b/x11-themes/qtcurve/files/qtcurve-9999-add_utils_include.patch
@@ -0,0 +1,10 @@
+--- a/qt4/style/qtcurve_plugin.cpp 2016-10-25 10:12:41.000000000 +0200
++++ b/qt4/style/qtcurve_plugin.cpp 2016-10-25 10:21:32.446853060 +0200
+@@ -22,6 +22,7 @@
+
+ #include "qtcurve_plugin.h"
+ #include "qtcurve.h"
++#include "utils.h"
+ #include "config.h"
+
+ #include <qtcurve-utils/qtprops.h>
diff --git a/x11-themes/qtcurve/qtcurve-9999.ebuild b/x11-themes/qtcurve/qtcurve-9999.ebuild
new file mode 100644
index 000000000000..b88845610466
--- /dev/null
+++ b/x11-themes/qtcurve/qtcurve-9999.ebuild
@@ -0,0 +1,94 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+inherit cmake-utils kde5-functions git-r3
+
+DESCRIPTION="A set of widget styles for Qt and GTK2"
+HOMEPAGE="https://quickgit.kde.org/?p=qtcurve.git"
+EGIT_REPO_URI="git://anongit.kde.org/qtcurve"
+
+LICENSE="LGPL-2+"
+SLOT="0"
+IUSE="+X gtk nls plasma qt4 +qt5 test"
+KEYWORDS=""
+
+REQUIRED_USE="gtk? ( X )
+ || ( gtk qt4 qt5 )
+ plasma? ( qt5 )
+"
+
+RDEPEND="X? (
+ x11-libs/libX11
+ x11-libs/libxcb
+ )
+ gtk? ( x11-libs/gtk+:2 )
+ qt4? (
+ dev-qt/qtcore:4
+ dev-qt/qtdbus:4
+ dev-qt/qtgui:4
+ dev-qt/qtsvg:4
+ )
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtsvg:5
+ dev-qt/qtwidgets:5
+ dev-qt/qtx11extras:5
+ )
+ plasma? (
+ dev-qt/qtprintsupport:5
+ $(add_frameworks_dep karchive)
+ $(add_frameworks_dep kcompletion)
+ $(add_frameworks_dep kconfig)
+ $(add_frameworks_dep kconfigwidgets)
+ $(add_frameworks_dep kcoreaddons)
+ $(add_frameworks_dep kdelibs4support)
+ $(add_frameworks_dep kguiaddons)
+ $(add_frameworks_dep ki18n)
+ $(add_frameworks_dep kiconthemes)
+ $(add_frameworks_dep kio)
+ $(add_frameworks_dep kwidgetsaddons)
+ $(add_frameworks_dep kwindowsystem)
+ $(add_frameworks_dep kxmlgui)
+ )
+ !x11-themes/gtk-engines-qtcurve"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ nls? ( sys-devel/gettext )"
+
+S="${WORKDIR}/${P/_/}"
+
+DOCS=( AUTHORS ChangeLog.md README.md TODO.md )
+
+#PATCHES=(
+# "${FILESDIR}/${P}-add_utils_include.patch"
+#)
+
+pkg_setup() {
+ # bug #498776
+ if ! version_is_at_least 4.7 $(gcc-version) ; then
+ append-cxxflags -Doverride=
+ fi
+}
+
+src_configure() {
+ local mycmakeargs
+
+ mycmakeargs=(
+ -DQTC_QT4_ENABLE_KDE=OFF
+ -DQTC_QT4_ENABLE_KWIN=OFF
+ -DQTC_KDE4_DEFAULT_HOME=ON
+ -DENABLE_GTK2="$(usex gtk)"
+ -DENABLE_QT4="$(usex qt4)"
+ -DENABLE_QT5="$(usex qt5)"
+ -DENABLE_TEST="$(usex test)"
+ -DQTC_ENABLE_X11="$(usex X)"
+ -DQTC_INSTALL_PO="$(usex nls)"
+ -DQTC_QT5_ENABLE_KDE="$(usex plasma)"
+ )
+
+ cmake-utils_src_configure
+}