summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-themes/tango-icon-theme
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-themes/tango-icon-theme')
-rw-r--r--x11-themes/tango-icon-theme/Manifest1
-rw-r--r--x11-themes/tango-icon-theme/metadata.xml8
-rw-r--r--x11-themes/tango-icon-theme/tango-icon-theme-0.8.90.ebuild56
3 files changed, 65 insertions, 0 deletions
diff --git a/x11-themes/tango-icon-theme/Manifest b/x11-themes/tango-icon-theme/Manifest
new file mode 100644
index 000000000000..9c2538fb12f8
--- /dev/null
+++ b/x11-themes/tango-icon-theme/Manifest
@@ -0,0 +1 @@
+DIST tango-icon-theme-0.8.90.tar.gz 1790489 SHA256 6e98d8032d57d818acc907ec47e6a718851ff251ae7c29aafb868743eb65c88e SHA512 78b909bfc8b126060f8a320f5465ee6af98533b5229ebe46952469ba9f08796189b1ad8110e0ffa1e5745d083cad292396af887c4f8792595b0b8d2891258a52 WHIRLPOOL 112b50fac26ee53e2815f10204d209656d26f7b8fe7582a0d0b1c64aa1c2a55495d4f5e5f67c39b549b84f1e422bf6deb61461a3182a633511c579220561a4c2
diff --git a/x11-themes/tango-icon-theme/metadata.xml b/x11-themes/tango-icon-theme/metadata.xml
new file mode 100644
index 000000000000..c03b663ea9ff
--- /dev/null
+++ b/x11-themes/tango-icon-theme/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>freedesktop</herd>
+ <maintainer>
+ <email>freedesktop-bugs@gentoo.org</email>
+ </maintainer>
+</pkgmetadata>
diff --git a/x11-themes/tango-icon-theme/tango-icon-theme-0.8.90.ebuild b/x11-themes/tango-icon-theme/tango-icon-theme-0.8.90.ebuild
new file mode 100644
index 000000000000..40a14ffa3b0b
--- /dev/null
+++ b/x11-themes/tango-icon-theme/tango-icon-theme-0.8.90.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=4
+inherit gnome2-utils
+
+DESCRIPTION="SVG and PNG icon theme from the Tango project"
+HOMEPAGE="http://tango.freedesktop.org"
+SRC_URI="http://tango.freedesktop.org/releases/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd ~x86-freebsd ~x86-interix ~amd64-linux ~x86-linux ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="minimal png"
+
+RDEPEND="!hppa? ( !minimal? ( x11-themes/gnome-icon-theme ) )
+ >=x11-themes/hicolor-icon-theme-0.12"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ virtual/pkgconfig
+ >=gnome-base/librsvg-2.34
+ || ( media-gfx/imagemagick[png?] media-gfx/graphicsmagick[imagemagick,png?] )
+ sys-devel/gettext
+ >=x11-misc/icon-naming-utils-0.8.90"
+
+RESTRICT="binchecks strip"
+
+DOCS="AUTHORS ChangeLog README"
+
+src_prepare() {
+ sed -i -e '/svgconvert_prog/s:rsvg:&-convert:' configure || die #413183
+
+ # http://bugs.gentoo.org/472766
+ shopt -s nullglob
+ cards=$(echo -n /dev/dri/card* | sed 's/ /:/g')
+ if test -n "${cards}"; then
+ addpredict "${cards}"
+ fi
+ shopt -u nullglob
+}
+
+src_configure() {
+ econf \
+ $(use_enable png png-creation) \
+ $(use_enable png icon-framing)
+}
+
+src_install() {
+ addwrite /root/.gnome2
+ default
+}
+
+pkg_preinst() { gnome2_icon_savelist; }
+pkg_postinst() { gnome2_icon_cache_update; }
+pkg_postrm() { gnome2_icon_cache_update; }