summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2017-01-16 20:28:31 +0200
committerMart Raudsepp <leio@gentoo.org>2017-01-16 20:45:30 +0200
commitc9bff85f6f63656956401eb6b906b0ec7bfa6a83 (patch)
treedb2d62bea75857bdcf719ae6b185546604d4e918 /x11-themes
parentx11-libs/gdk-pixbuf: Clarify what USE=X does in local description (diff)
downloadgentoo-c9bff85f6f63656956401eb6b906b0ec7bfa6a83.tar.gz
gentoo-c9bff85f6f63656956401eb6b906b0ec7bfa6a83.tar.bz2
gentoo-c9bff85f6f63656956401eb6b906b0ec7bfa6a83.zip
x11-themes/gtk-engines-adwaita: Bump to 3.22.2 to keep in sync with gnome-themes-standard
No changes to the compiled code that this split uses, but it's a fast compile and better to keep in sync with gnome-themes-standard to use the same tarball at the same visibility level. Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/gtk-engines-adwaita/Manifest1
-rw-r--r--x11-themes/gtk-engines-adwaita/gtk-engines-adwaita-3.22.2.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/x11-themes/gtk-engines-adwaita/Manifest b/x11-themes/gtk-engines-adwaita/Manifest
index b39c7ecc1111..a5e8891a2060 100644
--- a/x11-themes/gtk-engines-adwaita/Manifest
+++ b/x11-themes/gtk-engines-adwaita/Manifest
@@ -1 +1,2 @@
DIST gnome-themes-standard-3.20.2.tar.xz 2878508 SHA256 9d0d9c4b2c9f9008301c3c1878ebb95859a735b7fd4a6a518802b9637e4a7915 SHA512 ce6dd2697e4afd5f36b6c362086eb5d5f3732ab863770f024e4970b2f7399b8ae6e49241de99bf8b558e4d80869ec1002d817f3dd9e7b8fbf9ea8da5a1d386fc WHIRLPOOL aa3e2f2f8a845cf6d1d09726cb58b113a8f4d6cf0cbf04b450602ba8ff17668dd827e0c2de40326f1a388d9a8998e03db4c301395a2e41ec3666e0c40cd23883
+DIST gnome-themes-standard-3.22.2.tar.xz 2900572 SHA256 b34516cd59b873c187c1897c25bac3b9ce2d30a472f1fd7ae9d7105d93e17da5 SHA512 d1fe6d93d06b9a231898055cf801adace0949c06658a08b445c3e0aaf127a4682d857463ee08a74d3652bad9e19bfaff4f651b5174cbeb76c99143da25cf39bd WHIRLPOOL 31c2e71d180b281d15319ca777a216d4db6be5639b4fb1ae33dbd1ff3981b4953ac934b58d1a77565c811d2c835f9d62518d342d8e5c1dc0a8ba5a8e437952aa
diff --git a/x11-themes/gtk-engines-adwaita/gtk-engines-adwaita-3.22.2.ebuild b/x11-themes/gtk-engines-adwaita/gtk-engines-adwaita-3.22.2.ebuild
new file mode 100644
index 000000000000..f765a8bb1be5
--- /dev/null
+++ b/x11-themes/gtk-engines-adwaita/gtk-engines-adwaita-3.22.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="6"
+GNOME_ORG_MODULE="gnome-themes-standard"
+
+inherit gnome.org multilib-minimal
+
+DESCRIPTION="Adwaita GTK+2 theme engine"
+HOMEPAGE="https://git.gnome.org/browse/gnome-themes-standard/"
+
+LICENSE="LGPL-2.1+"
+SLOT="0"
+IUSE=""
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~sh ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~x86-freebsd ~amd64-linux ~arm-linux ~x86-linux ~x64-solaris ~x86-solaris"
+
+COMMON_DEPEND="
+ >=x11-libs/gtk+-2.24.15:2[${MULTILIB_USEDEP}]
+"
+RDEPEND="${COMMON_DEPEND}
+ !<x11-themes/gnome-themes-standard-3.20.2-r1
+"
+DEPEND="${COMMON_DEPEND}
+ >=dev-util/intltool-0.40
+ sys-devel/gettext
+ virtual/pkgconfig
+"
+
+multilib_src_configure() {
+ ECONF_SOURCE="${S}" econf \
+ --disable-static \
+ --enable-gtk2-engine \
+ --disable-gtk3-engine \
+ GTK_UPDATE_ICON_CACHE=$(type -P true)
+}
+
+multilib_src_compile() {
+ emake -C themes/Adwaita/gtk-2.0 libadwaita.la
+}
+
+multilib_src_install() {
+ emake -C themes/Adwaita/gtk-2.0 DESTDIR="${D}" install-engineLTLIBRARIES
+ prune_libtool_files --modules
+}