summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2019-08-25 10:19:55 +0200
committerJeroen Roovers <jer@gentoo.org>2019-08-25 10:22:28 +0200
commitdcf6998af231ac77f35395f20aae2ded1bcc5a62 (patch)
tree7e80dc4fcde2f7a3fe18931d15cd7fdf4ded1ec7 /x11-themes
parentdev-util/pkgcheck: version bump to 0.6.1 (diff)
downloadgentoo-dcf6998af231ac77f35395f20aae2ded1bcc5a62.tar.gz
gentoo-dcf6998af231ac77f35395f20aae2ded1bcc5a62.tar.bz2
gentoo-dcf6998af231ac77f35395f20aae2ded1bcc5a62.zip
x11-themes/gtk-engines-rezlooks: EAPI=7
Package-Manager: Portage-2.3.73, Repoman-2.3.17 Co-Authored-By: Stephan Hartmann <stha09@googlemail.com> Fixes: https://bugs.gentoo.org/692816 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/gtk-engines-rezlooks/files/gtk-engines-rezlooks-0.6-glib-single-include.patch6
-rw-r--r--x11-themes/gtk-engines-rezlooks/gtk-engines-rezlooks-0.6-r1.ebuild45
2 files changed, 47 insertions, 4 deletions
diff --git a/x11-themes/gtk-engines-rezlooks/files/gtk-engines-rezlooks-0.6-glib-single-include.patch b/x11-themes/gtk-engines-rezlooks/files/gtk-engines-rezlooks-0.6-glib-single-include.patch
index 340bd046fb0e..d9b035ac53b3 100644
--- a/x11-themes/gtk-engines-rezlooks/files/gtk-engines-rezlooks-0.6-glib-single-include.patch
+++ b/x11-themes/gtk-engines-rezlooks/files/gtk-engines-rezlooks-0.6-glib-single-include.patch
@@ -1,7 +1,5 @@
-Index: rezlooks-0.6/src/animation.c
-===================================================================
---- rezlooks-0.6.orig/src/animation.c
-+++ rezlooks-0.6/src/animation.c
+--- a/src/animation.c
++++ b/src/animation.c
@@ -7,7 +7,7 @@
#include "animation.h"
diff --git a/x11-themes/gtk-engines-rezlooks/gtk-engines-rezlooks-0.6-r1.ebuild b/x11-themes/gtk-engines-rezlooks/gtk-engines-rezlooks-0.6-r1.ebuild
new file mode 100644
index 000000000000..2cc642b0031a
--- /dev/null
+++ b/x11-themes/gtk-engines-rezlooks/gtk-engines-rezlooks-0.6-r1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools
+
+DESCRIPTION="Rezlooks GTK+ Engine"
+HOMEPAGE="https://www.gnome-look.org/content/show.php?content=39179"
+SRC_URI="https://www.gnome-look.org/content/files/39179-rezlooks-0.6.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+
+RDEPEND="
+ >=x11-libs/gtk+-2.8:2
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+"
+PATCHES=(
+ "${FILESDIR}"/${PN}-0.6-glib-single-include.patch
+)
+S=${WORKDIR}/rezlooks-${PV}
+
+src_prepare() {
+ default
+
+ # automake complains: ChangeLog missing. There however is a Changelog.
+ # to avoid problems with case insensitive fs, move somewhere else first.
+ mv Changelog{,.1} || die
+ mv Changelog.1 ChangeLog || die
+
+ eautoreconf # required for interix
+}
+
+src_configure() {
+ econf --enable-animation
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -exec rm -f {} + || die
+}