summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2020-05-31 13:26:48 +0200
committerPacho Ramos <pacho@gentoo.org>2020-05-31 14:42:20 +0200
commite0e7950a00afc612df17ddd53dfb259e874a3654 (patch)
tree46b68a6e9c456426e5057646c3437aeccf6cfa31 /x11-themes
parentapp-backup/synology-cloud-station-backup: Drop old (diff)
downloadgentoo-e0e7950a00afc612df17ddd53dfb259e874a3654.tar.gz
gentoo-e0e7950a00afc612df17ddd53dfb259e874a3654.tar.bz2
gentoo-e0e7950a00afc612df17ddd53dfb259e874a3654.zip
x11-themes/adwaita-qt: Bump to 1.1.4
Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Pacho Ramos <pacho@gentoo.org>
Diffstat (limited to 'x11-themes')
-rw-r--r--x11-themes/adwaita-qt/Manifest1
-rw-r--r--x11-themes/adwaita-qt/adwaita-qt-1.1.4.ebuild45
2 files changed, 46 insertions, 0 deletions
diff --git a/x11-themes/adwaita-qt/Manifest b/x11-themes/adwaita-qt/Manifest
index 82dca94e74af..c2e8722a6dbb 100644
--- a/x11-themes/adwaita-qt/Manifest
+++ b/x11-themes/adwaita-qt/Manifest
@@ -1,2 +1,3 @@
DIST adwaita-qt-1.1.1.tar.gz 435566 BLAKE2B c8ca8df84ce06311b0937d994a859bb6e71a4a45570c179bdf3ded144bee06c93d8d80b300db3786b1bcc8db7f2b1d78423c8d8b0456079c4563924b2a036abc SHA512 6d11fc8eecc94da4f2e3798ee5147258f277032b23a82d5bf8d3414943ac89c5ebd056d519338959c72a8a45d1638ab8cfeac01b3f3fd1118b4c89eb0c8b5608
DIST adwaita-qt-1.1.3.tar.gz 436159 BLAKE2B cebb1996d5ce7aa1147c097aa791e28b8f95dd8003eb344cc49c58b860c1f41806c152a11c420d420e13a83707c76009961b391ed2bacfcc921978ad05ad0d04 SHA512 82abdd2320cbfcd6983d0ea8b07615ee2d675849d03b6fa61c8c18dcf5974136d80612cb308a5502714827b2e9358f2ee66091a2d9a19851969d8070c9a454bb
+DIST adwaita-qt-1.1.4.tar.gz 436392 BLAKE2B 2a8ab80a2189cc7bbc21bb83c409b16c8824364cc768765246876dedab8ac4073f0325d28dd916b2173bb3cd7396bb2c4b19b07c8932d589200d91f3ea48e2b9 SHA512 78390787c4b080608036605c6c713bbd5d482b039796e76974ca8c034e0d8af694704e063d53f99a3e5e7ac4d48f6325ff1c90d67fbeb4bc9e49792485e11cb1
diff --git a/x11-themes/adwaita-qt/adwaita-qt-1.1.4.ebuild b/x11-themes/adwaita-qt/adwaita-qt-1.1.4.ebuild
new file mode 100644
index 000000000000..c290d5c603dc
--- /dev/null
+++ b/x11-themes/adwaita-qt/adwaita-qt-1.1.4.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit cmake
+
+DESCRIPTION="A style to bend Qt applications to look like they belong into GNOME Shell"
+HOMEPAGE="https://github.com/FedoraQt/adwaita-qt"
+SRC_URI="https://github.com/FedoraQt/${PN}/archive/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc64 ~x86"
+IUSE="gnome"
+
+DEPEND="
+ dev-qt/qtcore:5
+ dev-qt/qtdbus:5
+ dev-qt/qtgui:5
+ dev-qt/qtwidgets:5
+"
+RDEPEND="${DEPEND}
+ gnome? ( x11-themes/QGnomePlatform )
+"
+
+src_configure() {
+ BUILD_DIR="${WORKDIR}/${PN}_qt5"
+ local mycmakeargs=( -DUSE_QT4=OFF )
+ cmake_src_configure
+}
+
+src_compile() {
+ local _d
+ for _d in "${WORKDIR}"/${PN}_qt*; do
+ cmake_src_compile -C "${_d}"
+ done
+}
+
+src_install() {
+ local _d
+ for _d in "${WORKDIR}"/${PN}_qt*; do
+ cmake_src_install -C "${_d}"
+ done
+}