summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJake Lilly <lillyjsm@gmail.com>2019-10-16 23:44:43 -0400
committerJoonas Niilola <juippis@gentoo.org>2020-02-19 15:32:19 +0200
commit5660053c47e3d25e9ce39c57bb1101356af40aa8 (patch)
tree99822fcf6c681086ead7d1f280a88cb9f53a562e /x11-wm/2bwm
parentdev-python/indexed_gzip: version bump 0.8.10, bug #696652 (diff)
downloadgentoo-5660053c47e3d25e9ce39c57bb1101356af40aa8.tar.gz
gentoo-5660053c47e3d25e9ce39c57bb1101356af40aa8.tar.bz2
gentoo-5660053c47e3d25e9ce39c57bb1101356af40aa8.zip
x11-wm/2bwm: new package
A fast, floating window manager Bug: https://bugs.gentoo.org/697904 Signed-off-by: Jake Lilly <lillyjsm@gmail.com> Package-Manager: Portage-2.3.84, Repoman-2.3.20 Closes: https://github.com/gentoo/gentoo/pull/13321 Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'x11-wm/2bwm')
-rw-r--r--x11-wm/2bwm/2bwm-0.3.ebuild44
-rw-r--r--x11-wm/2bwm/2bwm-9999.ebuild44
-rw-r--r--x11-wm/2bwm/Manifest1
-rw-r--r--x11-wm/2bwm/metadata.xml15
4 files changed, 104 insertions, 0 deletions
diff --git a/x11-wm/2bwm/2bwm-0.3.ebuild b/x11-wm/2bwm/2bwm-0.3.ebuild
new file mode 100644
index 000000000000..3f6bd230aa5a
--- /dev/null
+++ b/x11-wm/2bwm/2bwm-0.3.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit savedconfig toolchain-funcs
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/venam/2bwm.git"
+else
+ SRC_URI="https://github.com/venam/2bwm/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="A fast, floating window manager"
+HOMEPAGE="https://github.com/venam/2bwm"
+
+LICENSE="ISC"
+SLOT="0"
+
+DEPEND="
+ x11-libs/libxcb
+ x11-libs/xcb-util-keysyms
+ x11-libs/xcb-util-wm
+ x11-libs/xcb-util-xrm
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ sed -i -e "s:-Os -s::" Makefile || die
+ restore_config config.h
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" all
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
+ dodoc README.md
+ save_config config.h
+}
diff --git a/x11-wm/2bwm/2bwm-9999.ebuild b/x11-wm/2bwm/2bwm-9999.ebuild
new file mode 100644
index 000000000000..3f6bd230aa5a
--- /dev/null
+++ b/x11-wm/2bwm/2bwm-9999.ebuild
@@ -0,0 +1,44 @@
+# Copyright 2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit savedconfig toolchain-funcs
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/venam/2bwm.git"
+else
+ SRC_URI="https://github.com/venam/2bwm/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64"
+fi
+
+DESCRIPTION="A fast, floating window manager"
+HOMEPAGE="https://github.com/venam/2bwm"
+
+LICENSE="ISC"
+SLOT="0"
+
+DEPEND="
+ x11-libs/libxcb
+ x11-libs/xcb-util-keysyms
+ x11-libs/xcb-util-wm
+ x11-libs/xcb-util-xrm
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ sed -i -e "s:-Os -s::" Makefile || die
+ restore_config config.h
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)" all
+}
+
+src_install() {
+ emake DESTDIR="${D}" PREFIX="${EPREFIX}/usr" install
+ dodoc README.md
+ save_config config.h
+}
diff --git a/x11-wm/2bwm/Manifest b/x11-wm/2bwm/Manifest
new file mode 100644
index 000000000000..dc24b53eec2e
--- /dev/null
+++ b/x11-wm/2bwm/Manifest
@@ -0,0 +1 @@
+DIST 2bwm-0.3.tar.gz 41032 BLAKE2B 41fb12dccef95221fc5b6cec1d6b740037e0842628aedea23d80980961a615a4e5cf32ee9bc6c57eec8a2e304560b5f54dec0f65462af602f70c467d8c4ebe83 SHA512 088a97e5245287890c72e2b0685f7348a4cc0fd49582893b7ce7a081f80a4d7454a3c0eadf4609589314351ded02fd8b75548019b782e797350ad5db5c939f92
diff --git a/x11-wm/2bwm/metadata.xml b/x11-wm/2bwm/metadata.xml
new file mode 100644
index 000000000000..d33f238de018
--- /dev/null
+++ b/x11-wm/2bwm/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>lillyjsm@gmail.com</email>
+ <description>Jake Lilly</description>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">venam/2bwm</remote-id>
+ </upstream>
+</pkgmetadata>