summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-wm/afterstep/files
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-wm/afterstep/files')
-rwxr-xr-xx11-wm/afterstep/files/afterstep2
-rw-r--r--x11-wm/afterstep/files/afterstep-2.2.11-configure.patch13
-rw-r--r--x11-wm/afterstep/files/afterstep-2.2.11-execinfo.patch84
-rw-r--r--x11-wm/afterstep/files/afterstep-2.2.9-alpha.patch15
-rw-r--r--x11-wm/afterstep/files/afterstep-2.2.9-ldflags.patch37
-rw-r--r--x11-wm/afterstep/files/afterstep-2.2.9-libpng15.patch31
-rw-r--r--x11-wm/afterstep/files/afterstep-2.2.9-make_session_data_file.patch14
-rw-r--r--x11-wm/afterstep/files/no-alternatives-2.2.9.patch29
8 files changed, 225 insertions, 0 deletions
diff --git a/x11-wm/afterstep/files/afterstep b/x11-wm/afterstep/files/afterstep
new file mode 100755
index 000000000000..22bc4441ea42
--- /dev/null
+++ b/x11-wm/afterstep/files/afterstep
@@ -0,0 +1,2 @@
+#!/bin/sh
+/usr/bin/afterstep
diff --git a/x11-wm/afterstep/files/afterstep-2.2.11-configure.patch b/x11-wm/afterstep/files/afterstep-2.2.11-configure.patch
new file mode 100644
index 000000000000..1ed6bd9394d1
--- /dev/null
+++ b/x11-wm/afterstep/files/afterstep-2.2.11-configure.patch
@@ -0,0 +1,13 @@
+diff --git a/autoconf/configure.in b/autoconf/configure.in
+index 4170f98..a16388e 100644
+--- a/autoconf/configure.in
++++ b/autoconf/configure.in
+@@ -105,7 +105,7 @@ AC_ARG_ENABLE(send-postcard-to-developer, [ --enable-send-postcard-to-developer
+ AC_ARG_ENABLE(data-reinstall, [ --enable-data-reinstall will prevent AfterStep from reinstalling image and font files.[[yes]] ],data_reinstall=$enableval,data_reinstall="yes")
+
+ AC_ARG_ENABLE(script, [ --enable-script compile Script module [[yes]] ], enable_script=$enableval,enable_script="yes")
+-AC_ARG_ENABLE(reuse-font, [ --enable-reuse-font enables reuse of loaded font resource by modules (don't use with TrueType fonts !)[[no]] ],[if test x$enableval == "xyes"; then AC_DEFINE(MODULE_REUSE_LOADED_FONT,1,Enables reuse of loaded font resource by modules) fi])
++AC_ARG_ENABLE(reuse-font, [ --enable-reuse-font enables reuse of loaded font resource by modules (don't use with TrueType fonts !)[[no]] ],[if test x$enableval = "xyes"; then AC_DEFINE(MODULE_REUSE_LOADED_FONT,1,Enables reuse of loaded font resource by modules) fi])
+
+ dnl# For FreeBSD, add -I/usr/local/include
+
diff --git a/x11-wm/afterstep/files/afterstep-2.2.11-execinfo.patch b/x11-wm/afterstep/files/afterstep-2.2.11-execinfo.patch
new file mode 100644
index 000000000000..61f4f08c082d
--- /dev/null
+++ b/x11-wm/afterstep/files/afterstep-2.2.11-execinfo.patch
@@ -0,0 +1,84 @@
+diff --git a/libAfterBase/configure.in b/libAfterBase/configure.in
+index de055ea..eb5619e 100644
+--- a/libAfterBase/configure.in
++++ b/libAfterBase/configure.in
+@@ -189,6 +189,8 @@ AC_CHECK_HEADERS(elf.h,[AC_CHECK_DECLS([ElfW],,,[#include <link.h>])
+ AC_CHECK_MEMBERS([Elf32_Dyn.d_tag, Elf64_Dyn.d_tag],,,[#include <elf.h>])
+ AC_CHECK_TYPES([Elf64_Addr, Elf32_Addr],,,[#include <elf.h>])])
+
++AC_CHECK_LIB([execinfo], [backtrace], [LIBS="$LIBS -lexecinfo"; lib_execinfo="-lexecinfo"])
++
+ dnl# this is needed for self diagnostic code :
+ AC_CHECK_FUNCS(backtrace_symbols_fd backtrace_symbols backtrace)
+
+@@ -257,6 +257,7 @@ AC_SUBST(lib_file_name)
+ AC_SUBST(with_locale)
+ AC_SUBST(user_ldflags)
+ AC_SUBST(x_libs)
++AC_SUBST(lib_execinfo)
+ AC_SUBST(X_CFLAGS)
+ AC_SUBST(LIBPROG)
+ AC_SUBST(LIBINSTALL)
+diff --git a/libAfterBase/Makefile.in b/libAfterBase/Makefile.in
+index f04be29..c3bacbb 100644
+--- a/libAfterBase/Makefile.in
++++ b/libAfterBase/Makefile.in
+@@ -80,6 +80,7 @@ INCLUDES = $(INCS_X) $(INCS_PRIVATE)
+
+ USER_LD_FLAGS = @user_ldflags@
+ LIBS_X = @x_libs@
++LIB_EXECINFO = @lib_execinfo@
+
+
+ LIBDIR = $(DESTDIR)@libdir@
+@@ -326,7 +327,7 @@ $(LIB_SHARED).$(LIBVERMAJOR): $(LIB_SHARED).$(LIBVER)
+
+ $(LIB_SHARED).$(LIBVER): $(LIB_OBJS) $(LIB_INCS)
+ $(CC) -shared $(LDFLAGS) -Wl,-soname,$(LIB_SHARED).$(LIBVERMAJOR) -o $(LIB_SHARED).$(LIBVER) \
+- $(USER_LD_FLAGS) $(LIBS_X) $(LIB_OBJS)
++ $(USER_LD_FLAGS) $(LIB_OBJS) $(LIBS_X) $(LIB_EXECINFO)
+
+ install: install.lib
+
+diff --git a/autoconf/Makefile.defines.in b/autoconf/Makefile.defines.in
+index e6c283f..f8cae5e 100644
+--- a/autoconf/Makefile.defines.in
++++ b/autoconf/Makefile.defines.in
+@@ -40,6 +40,7 @@ LIBS_READLINE = @readline_libs@
+ LIBS_X = @x_libs@
+ LIBS_ALSA = @ALSA_LIBS@
+ LIBS_XEXTS =
++LIB_EXECINFO = @lib_execinfo@
+ LIB_AFTERBASE = @AFTERBASE_LIB@
+ LIB_AFTERIMAGE = @AFTERIMAGE_LIB@
+ LIB_AFTERSTEP = @AFTERSTEP_LIB@
+@@ -53,7 +54,7 @@ LIB_AFTERCONF_STATIC = @AFTERCONF_STATIC_LIB@
+ LIB_ASGTK_STATIC = @ASGTK_STATIC_LIB@
+ LIB_WIDGETS_STATIC = @WIDGETS_STATIC_LIB@
+ LIBS_AFTERIMAGE = @AFTERIMAGE_LIBS@
+-LIBRARIES = $(USER_LD_FLAGS) $(LIBS_PRIVATE) $(LIBS_XEXTS) $(LIBS_X)
++LIBRARIES = $(USER_LD_FLAGS) $(LIBS_PRIVATE) $(LIBS_XEXTS) $(LIBS_X) $(LIB_EXECINFO)
+
+ LIBS_ALL = $(LIBRARIES) $(EXTRA_LIBRARIES)
+
+diff --git a/autoconf/configure.in b/autoconf/configure.in
+index 45add70..4170f98 100644
+--- a/autoconf/configure.in
++++ b/autoconf/configure.in
+@@ -651,6 +651,8 @@ if test "x$send_postcard_to_developer" = "xyes"; then
+ AC_DEFINE(DO_SEND_POSTCARD,1,E-mail installation notification to AfterStep developers)
+ fi
+
++AC_CHECK_LIB([execinfo],[backtrace],[lib_execinfo="-lexecinfo"])
++
+ AC_CANONICAL_TARGET
+ AC_SUBST(build)
+ AC_SUBST(build_os)
+@@ -718,6 +720,7 @@ AC_SUBST(with_desktops)
+ AC_SUBST(with_desktops_1)
+ AC_SUBST(with_deskgeometry)
+ AC_SUBST(no_data_reinstall)
++AC_SUBST(lib_execinfo)
+ dnl# old stuff :
+ AC_SUBST(enable_different_looknfeels)
+ AC_SUBST(enable_pagerbackground)
diff --git a/x11-wm/afterstep/files/afterstep-2.2.9-alpha.patch b/x11-wm/afterstep/files/afterstep-2.2.9-alpha.patch
new file mode 100644
index 000000000000..307180b9bae0
--- /dev/null
+++ b/x11-wm/afterstep/files/afterstep-2.2.9-alpha.patch
@@ -0,0 +1,15 @@
+libAfterStep/alpha_header.h:15: error: conflicting types for 'strlen'
+
+--- libAfterStep/asapp.h
++++ libAfterStep/asapp.h
+@@ -15,10 +15,6 @@
+ #include "sun_headers.h"
+ #endif
+
+-#if defined(__alpha)
+-#include "alpha_header.h"
+-#endif /* NEEDS_ALPHA_HEADER */
+-
+ /* Some people say that AIX and AIXV3 need 3 preceding underscores, other say
+ * no. I'll do both */
+ #if defined ___AIX || defined _AIX || defined __QNX__ || defined ___AIXV3 || defined AIXV3 || defined _SEQUENT_ \ No newline at end of file
diff --git a/x11-wm/afterstep/files/afterstep-2.2.9-ldflags.patch b/x11-wm/afterstep/files/afterstep-2.2.9-ldflags.patch
new file mode 100644
index 000000000000..5d27d7d8293f
--- /dev/null
+++ b/x11-wm/afterstep/files/afterstep-2.2.9-ldflags.patch
@@ -0,0 +1,37 @@
+Respect LDFLAGS
+
+http://bugs.gentoo.org/show_bug.cgi?id=325309
+
+--- autoconf/Makefile.common.lib.in
++++ autoconf/Makefile.common.lib.in
+@@ -245,7 +245,7 @@
+ $(LN_S) -f $(LIB_SHARED).$(LIBVER) $(LIB_SHARED).$(LIBVERMAJOR)
+
+ $(LIB_SHARED).$(LIBVER): $(LIB_OBJS) $(LIB_INCS)
+- $(CC) -shared -Wl,-soname,$(LIB_SHARED).$(LIBVERMAJOR) -o $(LIB_SHARED).$(LIBVER) \
++ $(CC) -shared $(LDFLAGS) -Wl,-soname,$(LIB_SHARED).$(LIBVERMAJOR) -o $(LIB_SHARED).$(LIBVER) \
+ $(LIB_OBJS)
+
+ install: install.lib install.bin
+--- libAfterImage/Makefile.in
++++ libAfterImage/Makefile.in
+@@ -395,7 +395,7 @@
+ $(LN_S) -f $(LIB_SHARED).$(LIBVER) $(LIB_SHARED).$(LIBVERMAJOR)
+
+ $(LIB_SHARED).$(LIBVER): $(LIB_OBJS) $(LIB_INCS) config.h
+- $(CC) -shared -Wl,-soname,$(LIB_SHARED).$(LIBVERMAJOR) -o $(LIB_SHARED).$(LIBVER) \
++ $(CC) -shared $(LDFLAGS) -Wl,-soname,$(LIB_SHARED).$(LIBVERMAJOR) -o $(LIB_SHARED).$(LIBVER) \
+ $(LIB_OBJS)
+
+ install.man:
+--- libAfterBase/Makefile.in
++++ libAfterBase/Makefile.in
+@@ -325,7 +325,7 @@
+ $(LN_S) -f $(LIB_SHARED).$(LIBVER) $(LIB_SHARED).$(LIBVERMAJOR)
+
+ $(LIB_SHARED).$(LIBVER): $(LIB_OBJS) $(LIB_INCS)
+- $(CC) -shared -Wl,-soname,$(LIB_SHARED).$(LIBVERMAJOR) -o $(LIB_SHARED).$(LIBVER) \
++ $(CC) -shared $(LDFLAGS) -Wl,-soname,$(LIB_SHARED).$(LIBVERMAJOR) -o $(LIB_SHARED).$(LIBVER) \
+ $(USER_LD_FLAGS) $(LIBS_X) $(LIB_OBJS)
+
+ install: install.lib
diff --git a/x11-wm/afterstep/files/afterstep-2.2.9-libpng15.patch b/x11-wm/afterstep/files/afterstep-2.2.9-libpng15.patch
new file mode 100644
index 000000000000..b420489b3266
--- /dev/null
+++ b/x11-wm/afterstep/files/afterstep-2.2.9-libpng15.patch
@@ -0,0 +1,31 @@
+--- libAfterImage/export.c
++++ libAfterImage/export.c
+@@ -483,7 +483,7 @@
+ png_ptr = png_create_write_struct( PNG_LIBPNG_VER_STRING, NULL, NULL, NULL );
+ if ( png_ptr != NULL )
+ if( (info_ptr = png_create_info_struct(png_ptr)) != NULL )
+- if( setjmp(png_ptr->jmpbuf) )
++ if( setjmp(png_jmpbuf(png_ptr)) )
+ {
+ png_destroy_info_struct(png_ptr, (png_infopp) &info_ptr);
+ info_ptr = NULL ;
+--- libAfterImage/import.c
++++ libAfterImage/import.c
+@@ -1251,7 +1251,7 @@
+ * the normal method of doing things with libpng). REQUIRED unless you
+ * set up your own error handlers in the png_create_read_struct() earlier.
+ */
+- if ( !setjmp (png_ptr->jmpbuf))
++ if ( !setjmp (png_jmpbuf(png_ptr)))
+ {
+ ASFlagType rgb_flags = ASStorage_RLEDiffCompress|ASStorage_32Bit ;
+
+@@ -1468,7 +1468,7 @@
+
+ static void asim_png_read_data(png_structp png_ptr, png_bytep data, png_size_t length)
+ {
+- ASImPNGReadBuffer *buf = (ASImPNGReadBuffer *)png_ptr->io_ptr;
++ ASImPNGReadBuffer *buf = (ASImPNGReadBuffer *)png_get_io_ptr(png_ptr);
+ memcpy(data, buf->buffer, length);
+ buf->buffer += length;
+ }
diff --git a/x11-wm/afterstep/files/afterstep-2.2.9-make_session_data_file.patch b/x11-wm/afterstep/files/afterstep-2.2.9-make_session_data_file.patch
new file mode 100644
index 000000000000..2c2f8bfeee3d
--- /dev/null
+++ b/x11-wm/afterstep/files/afterstep-2.2.9-make_session_data_file.patch
@@ -0,0 +1,14 @@
+http://bugs.gentoo.org/308649
+
+asgtklookedit.c:658:3: warning: implicit declaration of function ‘make_session_data_file’
+
+--- libASGTK/asgtklookedit.c
++++ libASGTK/asgtklookedit.c
+@@ -28,6 +28,7 @@
+ #include "../libAfterStep/parser.h"
+ #include "../libAfterStep/freestor.h"
+ #include "../libAfterStep/mystyle.h"
++#include "../libAfterStep/session.h"
+ #include "../libAfterConf/afterconf.h"
+
+ #include <unistd.h>
diff --git a/x11-wm/afterstep/files/no-alternatives-2.2.9.patch b/x11-wm/afterstep/files/no-alternatives-2.2.9.patch
new file mode 100644
index 000000000000..4195413c5eed
--- /dev/null
+++ b/x11-wm/afterstep/files/no-alternatives-2.2.9.patch
@@ -0,0 +1,29 @@
+--- Makefile.in.orig 2008-08-08 18:59:39.000000000 +0200
++++ Makefile.in 2008-08-08 19:00:51.000000000 +0200
+@@ -71,7 +71,8 @@
+
+ module.clean:
+
+-install: install.alternative install.desktop install.wmprops mkdir
++#install: install.alternative install.desktop install.wmprops mkdir
++install: install.desktop install.wmprops mkdir
+ @for I in ${subdirs} ; do if [ -d $$I ]; then (cd $$I; ${MAKE} install || exit 1); fi; done
+
+ install.bin: mkdir.bin
+@@ -86,11 +87,11 @@
+ install.script: mkdir.bin
+ @for I in ${subdirs}; do if [ -d $$I ]; then (cd $$I; ${MAKE} install.script || exit 1); fi; done
+
+-install.alternative:
+- @if update-alternatives --version > /dev/null 2>&1 ; then \
+- update-alternatives --install /etc/alternatives/x-window-manager x-window-manager $(AFTER_BIN_DIR)/afterstep 100; \
+- echo "added AfterStep as an x-window-manager alternative"; \
+- fi
++#install.alternative:
++# @if update-alternatives --version > /dev/null 2>&1 ; then \
++# update-alternatives --install /etc/alternatives/x-window-manager x-window-manager $(AFTER_BIN_DIR)/afterstep 100; \
++# echo "added AfterStep as an x-window-manager alternative"; \
++# fi
+
+
+ install.desktop: AfterStep.desktop.final mkdir.share