summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2019-07-08 14:21:43 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2019-07-11 13:56:20 -0700
commitede3b5b2ac4e45b09943fec7c9c741e719af3988 (patch)
tree0941208417f0dbd654dbb7ff32bc99532f10dc2b /x11-wm/awesome
parentx11-wm/awesome: improve consistency of ebuilds before other changes (diff)
downloadgentoo-ede3b5b2ac4e45b09943fec7c9c741e719af3988.tar.gz
gentoo-ede3b5b2ac4e45b09943fec7c9c741e719af3988.tar.bz2
gentoo-ede3b5b2ac4e45b09943fec7c9c741e719af3988.zip
x11-wm/awesome: slotted lua5.1 for awesome-3.5
Package-Manager: Portage-2.3.67, Repoman-2.3.16 Signed-off-by: Robin H. Johnson <robbat2@gentoo.org>
Diffstat (limited to 'x11-wm/awesome')
-rw-r--r--x11-wm/awesome/awesome-3.5.9-r2.ebuild9
-rw-r--r--x11-wm/awesome/files/awesome-3.5.9-slotted-lua.patch51
2 files changed, 58 insertions, 2 deletions
diff --git a/x11-wm/awesome/awesome-3.5.9-r2.ebuild b/x11-wm/awesome/awesome-3.5.9-r2.ebuild
index 0a13897d09e6..31b4a95fd889 100644
--- a/x11-wm/awesome/awesome-3.5.9-r2.ebuild
+++ b/x11-wm/awesome/awesome-3.5.9-r2.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI="5"
@@ -14,7 +14,7 @@ KEYWORDS="amd64 arm ppc ppc64 x86 ~x86-fbsd"
IUSE="dbus doc elibc_FreeBSD gnome"
COMMON_DEPEND="
- >=dev-lang/lua-5.1:0
+ || ( >=dev-lang/lua-5.1:0 dev-lang/lua:5.1 )
dev-libs/glib:2
>=dev-libs/libxdg-basedir-1
>=dev-lua/lgi-0.7
@@ -53,13 +53,18 @@ PATCHES=(
"${FILESDIR}/${PN}-xsession.patch"
"${FILESDIR}/${PN}-3.5.5-util.lua-xdg-icons-fix.patch"
"${FILESDIR}/${PN}-3.5.5-cflag-cleanup.patch"
+ "${FILESDIR}/${PN}-3.5.9-slotted-lua.patch"
)
src_configure() {
+ has_version 'dev-lang/lua:5.1' \
+ && LUA=lua5.1 \
+ || LUA=lua
mycmakeargs=(
-DSYSCONFDIR="${EPREFIX}"/etc
$(cmake-utils_use_with dbus DBUS)
$(cmake-utils_use doc GENERATE_DOC)
+ -DLUA_EXECUTABLE="${EPREFIX}"/usr/bin/${LUA}
)
cmake-utils_src_configure
diff --git a/x11-wm/awesome/files/awesome-3.5.9-slotted-lua.patch b/x11-wm/awesome/files/awesome-3.5.9-slotted-lua.patch
new file mode 100644
index 000000000000..67f0d9810f44
--- /dev/null
+++ b/x11-wm/awesome/files/awesome-3.5.9-slotted-lua.patch
@@ -0,0 +1,51 @@
+diff -Nuar awesome-3.5.9.orig/build-utils/lgi-check.sh awesome-3.5.9/build-utils/lgi-check.sh
+--- awesome-3.5.9.orig/build-utils/lgi-check.sh 2016-03-06 14:05:54.000000000 +0000
++++ awesome-3.5.9/build-utils/lgi-check.sh 2019-01-23 21:36:35.973967623 +0000
+@@ -1,5 +1,7 @@
+ #!/bin/sh
+
++LUA=${LUA:=lua}
++
+ die()
+ {
+ exec >&2
+@@ -22,11 +24,11 @@
+ }
+
+ # Check if we have lgi
+-lua -e 'require("lgi")' || die
++$LUA -e 'require("lgi")' || die
+
+ # Check the version number
+ # Keep this in sync with lib/gears/surface.lua.in!
+-lua -e 'if tonumber(string.match(require("lgi.version"), "(%d%.%d)")) < 0.7 then error("lgi too old, need at least version 0.7.0") end' || die
++$LUA -e 'if tonumber(string.match(require("lgi.version"), "(%d%.%d)")) < 0.7 then error("lgi too old, need at least version 0.7.0") end' || die
+
+ # Check for the needed gi files
+-lua -e 'l = require("lgi") assert(l.cairo, l.Pango, l.PangoCairo)' || die
++$LUA -e 'l = require("lgi") assert(l.cairo, l.Pango, l.PangoCairo)' || die
+diff -Nuar awesome-3.5.9.orig/awesomeConfig.cmake awesome-3.5.9/awesomeConfig.cmake
+--- awesome-3.5.9.orig/awesomeConfig.cmake 2019-01-23 22:01:17.364046606 +0000
++++ awesome-3.5.9/awesomeConfig.cmake 2019-01-23 21:50:30.152919084 +0000
+@@ -66,6 +66,7 @@
+ include(FindPkgConfig)
+ # lua 5.1
+ include(FindLua51)
++set(ENV{LUA} "${LUA_EXECUTABLE}")
+ # }}}
+
+ # {{{ Check if documentation can be build
+diff -Nuar awesome-3.5.9.orig/CMakeLists.txt awesome-3.5.9/CMakeLists.txt
+--- awesome-3.5.9.orig/CMakeLists.txt 2016-03-06 14:05:54.000000000 +0000
++++ awesome-3.5.9/CMakeLists.txt 2019-01-23 22:00:08.715111414 +0000
+@@ -105,7 +105,9 @@
+
+ # check for lgi and the needed gobject introspection files
+ add_custom_target(lgi-check ALL
+- COMMAND ${SOURCE_DIR}/build-utils/lgi-check.sh)
++ COMMAND ${CMAKE_COMMAND} -E env LUA=${LUA_EXECUTABLE} ${SOURCE_DIR}/build-utils/lgi-check.sh
++ COMMENT "Verifying LGI module")
++# VERBATIM)
+
+ # atoms
+ file(MAKE_DIRECTORY ${BUILD_DIR}/common)