summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /x11-wm/blackbox
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'x11-wm/blackbox')
-rw-r--r--x11-wm/blackbox/Manifest1
-rw-r--r--x11-wm/blackbox/blackbox-0.70.1-r1.ebuild58
-rw-r--r--x11-wm/blackbox/blackbox-0.70.1.ebuild57
-rw-r--r--x11-wm/blackbox/files/blackbox-0.70.1-asneeded.patch49
-rw-r--r--x11-wm/blackbox/files/blackbox-0.70.1-gcc-4.3.patch106
-rw-r--r--x11-wm/blackbox/files/blackbox-0.70.1-no-LDFLAGS-pc.patch14
-rw-r--r--x11-wm/blackbox/files/blackbox.desktop7
-rw-r--r--x11-wm/blackbox/metadata.xml15
8 files changed, 307 insertions, 0 deletions
diff --git a/x11-wm/blackbox/Manifest b/x11-wm/blackbox/Manifest
new file mode 100644
index 000000000000..69a11eb83f3a
--- /dev/null
+++ b/x11-wm/blackbox/Manifest
@@ -0,0 +1 @@
+DIST blackbox-0.70.1.tar.bz2 492399 SHA256 92c2be347253f29b10063d579b4267a21516cb322a41b5e83d770fa6d44afd21 SHA512 6e8cf6fd04030a5f97ffd8dbe97aaa0f683f776e7237cdd46f2b93265cd8de665cffce5a352624a2235aa6c42628be13f98d565af765b3f06e95bff404fb0ccb WHIRLPOOL 8cab9c8ff749e4aea11bce5aca53127013cb5e36d791b426dded53dcf3db96590f6c43572df8ccd0f89e33b9ddfaa1f69cc1bda89cb7b85ec21298eba6730606
diff --git a/x11-wm/blackbox/blackbox-0.70.1-r1.ebuild b/x11-wm/blackbox/blackbox-0.70.1-r1.ebuild
new file mode 100644
index 000000000000..5a1ab87f0ac7
--- /dev/null
+++ b/x11-wm/blackbox/blackbox-0.70.1-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit autotools eutils
+
+DESCRIPTION="A small, fast, full-featured window manager for X"
+HOMEPAGE="http://blackboxwm.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}wm/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="nls truetype debug"
+
+RDEPEND="x11-libs/libXft
+ x11-libs/libXt
+ nls? ( sys-devel/gettext )
+ truetype? ( media-libs/freetype )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ >=sys-apps/sed-4
+ x11-proto/xextproto"
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-gcc-4.3.patch \
+ "${FILESDIR}"/${P}-asneeded.patch \
+ "${FILESDIR}"/${P}-no-LDFLAGS-pc.patch
+
+ sed -i -e "s/_XUTIL_H_/_X11&/" lib/Util.hh || die #348556
+ sed -e "s/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/" -i configure.ac || die
+
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ --sysconfdir=/etc/X11/${PN} \
+ $(use_enable debug) \
+ $(use_enable nls) \
+ $(use_enable truetype xft)
+}
+
+src_install() {
+ dodir /etc/X11/Sessions
+ echo "/usr/bin/blackbox" > "${D}/etc/X11/Sessions/${PN}"
+ fperms a+x /etc/X11/Sessions/${PN}
+
+ insinto /usr/share/xsessions
+ doins "${FILESDIR}/${PN}.desktop"
+
+ emake DESTDIR="${D}" install
+ dodoc AUTHORS ChangeLog* COMPLIANCE README* TODO
+
+ prune_libtool_files --all
+}
diff --git a/x11-wm/blackbox/blackbox-0.70.1.ebuild b/x11-wm/blackbox/blackbox-0.70.1.ebuild
new file mode 100644
index 000000000000..ee0d2f947287
--- /dev/null
+++ b/x11-wm/blackbox/blackbox-0.70.1.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+inherit autotools eutils
+
+DESCRIPTION="A small, fast, full-featured window manager for X"
+HOMEPAGE="http://blackboxwm.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}wm/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="alpha amd64 arm hppa ia64 ppc ppc64 sparc x86 ~x86-fbsd"
+IUSE="nls truetype debug"
+
+RDEPEND="x11-libs/libXft
+ x11-libs/libXt
+ nls? ( sys-devel/gettext )
+ truetype? ( media-libs/freetype )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ >=sys-apps/sed-4
+ x11-proto/xextproto"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ epatch "${FILESDIR}/${P}-gcc-4.3.patch" \
+ "${FILESDIR}/${P}-asneeded.patch"
+ if has_version ">=x11-libs/libX11-1.4.0"; then
+ sed -i -e "s/_XUTIL_H_/_X11&/" lib/Util.hh || die #348556
+ fi
+ sed -e "s/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/" -i configure.ac || die
+ eautoreconf
+}
+
+src_compile() {
+ econf \
+ --sysconfdir=/etc/X11/${PN} \
+ $(use_enable debug) \
+ $(use_enable nls) \
+ $(use_enable truetype xft)
+ emake || die "emake failed"
+}
+
+src_install() {
+ dodir /etc/X11/Sessions
+ echo "/usr/bin/blackbox" > "${D}/etc/X11/Sessions/${PN}"
+ fperms a+x /etc/X11/Sessions/${PN}
+
+ insinto /usr/share/xsessions
+ doins "${FILESDIR}/${PN}.desktop"
+
+ emake DESTDIR="${D}" install || die "emake install failed"
+ dodoc AUTHORS ChangeLog* COMPLIANCE README* TODO || die
+}
diff --git a/x11-wm/blackbox/files/blackbox-0.70.1-asneeded.patch b/x11-wm/blackbox/files/blackbox-0.70.1-asneeded.patch
new file mode 100644
index 000000000000..a6b1e22e62b5
--- /dev/null
+++ b/x11-wm/blackbox/files/blackbox-0.70.1-asneeded.patch
@@ -0,0 +1,49 @@
+Fixing build with as-needed. Enabling shared libs.
+
+http://bugs.gentoo.org/show_bug.cgi?id=248549
+
+--- src/Makefile.am
++++ src/Makefile.am
+@@ -22,7 +22,7 @@
+
+ DEFAULT_MENU = $(pkgdatadir)/menu
+ DEFAULT_STYLE = $(pkgdatadir)/styles/Gray
+-CPPFLAGS = @CPPFLAGS@ @SHAPE@ @XFT@ @DEBUG@ @NLS@ \
++AM_CPPFLAGS = @SHAPE@ @XFT@ @DEBUG@ @NLS@ \
+ -DLOCALEPATH=\"$(pkgdatadir)/nls\" \
+ -DDEFAULTMENU=\"$(DEFAULT_MENU)\" \
+ -DDEFAULTSTYLE=\"$(DEFAULT_STYLE)\" \
+--- lib/Makefile.am
++++ lib/Makefile.am
+@@ -62,7 +62,8 @@
+ Util.hh \
+ XDG.hh
+
+-libbt_la_LIBADD = @ICONV@ @LOCALE@
++libbt_la_LIBADD = @ICONV@ @LOCALE@ @xft_LIBS@
++libbt_la_CFLAGS = @xft_CFLAGS@
+
+ pkgconfigdir = $(libdir)/pkgconfig
+ nodist_pkgconfig_DATA = libbt.pc
+--- util/Makefile.am
++++ util/Makefile.am
+@@ -21,7 +21,7 @@
+ # FROM, OUT OF OR IN CONNECTION WITH THE SOFTWARE OR THE USE OR OTHER
+ # DEALINGS IN THE SOFTWARE.
+
+-CPPFLAGS = @CPPFLAGS@ @DEBUG@ @NLS@ \
++AM_CPPFLAGS = @DEBUG@ @NLS@ \
+ -I$(top_srcdir)/lib
+
+ bin_SCRIPTS = bsetbg
+--- configure.ac
++++ configure.ac
+@@ -29,7 +29,7 @@
+ AC_PROG_INSTALL
+
+ dnl libbt shouldn't be shared by default (yet)
+-AC_DISABLE_SHARED
++dnl AC_DISABLE_SHARED
+ AC_PROG_LIBTOOL
+ AC_SUBST(LIBTOOL_DEPS)
+
diff --git a/x11-wm/blackbox/files/blackbox-0.70.1-gcc-4.3.patch b/x11-wm/blackbox/files/blackbox-0.70.1-gcc-4.3.patch
new file mode 100644
index 000000000000..1026bd5c80ee
--- /dev/null
+++ b/x11-wm/blackbox/files/blackbox-0.70.1-gcc-4.3.patch
@@ -0,0 +1,106 @@
+diff -Naupr blackbox-0.70.1.orig/lib/Image.cc blackbox-0.70.1/lib/Image.cc
+--- blackbox-0.70.1.orig/lib/Image.cc 2005-04-08 17:41:09.000000000 +0200
++++ blackbox-0.70.1/lib/Image.cc 2008-02-24 08:31:28.000000000 +0100
+@@ -42,8 +42,9 @@
+
+ #include <assert.h>
+ #include <math.h>
+-#include <stdio.h>
+-#include <stdlib.h>
++#include <cstdio>
++#include <cstdlib>
++#include <cstring>
+
+ // #define COLORTABLE_DEBUG
+ // #define MITSHM_DEBUG
+diff -Naupr blackbox-0.70.1.orig/lib/Resource.cc blackbox-0.70.1/lib/Resource.cc
+--- blackbox-0.70.1.orig/lib/Resource.cc 2005-04-06 23:16:50.000000000 +0200
++++ blackbox-0.70.1/lib/Resource.cc 2008-02-24 08:33:11.000000000 +0100
+@@ -28,7 +28,8 @@
+ #include <X11/Xlib.h>
+ #include <X11/Xresource.h>
+
+-#include <stdio.h>
++#include <cstdio>
++#include <cstring>
+
+
+ bt::Resource::Resource(void)
+diff -Naupr blackbox-0.70.1.orig/lib/XDG.cc blackbox-0.70.1/lib/XDG.cc
+--- blackbox-0.70.1.orig/lib/XDG.cc 2005-04-06 16:04:38.000000000 +0200
++++ blackbox-0.70.1/lib/XDG.cc 2008-02-24 08:34:11.000000000 +0100
+@@ -25,7 +25,8 @@
+ #include "Util.hh"
+ #include "XDG.hh"
+
+-#include <stdlib.h>
++#include <cstdlib>
++#include <algorithm>
+
+
+ // make sure directory names end with a slash
+diff -Naupr blackbox-0.70.1.orig/src/BlackboxResource.cc blackbox-0.70.1/src/BlackboxResource.cc
+--- blackbox-0.70.1.orig/src/BlackboxResource.cc 2005-10-18 09:34:46.000000000 +0200
++++ blackbox-0.70.1/src/BlackboxResource.cc 2008-02-24 08:34:49.000000000 +0100
+@@ -33,6 +33,8 @@
+ #include <X11/Xutil.h>
+ #include <X11/cursorfont.h>
+
++#include <cstring>
++
+
+ BlackboxResource::BlackboxResource(const std::string& rc): rc_file(rc) {
+ screen_resources = 0;
+diff -Naupr blackbox-0.70.1.orig/src/main.cc blackbox-0.70.1/src/main.cc
+--- blackbox-0.70.1.orig/src/main.cc 2005-01-03 10:42:57.000000000 +0100
++++ blackbox-0.70.1/src/main.cc 2008-02-24 08:37:16.000000000 +0100
+@@ -34,7 +34,8 @@
+ #include "blackbox.hh"
+ #include "../version.h"
+
+-#include <stdio.h>
++#include <cstdio>
++#include <cstring>
+
+
+ static void showHelp(int exitval) {
+diff -Naupr blackbox-0.70.1.orig/src/Screen.cc blackbox-0.70.1/src/Screen.cc
+--- blackbox-0.70.1.orig/src/Screen.cc 2005-10-18 10:07:22.000000000 +0200
++++ blackbox-0.70.1/src/Screen.cc 2008-02-24 08:35:46.000000000 +0100
+@@ -45,8 +45,9 @@
+ #include <sys/types.h>
+ #include <sys/stat.h>
+ #include <assert.h>
+-#include <ctype.h>
+ #include <dirent.h>
++#include <cctype>
++#include <cstring>
+
+
+ static bool running = true;
+diff -Naupr blackbox-0.70.1.orig/src/ScreenResource.cc blackbox-0.70.1/src/ScreenResource.cc
+--- blackbox-0.70.1.orig/src/ScreenResource.cc 2005-04-13 07:54:08.000000000 +0200
++++ blackbox-0.70.1/src/ScreenResource.cc 2008-02-24 08:36:31.000000000 +0100
+@@ -33,6 +33,8 @@
+
+ #include <assert.h>
+
++#include <cstring>
++
+
+ static const int iconify_width = 9;
+ static const int iconify_height = 9;
+diff -Naupr blackbox-0.70.1.orig/util/bsetroot.cc blackbox-0.70.1/util/bsetroot.cc
+--- blackbox-0.70.1.orig/util/bsetroot.cc 2005-03-15 08:01:37.000000000 +0100
++++ blackbox-0.70.1/util/bsetroot.cc 2008-02-24 08:38:41.000000000 +0100
+@@ -30,7 +30,9 @@
+ #include <cctype>
+
+ #include <X11/Xatom.h>
+-#include <stdio.h>
++#include <cstdio>
++#include <cstdlib>
++#include <cstring>
+
+
+ // ignore all X errors
diff --git a/x11-wm/blackbox/files/blackbox-0.70.1-no-LDFLAGS-pc.patch b/x11-wm/blackbox/files/blackbox-0.70.1-no-LDFLAGS-pc.patch
new file mode 100644
index 000000000000..e907b588b158
--- /dev/null
+++ b/x11-wm/blackbox/files/blackbox-0.70.1-no-LDFLAGS-pc.patch
@@ -0,0 +1,14 @@
+Fix LDFGAS leak to .pc file:
+> * QA Notice: pkg-config files with wrong LDFLAGS detected:
+> * /usr/lib64/pkgconfig/libbt.pc:Libs: -L${libdir} -lbt -Wl,-O1 -Wl,--as-needed -Wl,--hash-style=gnu -L/usr/lib -L/usr/local/lib
+diff --git a/lib/libbt.pc.in b/lib/libbt.pc.in
+index a2a8869..8246cb0 100644
+--- a/lib/libbt.pc.in
++++ b/lib/libbt.pc.in
+@@ -7,5 +7,5 @@ Name: Blackbox Toolbox
+ Description: Utility class library for writing small applications
+ Requires: @XFT_PKGCONFIG@
+ Version: @VERSION@
+-Libs: -L${libdir} -lbt @LDFLAGS@ @ICONV@ @LOCALE@
++Libs: -L${libdir} -lbt @ICONV@ @LOCALE@
+ Cflags: -I${includedir}/bt
diff --git a/x11-wm/blackbox/files/blackbox.desktop b/x11-wm/blackbox/files/blackbox.desktop
new file mode 100644
index 000000000000..c84ce24a2a53
--- /dev/null
+++ b/x11-wm/blackbox/files/blackbox.desktop
@@ -0,0 +1,7 @@
+[Desktop Entry]
+Name=Blackbox
+Comment=This session logs you into Blackbox
+Exec=blackbox
+TryExec=blackbox
+Icon=
+Type=Application
diff --git a/x11-wm/blackbox/metadata.xml b/x11-wm/blackbox/metadata.xml
new file mode 100644
index 000000000000..0deb53ae1fa4
--- /dev/null
+++ b/x11-wm/blackbox/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer>
+ <email>maintainer-needed@gentoo.org</email>
+ </maintainer>
+ <longdescription>
+ Blackbox is that fast, light window manager you have been looking for
+ without all those annoying library dependencies. If you have a C++
+ compiler and the X Window System you can compile and use it.
+ </longdescription>
+ <upstream>
+ <remote-id type="sourceforge">blackboxwm</remote-id>
+ </upstream>
+</pkgmetadata>