summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2017-04-12 22:14:29 +0200
committerJeroen Roovers <jer@gentoo.org>2017-04-12 22:14:58 +0200
commit403a8f6b51b86d0ef614c1aa590b3e10b4fca89a (patch)
tree2eb26e34882056165bc163a27a0eebcb385d34f5 /x11-wm/ratpoison/ratpoison-1.4.9.ebuild
parentx11-wm/ratpoison: Old. (diff)
downloadgentoo-403a8f6b51b86d0ef614c1aa590b3e10b4fca89a.tar.gz
gentoo-403a8f6b51b86d0ef614c1aa590b3e10b4fca89a.tar.bz2
gentoo-403a8f6b51b86d0ef614c1aa590b3e10b4fca89a.zip
x11-wm/ratpoison: Version bump.
Package-Manager: Portage-2.3.5, Repoman-2.3.2
Diffstat (limited to 'x11-wm/ratpoison/ratpoison-1.4.9.ebuild')
-rw-r--r--x11-wm/ratpoison/ratpoison-1.4.9.ebuild99
1 files changed, 99 insertions, 0 deletions
diff --git a/x11-wm/ratpoison/ratpoison-1.4.9.ebuild b/x11-wm/ratpoison/ratpoison-1.4.9.ebuild
new file mode 100644
index 000000000000..f0c2e4dc948d
--- /dev/null
+++ b/x11-wm/ratpoison/ratpoison-1.4.9.ebuild
@@ -0,0 +1,99 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit elisp-common eutils toolchain-funcs
+
+DESCRIPTION="window manager without mouse dependency"
+HOMEPAGE="http://www.nongnu.org/ratpoison/"
+SRC_URI="http://download.savannah.gnu.org/releases/${PN}/${P}.tar.xz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86 ~x86-fbsd ~amd64-linux ~x86-linux"
+IUSE="debug emacs +history sloppy +xft +xrandr"
+
+RDEPEND="
+ emacs? ( virtual/emacs )
+ history? ( sys-libs/readline:= )
+ xft? ( x11-libs/libXft )
+ xrandr? ( x11-libs/libXrandr )
+ virtual/perl-Pod-Parser
+ x11-libs/libXtst
+"
+DEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+ x11-proto/randrproto
+ x11-proto/xproto
+"
+
+SITEFILE=50ratpoison-gentoo.el
+DOCS=(
+ AUTHORS
+ ChangeLog
+ NEWS
+ README
+ TODO
+)
+
+PATCHES=(
+ "${FILESDIR}"/ratpoison.el-gentoo.patch
+)
+
+src_configure() {
+ econf \
+ $(use_enable debug) \
+ $(use_enable history) \
+ $(use_with xft) \
+ $(use_with xrandr) \
+ --without-electric-fence
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}"
+ if use emacs; then
+ elisp-compile contrib/ratpoison.el || die
+ fi
+
+ if use sloppy; then
+ pushd contrib
+ $(tc-getCC) \
+ ${CFLAGS} \
+ ${LDFLAGS} \
+ -o sloppy{,.c} \
+ $( $(tc-getPKG_CONFIG) --libs x11) \
+ || die
+ fi
+}
+
+src_install() {
+ default
+
+ exeinto /etc/X11/Sessions
+ newexe "${FILESDIR}"/ratpoison.xsession ratpoison
+
+ insinto /usr/share/xsessions
+ doins "${FILESDIR}"/${PN}.desktop
+
+ use sloppy && dobin contrib/sloppy
+
+ docinto example
+ dodoc contrib/{genrpbindings,split.sh} \
+ doc/{ipaq.ratpoisonrc,sample.ratpoisonrc}
+
+ rm -rf "${ED}/usr/share/"{doc/ratpoison,ratpoison}
+
+ if use emacs; then
+ elisp-install ${PN} contrib/ratpoison.*
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}