summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergei Trofimovich <slyfox@gentoo.org>2017-02-16 20:53:58 +0000
committerSergei Trofimovich <slyfox@gentoo.org>2017-02-16 21:56:57 +0000
commit6b54bfe8d03126a1bf063721177a198ead3916e9 (patch)
treeee69fb4f54a9239d11f27772512eec5820daa0cd /x11-wm/xmonad
parentdev-haskell/x11: bump up to 1.8 (diff)
downloadgentoo-6b54bfe8d03126a1bf063721177a198ead3916e9.tar.gz
gentoo-6b54bfe8d03126a1bf063721177a198ead3916e9.tar.bz2
gentoo-6b54bfe8d03126a1bf063721177a198ead3916e9.zip
x11-wm/xmonad: bump up to 0.13
Package-Manager: Portage-2.3.3, Repoman-2.3.1
Diffstat (limited to 'x11-wm/xmonad')
-rw-r--r--x11-wm/xmonad/Manifest1
-rw-r--r--x11-wm/xmonad/xmonad-0.13.ebuild79
2 files changed, 80 insertions, 0 deletions
diff --git a/x11-wm/xmonad/Manifest b/x11-wm/xmonad/Manifest
index b0d194639aff..308d86df9852 100644
--- a/x11-wm/xmonad/Manifest
+++ b/x11-wm/xmonad/Manifest
@@ -1,3 +1,4 @@
DIST xmonad-0.11.1.tar.gz 59307 SHA256 39e0bf227df782d7a5799c811ad0d8b70c9d6eaaa94e8cc395fcf25895d6d2dd SHA512 4916451d81d359dbbf508f3b20f649f956255f526f14b1eb6c0d32bc789474db30d7acac768663ca32784c7fe361195a50f45a7cb7371ee9a29c9b8f1c64d528 WHIRLPOOL 5707bd5763f525b196deea6ead806af74707e2bbd31ff67039b292f3b97f607c2351ef45e57373f0f7313e5c307335cb5f4a84820d8e658b7d864927f109891c
DIST xmonad-0.11.tar.gz 59119 SHA256 e5bd36d5184facad66acf2688b02922bfc6de32b576758f4b00688253c425bdb SHA512 34740f032508584f34f6b138d21394eca17e8020bccc4d8c6e8b3cb6b7ca64b153077cfd16636a6130768ebd145fe993569f8a229862d7816d0c89c905ee08bc WHIRLPOOL 9bab495c4094f21427afa797f97b6af13d9c156484b33087b6378191b0d99255f070adc09df3da9eba3ff55a59a8f03830110a4ab2aa9ad9d93d2f1a35d5dc54
DIST xmonad-0.12.tar.gz 61436 SHA256 e8f649dbd4a8d5f75fdac9ceb5ee38b64fd351910ade81c188f5dd7bc21dfdd7 SHA512 e519c038d90db037bc81e7baf7b07cfa53922509e98ffddacfc4a6cc2c7376383be1e721f613057a5febbfcc661807b6382124eb673ac7a7cda23c738d3539ab WHIRLPOOL f0d37d35a9730b68b38c46ec7694ccd922b2fab96b3e8d99d007ccb887a06b3f88e6f1ea818124d427378246caab1f7d3ec4338eab1007431cdf5a19fc1cc3b9
+DIST xmonad-0.13.tar.gz 72034 SHA256 f9f81b63569f18c777a939741024ec3ae34e4ec84015e5cc50f6622034a303ca SHA512 9d9436f36fe0f6a9732502b0211fc41a224b1320b843d266b6d2dd201e4329b688f7eed5b08597b2edd713cc25f2b88a2a1f1ee43e18615c0a78e97e4716b122 WHIRLPOOL 3c845bc562b60b6af46d259b5f162fc2b0545401e85eb1eace8494abeeb121ea78f8ecb1e58260dd7b2a7762d25d71e045997ca798efa79dba21ef19c4cd59f8
diff --git a/x11-wm/xmonad/xmonad-0.13.ebuild b/x11-wm/xmonad/xmonad-0.13.ebuild
new file mode 100644
index 000000000000..d6a98d459d1d
--- /dev/null
+++ b/x11-wm/xmonad/xmonad-0.13.ebuild
@@ -0,0 +1,79 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+# ebuild generated by hackport 0.5.1.9999
+#hackport: flags: -generatemanpage,-testing,-profiling
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour test-suite"
+inherit haskell-cabal
+
+DESCRIPTION="A tiling window manager"
+HOMEPAGE="http://xmonad.org"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="+default-term"
+
+RDEPEND="dev-haskell/data-default:=[profile?]
+ dev-haskell/extensible-exceptions:=[profile?]
+ dev-haskell/mtl:=[profile?]
+ dev-haskell/setlocale:=[profile?]
+ >=dev-haskell/utf8-string-0.3:=[profile?] <dev-haskell/utf8-string-1.1:=[profile?]
+ >=dev-haskell/x11-1.8:=[profile?] <dev-haskell/x11-1.9:=[profile?]
+ >=dev-lang/ghc-8.0.1:=
+"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.24.0.0
+ test? ( >=dev-haskell/quickcheck-2 )
+"
+PDEPEND="default-term? ( x11-terms/xterm )
+ x11-apps/xmessage
+"
+
+DOCS=( CONFIG README.md CHANGES.md )
+HTML_DOCS=( man/xmonad.1.html )
+
+src_configure() {
+ haskell-cabal_src_configure \
+ --flag=-generatemanpage \
+ --flag=-profiling \
+ --flag=-testing
+}
+
+src_install() {
+ default
+
+ cabal_src_install
+
+ echo -e "#!/bin/sh\n/usr/bin/xmonad" > "${T}/${PN}"
+ exeinto /etc/X11/Sessions
+ doexe "${T}/${PN}"
+
+ insinto /usr/share/xsessions
+ doins "${FILESDIR}/${PN}.desktop"
+
+ doman man/xmonad.1
+}
+
+pkg_postinst() {
+ haskell-cabal_pkg_postinst
+
+ elog "A sample ${SAMPLE_CONFIG} configuration file can be found here:"
+ elog " /usr/share/${PF}/ghc-$(ghc-version)/man/xmonad.hs"
+ elog "The parameters in this file are the defaults used by xmonad."
+ elog "To customize xmonad, copy this file to:"
+ elog " ~/.xmonad/${SAMPLE_CONFIG}"
+ elog "After editing, use 'mod-q' to dynamically restart xmonad "
+ elog "(where the 'mod' key defaults to 'Alt')."
+ elog ""
+ elog "Read the README or man page for more information, and to see "
+ elog "other possible configurations go to:"
+ elog " http://haskell.org/haskellwiki/Xmonad/Config_archive"
+ elog "Please note that many of these configurations will require the "
+ elog "x11-wm/xmonad-contrib package to be installed."
+}