summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-06-05 08:55:46 +0200
committerJeroen Roovers <jer@gentoo.org>2020-06-05 08:56:20 +0200
commit06fc5c14cc1e8703d56a2ba3b8b737e361970aa7 (patch)
tree8eadcdc16c250b962b0a432417abc27cffd1d423 /x11-wm
parentdev-ruby/i18n: amd64 stable (diff)
downloadgentoo-06fc5c14cc1e8703d56a2ba3b8b737e361970aa7.tar.gz
gentoo-06fc5c14cc1e8703d56a2ba3b8b737e361970aa7.tar.bz2
gentoo-06fc5c14cc1e8703d56a2ba3b8b737e361970aa7.zip
x11-wm/dwm: Use savedconfig in live ebuild
Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/dwm/dwm-9999.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/x11-wm/dwm/dwm-9999.ebuild b/x11-wm/dwm/dwm-9999.ebuild
index 900dc238896c..4b464a12ac2f 100644
--- a/x11-wm/dwm/dwm-9999.ebuild
+++ b/x11-wm/dwm/dwm-9999.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit git-r3 toolchain-funcs
+inherit git-r3 savedconfig toolchain-funcs
DESCRIPTION="a dynamic window manager for X11"
HOMEPAGE="https://dwm.suckless.org/"
@@ -31,6 +31,8 @@ src_prepare() {
-e "s/ -Os / /" \
-e "/^\(LDFLAGS\|CFLAGS\|CPPFLAGS\)/{s| = | += |g;s|-s ||g}" \
config.mk || die
+
+ restore_config config.h
}
src_compile() {
@@ -51,4 +53,6 @@ src_install() {
doins "${FILESDIR}"/dwm.desktop
dodoc README
+
+ save_config config.h
}