summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorNelo-T. Wallus <nelo@wallus.de>2020-11-16 23:04:22 +0100
committerLars Wendler <polynomial-c@gentoo.org>2020-11-17 00:26:10 +0100
commit5493d458d8a44802b86ef5e6d3d045693ef66ac2 (patch)
treeac0e9633bc9e2b119ccb582c68b4d2f47e14c3d6 /x11-wm
parentdev-lang/maude: respect AR (diff)
downloadgentoo-5493d458d8a44802b86ef5e6d3d045693ef66ac2.tar.gz
gentoo-5493d458d8a44802b86ef5e6d3d045693ef66ac2.tar.bz2
gentoo-5493d458d8a44802b86ef5e6d3d045693ef66ac2.zip
x11-wm/i3: Bump to v4.19
Package-Manager: Portage-3.0.9, Repoman-3.0.2 Signed-off-by: Nelo-T. Wallus <nelo@wallus.de> Closes: https://github.com/gentoo/gentoo/pull/18289 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/i3/Manifest1
-rw-r--r--x11-wm/i3/i3-4.19.ebuild106
-rw-r--r--x11-wm/i3/i3-9999.ebuild2
3 files changed, 108 insertions, 1 deletions
diff --git a/x11-wm/i3/Manifest b/x11-wm/i3/Manifest
index f4ce02652a2d..231429f4aa1e 100644
--- a/x11-wm/i3/Manifest
+++ b/x11-wm/i3/Manifest
@@ -4,3 +4,4 @@ DIST i3-4.18.1.tar.bz2 1217703 BLAKE2B 469a6ac09004f95861655858c47d9e6b2f378152b
DIST i3-4.18.2.tar.bz2 1218440 BLAKE2B 55fba66b2399730cb3bc63d76efff18a439aad755c943f06d7622bd7c4d91502b3750cff638b98ef86d6f99746bc1858ffbd9396e2d89a7220f513575879e08a SHA512 997c7cdf32f95ba25cfcd483a09f7e37e5219e4501baefa5c1865ddffd206bc9725211e4082663fab4174dc947b663ff454d343a7e30340ac3ea451f999417fc
DIST i3-4.18.3.tar.bz2 1218766 BLAKE2B c394bbe9882dc893107f0c948632a3a79c52db75b75b2890f6f43fa60d80ce82d1c8a8c32a8793f59d9a6f929ab038765dbe3813c3c6bc1b79bebbbbde772451 SHA512 61599b79247ec546819bab22666a78fc8dc77eecbcf6055efb6b52720290fa7f72719ac6670396a6dfb54858781e438b5207c15fdf2cf9e2424a1b84ffeb749c
DIST i3-4.18.tar.bz2 1218591 BLAKE2B 582b7ba3a54edf8dd2657add05eb54a64b7c004761a1a248d91dfcb061cb9df215ff35301c125b11aa69b571daeacd5732b498934c1fb17f69404a101fd16ec8 SHA512 0bbfda7f4b20a92a50ffb6abbfc3f6bfe6bb4c987ad4b5b1791192eb23b8c3389cc9949a699901797370c14de1ff8e12447a3b8ce330ab7d300fafdb60a432ec
+DIST i3-4.19.tar.xz 1278600 BLAKE2B 3af5eac9cb618bc3b3da0bca430e1882701802f49e092d1e6fa7a35ceb3f2c0287b66eceeb0123a7dfda9976df06227bec34d7d98873aedc2292a2ba94584d84 SHA512 e9e85dfa099751e95f05e8ed5048535bc669d73c51d3bd7e83740ee79d613f981a1130c35f54fb4725b31d18bed63d6bd5efacce8e086483e28d7c778407653a
diff --git a/x11-wm/i3/i3-4.19.ebuild b/x11-wm/i3/i3-4.19.ebuild
new file mode 100644
index 000000000000..1f996455176e
--- /dev/null
+++ b/x11-wm/i3/i3-4.19.ebuild
@@ -0,0 +1,106 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit meson virtualx
+if [[ "${PV}" = *9999 ]]; then
+ inherit git-r3
+fi
+
+DESCRIPTION="An improved dynamic tiling window manager"
+HOMEPAGE="https://i3wm.org/"
+if [[ "${PV}" = *9999 ]]; then
+ EGIT_REPO_URI="https://github.com/i3/i3"
+ EGIT_BRANCH="next"
+else
+ SRC_URI="https://i3wm.org/downloads/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+fi
+
+LICENSE="BSD"
+SLOT="0"
+IUSE="doc test"
+
+CDEPEND="dev-libs/libev
+ dev-libs/libpcre
+ dev-libs/yajl
+ x11-libs/libxcb[xkb]
+ x11-libs/libxkbcommon[X]
+ x11-libs/startup-notification
+ x11-libs/xcb-util
+ x11-libs/xcb-util-cursor
+ x11-libs/xcb-util-keysyms
+ x11-libs/xcb-util-wm
+ x11-libs/xcb-util-xrm
+ x11-misc/xkeyboard-config
+ x11-libs/cairo[X,xcb(+)]
+ x11-libs/pango[X]"
+DEPEND="${CDEPEND}
+ test? (
+ dev-perl/AnyEvent
+ dev-perl/X11-XCB
+ dev-perl/Inline
+ dev-perl/Inline-C
+ dev-perl/IPC-Run
+ dev-perl/ExtUtils-PkgConfig
+ dev-perl/local-lib
+ virtual/perl-Test-Simple
+ x11-base/xorg-server[xephyr]
+ x11-misc/xvfb-run
+ )
+ doc? (
+ app-text/asciidoc
+ app-text/xmlto
+ dev-lang/perl
+ )"
+RDEPEND="${CDEPEND}
+ dev-lang/perl
+ dev-perl/AnyEvent-I3
+ dev-perl/JSON-XS"
+BDEPEND="virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-4.16-musl-GLOB_TILDE.patch"
+)
+
+src_prepare() {
+ default
+
+ cat <<- EOF > "${T}"/i3wm
+ #!/bin/sh
+ exec /usr/bin/i3
+ EOF
+}
+
+src_configure() {
+ local emesonargs=(
+ $(meson_use doc docs)
+ $(meson_use doc mans)
+ )
+
+ meson_src_configure
+}
+
+src_install() {
+ default
+
+ exeinto /etc/X11/Sessions
+ doexe "${T}"/i3wm
+}
+
+src_test() {
+ virtx meson_src_test
+}
+
+pkg_postinst() {
+ # Only show the elog information on a new install
+ if [[ ! ${REPLACING_VERSIONS} ]]; then
+ elog "There are several packages that you may find useful with ${PN} and"
+ elog "their usage is suggested by the upstream maintainers, namely:"
+ elog " x11-misc/dmenu"
+ elog " x11-misc/i3status"
+ elog " x11-misc/i3lock"
+ elog "Please refer to their description for additional info."
+ fi
+}
diff --git a/x11-wm/i3/i3-9999.ebuild b/x11-wm/i3/i3-9999.ebuild
index 01355605396d..1f996455176e 100644
--- a/x11-wm/i3/i3-9999.ebuild
+++ b/x11-wm/i3/i3-9999.ebuild
@@ -14,7 +14,7 @@ if [[ "${PV}" = *9999 ]]; then
EGIT_REPO_URI="https://github.com/i3/i3"
EGIT_BRANCH="next"
else
- SRC_URI="https://i3wm.org/downloads/${P}.tar.bz2"
+ SRC_URI="https://i3wm.org/downloads/${P}.tar.xz"
KEYWORDS="~amd64 ~arm ~arm64 ~x86"
fi