summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorDavid Seifert <soap@gentoo.org>2022-06-13 14:57:12 +0200
committerDavid Seifert <soap@gentoo.org>2022-06-13 14:57:12 +0200
commit766fe574ef971a60a0e1fb308db0c979e90f9ab0 (patch)
tree2114f37d5cac494539e37dd784dde08155a396fc /x11-wm
parentx11-wm/notion: update EAPI 7 -> 8 (diff)
downloadgentoo-766fe574ef971a60a0e1fb308db0c979e90f9ab0.tar.gz
gentoo-766fe574ef971a60a0e1fb308db0c979e90f9ab0.tar.bz2
gentoo-766fe574ef971a60a0e1fb308db0c979e90f9ab0.zip
x11-wm/notion: add 4.0.2_p20220613
Closes: https://bugs.gentoo.org/813123 Signed-off-by: David Seifert <soap@gentoo.org>
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/notion/Manifest1
-rw-r--r--x11-wm/notion/notion-4.0.2_p20220613.ebuild93
2 files changed, 94 insertions, 0 deletions
diff --git a/x11-wm/notion/Manifest b/x11-wm/notion/Manifest
index a52bb27879bf..2a557101b588 100644
--- a/x11-wm/notion/Manifest
+++ b/x11-wm/notion/Manifest
@@ -1 +1,2 @@
DIST notion-3_p2015061300.tar.gz 797057 BLAKE2B 55258bb1d47a1c2506e9cb6654e5d68d69494a749174eaace2a53416ae40cac908b0398400a5a377dbb07618aa800529cbdfc0c7ef946d285681e1dfccfd9c48 SHA512 254be12a8ece555d9f6253d99891bb51214379d0c04b6bf9595b7e5bf9493cb5d2fada37438f89621e7157f9e3647e446b5e173847498ee3608081f006b86679
+DIST notion-4.0.2_p20220613.tar.gz 791823 BLAKE2B 2aa50eb4f710bf289dd6edb6f4696662e8d2588b337f038845efdf79aa2e2b28a725734c829de5184def6fd5d32c51f511025dadf4ad6a689c0dc4e0b0d8e3eb SHA512 7c187571a00bdf5736032c0ff0b57a0afdb20a7b4f6e66877c84bf112922ec8f5b853165d419ecc7c18fc84a873b278c3cbdad5e7399e0312066141de1dc6673
diff --git a/x11-wm/notion/notion-4.0.2_p20220613.ebuild b/x11-wm/notion/notion-4.0.2_p20220613.ebuild
new file mode 100644
index 000000000000..6ba63e41d144
--- /dev/null
+++ b/x11-wm/notion/notion-4.0.2_p20220613.ebuild
@@ -0,0 +1,93 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-4 )
+
+inherit lua-single toolchain-funcs readme.gentoo-r1
+
+DESCRIPTION="Notion is a tiling, tabbed window manager for the X window system"
+HOMEPAGE="https://notionwm.net/"
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/raboof/${PN}.git"
+else
+ inherit vcs-snapshot
+ COMMIT="f161c1b4dbba1ac81d8e9c3d7e5e353058a4d7d1"
+ SRC_URI="https://github.com/raboof/${PN}/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="nls xinerama +xrandr"
+# needs slingshot,... not in tree
+RESTRICT="test"
+# mod_xrandr references mod_xinerama
+REQUIRED_USE="
+ ${LUA_REQUIRED_USE}
+ xrandr? ( xinerama )"
+
+RDEPEND="
+ ${LUA_DEPS}
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXext
+ nls? ( sys-devel/gettext )
+ xinerama? ( x11-libs/libXinerama )
+ xrandr? ( x11-libs/libXrandr )"
+DEPEND="${RDEPEND}"
+# luac is called at build time
+BDEPEND="
+ ${LUA_DEPS}
+ virtual/pkgconfig"
+
+src_configure() {
+ tc-export AR CC PKG_CONFIG
+ export INSTALL_STRIP=""
+
+ cat > system-local.mk <<- _EOF_ || die
+ PREFIX=${EPREFIX}/usr
+ DOCDIR=\$(PREFIX)/share/doc/${PF}
+ ETCDIR=${EPREFIX}/etc/${PN}
+ LIBDIR=\$(PREFIX)/$(get_libdir)
+ VARDIR=${EPREFIX}/var/cache/${PN}
+ LUA_MANUAL=1
+ LUA=${LUA}
+ LUAC=${BROOT}/usr/bin/${ELUA/lua/luac}
+ LUA_LIBS=$(lua_get_LIBS)
+ LUA_INCLUDES=$(lua_get_CFLAGS)
+ $(usev !nls "DEFINES+=-DCF_NO_LOCALE -DCF_NO_GETTEXT")
+ _EOF_
+
+ if ! use xinerama ; then
+ sed -e 's/mod_xinerama//g' -i modulelist.mk || die
+ fi
+
+ if ! use xrandr ; then
+ sed -e 's/mod_xrandr//g' -i modulelist.mk || die
+ sed -e '/mod_xrandr/d' -i etc/cfg_defaults.lua || die
+ fi
+}
+
+src_install() {
+ default
+
+ exeinto /etc/X11/Sessions
+ doexe "${FILESDIR}"/notion
+
+ insinto /usr/share/xsessions
+ doins "${FILESDIR}"/notion.desktop
+
+ local DOC_CONTENTS="
+ If you want notion to have an ability to view a file based on its
+ guessed MIME type you should emerge app-misc/run-mailcap."
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ readme.gentoo_print_elog
+}