summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2015-10-09 08:48:41 -0400
committerMike Frysinger <vapier@gentoo.org>2015-10-09 08:50:17 -0400
commit7e9fcb6e16c656c9ff360cda2e520c2676ca2248 (patch)
tree395274ff11bfeb66664a546294d51532f7bc9dc2 /x11-wm
parentx11-wm/enlightenment: drop old e17 versions (diff)
downloadgentoo-7e9fcb6e16c656c9ff360cda2e520c2676ca2248.tar.gz
gentoo-7e9fcb6e16c656c9ff360cda2e520c2676ca2248.tar.bz2
gentoo-7e9fcb6e16c656c9ff360cda2e520c2676ca2248.zip
x11-wm/enlightenment: version bump to 0.19.12 #561304
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/enlightenment/Manifest1
-rw-r--r--x11-wm/enlightenment/enlightenment-0.19.12.ebuild92
2 files changed, 93 insertions, 0 deletions
diff --git a/x11-wm/enlightenment/Manifest b/x11-wm/enlightenment/Manifest
index 4372f518ddd9..2e56dc6e42e4 100644
--- a/x11-wm/enlightenment/Manifest
+++ b/x11-wm/enlightenment/Manifest
@@ -6,3 +6,4 @@ DIST e16-1.0.16.tar.gz 2395638 SHA256 a50ecbcf1cf239a5b36cc592364b2b1ee8e4135098
DIST e16-1.0.17.tar.gz 2417299 SHA256 41ed67b648acc9b570cc681cf69d0accf38b69fd5d0af6b8ea8a6eacbf87659d SHA512 d6ad565cf638de5240fbcd0f1cd37977c69e6af31a4ff9127e9c570fdf57a56bde50978620fbc34508d02661effa17f0c8b91ca23faebc0b77f9d40e166ba021 WHIRLPOOL d4996798db0ce676c0cdce8bc6a354fcb6649ee4a9c579dc4c51beaeb96d7dcd2dfe0f063ead6724b21bb9f7f66608596412a251df0c2670b944f7376cb3e504
DIST enlightenment-0.18.8.tar.bz2 27616548 SHA256 e99b1d8a9c64dad80611310bd3dc3a7b6d9eaefbd21d0f4a3c350aed9137ca13 SHA512 8ba767b7004c78130eda315a4b7c06d5dcd4034e4d9ef588d0012eca70fb677cff8f9a81bb5a33e6e8891d52f9f93e0f1cf4d3fadec505afd6c1f476b964fe73 WHIRLPOOL edbd586f1c00574457fe2123d1a0c86e00b8c949abf04677535b0d4378bc66822cc72f48138be622a8c671f40f65fe5ce42b6d8af3f96259b15136981f556994
DIST enlightenment-0.19.10.tar.xz 24594372 SHA256 8bdc2b764765e807df263962cb3c4793256a34ce74cf854f623a47859f7a4f5d SHA512 c9ee8e9a6a6575103cb1785fc478cfdcd7c544e21eb8738d3877f8742fb0250bae751ae7d05b6b57b7ca37c7011e7ae183da1aa251233c85dd7e38a23f897243 WHIRLPOOL a0d320c52850de00db1a2778f2d71be58b0567854e0c07e03b00ef42f8b94a00abff0616ae389831a117a37a1f554f6e41474e9e8fec0186a8079f970d1db977
+DIST enlightenment-0.19.12.tar.xz 24569084 SHA256 55f23c337e3092e735ae37ada8f6701adab5ddd13f37ef38c63eec8a536f0b25 SHA512 30332fa0108a4361dd7cc961325b607fccef99caa1db6eaf068fc97de9978ad21dde5724a7e8f6612441fb0529a56461c8df63de25579f67d452fa9bf382d859 WHIRLPOOL e19f84c4a6311ef583d8f2bd53bc85a13e37bc65bdccc1823953685e0946f18cfaf0a75ee97f1a97e5d7fb9c9b0711b92f00f6949e5ca44718b6bf2347cb3a4c
diff --git a/x11-wm/enlightenment/enlightenment-0.19.12.ebuild b/x11-wm/enlightenment/enlightenment-0.19.12.ebuild
new file mode 100644
index 000000000000..bde419396bec
--- /dev/null
+++ b/x11-wm/enlightenment/enlightenment-0.19.12.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="5"
+
+MY_P=${P/_/-}
+
+if [[ ${PV} == *9999 ]] ; then
+ EGIT_SUB_PROJECT="core"
+ EGIT_URI_APPEND="${PN}"
+else
+ SRC_URI="https://download.enlightenment.org/rel/apps/${PN}/${MY_P}.tar.xz"
+ EKEY_STATE="snap"
+fi
+
+inherit enlightenment
+
+DESCRIPTION="Enlightenment DR17 window manager"
+
+LICENSE="BSD-2"
+KEYWORDS="~amd64 ~arm ~x86"
+SLOT="0.17/${PV%%_*}"
+
+# The @ is just an anchor to expand from
+__EVRY_MODS=""
+__CONF_MODS="
+ +@applications +@comp +@dialogs +@display
+ +@interaction +@intl +@menus
+ +@paths +@performance +@randr +@shelves +@theme +@wallpaper2
+ +@window-manipulation +@window-remembers"
+__NORM_MODS="
+ @access +@appmenu +@backlight +@bluez4 +@battery +@clock
+ +@connman +@contact +@cpufreq +@everything +@fileman
+ +@fileman-opinfo +@gadman +@ibar +@ibox +@illume2 +@mixer +@msgbus
+ +@music-control +@notification +@pager +@quickaccess +@shot
+ +@start +@syscon +@systray +@tasks +@teamwork +@temperature +@tiling
+ +@winlist +@wizard @wl-desktop-shell @wl-screenshot +@xkbswitch"
+IUSE_E_MODULES="
+ ${__CONF_MODS//@/enlightenment_modules_conf-}
+ ${__NORM_MODS//@/enlightenment_modules_}"
+
+IUSE="pam spell static-libs systemd +udev ukit wayland ${IUSE_E_MODULES}"
+
+RDEPEND="
+ pam? ( sys-libs/pam )
+ systemd? ( sys-apps/systemd )
+ wayland? (
+ dev-libs/efl[wayland]
+ >=dev-libs/wayland-1.2.0
+ >=x11-libs/pixman-0.31.1
+ >=x11-libs/libxkbcommon-0.3.1
+ )
+ >=dev-libs/efl-${PV}[X]
+ >=media-libs/elementary-${PV}
+ x11-libs/xcb-util-keysyms"
+DEPEND="${RDEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/quickstart.diff
+ enlightenment_src_prepare
+}
+
+src_configure() {
+ E_ECONF=(
+ --disable-install-sysactions
+ $(use_enable doc)
+ --disable-device-hal
+ $(use_enable nls)
+ $(use_enable pam)
+ $(use_enable systemd)
+ --enable-device-udev
+ $(use_enable udev mount-eeze)
+ $(use_enable ukit mount-udisks)
+ $(use_enable wayland wayland-clients)
+ )
+ local u c
+ for u in ${IUSE_E_MODULES} ; do
+ u=${u#+}
+ c=${u#enlightenment_modules_}
+ E_ECONF+=( $(use_enable ${u} ${c}) )
+ done
+ enlightenment_src_configure
+}
+
+src_install() {
+ enlightenment_src_install
+ insinto /etc/enlightenment
+ newins "${FILESDIR}"/gentoo-sysactions.conf sysactions.conf
+}