summaryrefslogtreecommitdiff
path: root/x11-wm
diff options
context:
space:
mode:
authorPacho Ramos <pacho@gentoo.org>2016-05-29 14:39:26 +0200
committerPacho Ramos <pacho@gentoo.org>2016-05-29 14:41:59 +0200
commitc0104d7a380bd7bd073a2876a3d3ad00e2f92864 (patch)
treeb071031f5700a68cabf495ea0d33f1cbac2e0e5a /x11-wm
parentx11-wm/muffin: Drop old (diff)
downloadgentoo-c0104d7a380bd7bd073a2876a3d3ad00e2f92864.tar.gz
gentoo-c0104d7a380bd7bd073a2876a3d3ad00e2f92864.tar.bz2
gentoo-c0104d7a380bd7bd073a2876a3d3ad00e2f92864.zip
x11-wm/muffin: Version bump
Package-Manager: portage-2.3.0_rc1
Diffstat (limited to 'x11-wm')
-rw-r--r--x11-wm/muffin/Manifest1
-rw-r--r--x11-wm/muffin/muffin-2.8.5.ebuild85
2 files changed, 86 insertions, 0 deletions
diff --git a/x11-wm/muffin/Manifest b/x11-wm/muffin/Manifest
index b2b528ca4bea..7e31ce65f325 100644
--- a/x11-wm/muffin/Manifest
+++ b/x11-wm/muffin/Manifest
@@ -1 +1,2 @@
DIST muffin-2.8.4.tar.gz 2714879 SHA256 b0be7c338ac1c0015355d507d1d5dcba380d4b1749ab2bc4c57754be3e70734d SHA512 2966c52a6a4e57151479d6a6e7d8a54625f5ba833fd77451a8f4a0628a660c444dfc7bfbeb14b009f9666218db40d1e5cdd888eb3f90b52b7668720e455018b7 WHIRLPOOL cf3c331e2a72012fbfed827d7af9ae5479331cb6881cb3bf406441fdc0a1b02fdc9d88afd07baf6a10f3944663e1a11da130cae38c6c00fddd699a1cdd182845
+DIST muffin-2.8.5.tar.gz 2715965 SHA256 0ae19de74111f222b44f7bf8d159437a83c6ae2e7ce70b327c0296365d69aba4 SHA512 a285e076f27e3a52ba4c6d813578e780f7f900e0ed3fa009951d908ffef3b0ded3678f6d298dd08f80b1cd61f20c90b0acd8607d53ad2accc27e16bf1bc14221 WHIRLPOOL 6493050ea667b354324511818a692cf0fca33ef83701dfee38f3bf4cec738276f885cfbdf65efa769e5bd0c0870b6359acb3fd6de583e9ab66ef09daaeeba8ff
diff --git a/x11-wm/muffin/muffin-2.8.5.ebuild b/x11-wm/muffin/muffin-2.8.5.ebuild
new file mode 100644
index 000000000000..b41f6a20fe88
--- /dev/null
+++ b/x11-wm/muffin/muffin-2.8.5.ebuild
@@ -0,0 +1,85 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit autotools eutils gnome2 python-any-r1
+
+DESCRIPTION="Compositing window manager forked from Mutter for use with Cinnamon"
+HOMEPAGE="http://cinnamon.linuxmint.com/"
+SRC_URI="https://github.com/linuxmint/muffin/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2+"
+SLOT="0"
+IUSE="+introspection test xinerama"
+KEYWORDS="~amd64 ~x86"
+
+COMMON_DEPEND="
+ >=x11-libs/pango-1.2[X,introspection?]
+ >=x11-libs/cairo-1.14:=[X]
+ x11-libs/gdk-pixbuf:2[introspection?]
+ >=x11-libs/gtk+-3.9.12:3[X,introspection?]
+ >=dev-libs/glib-2.37.3:2[dbus]
+ >=gnome-extra/cinnamon-desktop-2.4:0=[introspection?]
+ >=gnome-base/gsettings-desktop-schemas-3.3.0[introspection?]
+ >=media-libs/clutter-1.14.3:1.0=[introspection?]
+ >=media-libs/cogl-1.13.3:1.0=[introspection?]
+ >=media-libs/libcanberra-0.26[gtk3]
+ >=x11-libs/libXcomposite-0.3
+ >=x11-libs/startup-notification-0.7:=
+
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXcomposite
+ x11-libs/libXcursor
+ x11-libs/libXdamage
+ x11-libs/libXext
+ x11-libs/libXfixes
+ x11-libs/libXrandr
+ x11-libs/libXrender
+ virtual/opengl
+
+ gnome-extra/zenity
+
+ introspection? ( >=dev-libs/gobject-introspection-0.9.5:= )
+ xinerama? ( x11-libs/libXinerama )
+"
+# needs gtk-doc, not just -am, for gtk-doc.make
+DEPEND="${COMMON_DEPEND}
+ ${PYTHON_DEPS}
+ >=app-text/gnome-doc-utils-0.8
+ sys-devel/gettext
+ dev-util/gtk-doc
+ dev-util/gtk-doc-am
+ >=dev-util/intltool-0.35
+ virtual/pkgconfig
+ test? ( app-text/docbook-xml-dtd:4.5 )
+ xinerama? ( x11-proto/xineramaproto )
+ x11-proto/xextproto
+ x11-proto/xproto
+"
+RDEPEND="${COMMON_DEPEND}
+ !x11-misc/expocity
+"
+
+src_prepare() {
+ eautoreconf
+ gnome2_src_prepare
+}
+
+src_configure() {
+ DOCS="AUTHORS ChangeLog HACKING MAINTAINERS NEWS README* *.txt doc/*.txt"
+ gnome2_src_configure \
+ --disable-static \
+ --enable-shape \
+ --enable-sm \
+ --enable-startup-notification \
+ --enable-xsync \
+ --enable-verbose-mode \
+ --with-libcanberra \
+ $(use_enable introspection) \
+ $(use_enable xinerama)
+}