summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2018-06-17 13:23:07 +0200
committerMichał Górny <mgorny@gentoo.org>2018-06-17 14:11:13 +0200
commitee2fa9529ecb12a0486fb6564f02661ec3fd25de (patch)
tree69c3f61331ed2f5080a8ddc6dad65d0818bf91d9 /xfce-base/exo
parentdev-python/hypothesis: remove old (diff)
downloadgentoo-ee2fa9529ecb12a0486fb6564f02661ec3fd25de.tar.gz
gentoo-ee2fa9529ecb12a0486fb6564f02661ec3fd25de.tar.bz2
gentoo-ee2fa9529ecb12a0486fb6564f02661ec3fd25de.zip
xfce-base/exo: Bump to 0.12.1
Diffstat (limited to 'xfce-base/exo')
-rw-r--r--xfce-base/exo/Manifest1
-rw-r--r--xfce-base/exo/exo-0.12.1.ebuild41
2 files changed, 42 insertions, 0 deletions
diff --git a/xfce-base/exo/Manifest b/xfce-base/exo/Manifest
index 6aa8bbe13930..70aaefe9a61f 100644
--- a/xfce-base/exo/Manifest
+++ b/xfce-base/exo/Manifest
@@ -1,2 +1,3 @@
DIST exo-0.10.7.tar.bz2 1262301 BLAKE2B f9a0454b1f5f125fec49de834bdefd12ad827e88a852596315090cca92f92628d594fe609a35b9f926c4d19ac67fbfa60fcd5e277d6cd69082b27273ff17c823 SHA512 5a872e6895595da027f403fb7951922c40481d53242cb4d9c3da2d36690c61dce2fdb34ba0eb39367558a5e3055733af25432d1f3a8f60984b7e2ed997408b60
DIST exo-0.12.0.tar.bz2 1310691 BLAKE2B 6acdfe0b3cf7b19717d17c4acc7973bc8e27e963b4213376061cee0bec72734303ed75b7bfd8d8cbe1da98af4a9b43132657ade0020f9d26add36aa77c184ff4 SHA512 8ec52aba3faa9728bb60e09cf696f772160bfd8357c06015a6d72a2302572e74389f78a20addcf3ac632a3ac84b3ee2f40750483a16e2f7e1cff7de6f7aa2692
+DIST exo-0.12.1.tar.bz2 1321285 BLAKE2B 99721961880387fb5a953c3276a08297582c3aed5f52d578826ddde056836ec7c3b06d6f553cd660ca236cb864b79076fb19856b75e487a27db5db356f4bf685 SHA512 ee5c759a977944d56804424f4532c6e34921a34ab56ae4a11b4c8173ccae29d2397701db3d73c62b7fbf04ffb2c439b6bbbc1a4fc841bce0ce7a76fa22c42bd4
diff --git a/xfce-base/exo/exo-0.12.1.ebuild b/xfce-base/exo/exo-0.12.1.ebuild
new file mode 100644
index 000000000000..40a8273b293e
--- /dev/null
+++ b/xfce-base/exo/exo-0.12.1.ebuild
@@ -0,0 +1,41 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit gnome2-utils
+
+DESCRIPTION="Extensions, widgets and framework library with session support for Xfce"
+HOMEPAGE="https://www.xfce.org/projects/"
+SRC_URI="mirror://xfce/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd ~x86-fbsd ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
+IUSE=""
+
+RDEPEND=">=dev-lang/perl-5.6
+ >=dev-libs/glib-2.42:=
+ dev-perl/URI
+ >=x11-libs/gtk+-2.24:2=
+ >=x11-libs/gtk+-3.22:3=
+ >=xfce-base/libxfce4ui-4.12:=[gtk3(+)]
+ >=xfce-base/libxfce4util-4.12:="
+DEPEND="${RDEPEND}
+ dev-util/gtk-doc-am
+ dev-util/intltool
+ sys-devel/gettext
+ virtual/pkgconfig"
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ gnome2_icon_cache_update
+}