summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-06-22 15:51:15 +0200
committerMichał Górny <mgorny@gentoo.org>2020-06-22 17:35:38 +0200
commitdfd91cc518f899c7fb13604f0d4ef2e09c9c93ce (patch)
tree12fa646b69682f4fc5ba81a8688cb11eacd5e6ce /xfce-base/libxfce4util
parentx11-themes/elementary-xfce-icon-theme: Bump to 0.15.1 (diff)
downloadgentoo-dfd91cc518f899c7fb13604f0d4ef2e09c9c93ce.tar.gz
gentoo-dfd91cc518f899c7fb13604f0d4ef2e09c9c93ce.tar.bz2
gentoo-dfd91cc518f899c7fb13604f0d4ef2e09c9c93ce.zip
xfce-base/libxfce4util: Bump to 4.15.1
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'xfce-base/libxfce4util')
-rw-r--r--xfce-base/libxfce4util/Manifest1
-rw-r--r--xfce-base/libxfce4util/libxfce4util-4.15.1.ebuild46
2 files changed, 47 insertions, 0 deletions
diff --git a/xfce-base/libxfce4util/Manifest b/xfce-base/libxfce4util/Manifest
index a8b7c90ede6b..36a8697406f0 100644
--- a/xfce-base/libxfce4util/Manifest
+++ b/xfce-base/libxfce4util/Manifest
@@ -1,2 +1,3 @@
DIST libxfce4util-4.14.0.tar.bz2 516358 BLAKE2B d8e3d1e3247e23908456aa296415240c1a9146001a02cb859541922ee541e30955279fd68f2d9938e43f992a5115b21836363fa8d8234de87fca0bbaac830bf0 SHA512 6ac95aea03052d9e2f886cbe76afe9bbb43511bf3fe1766097e10cd8762541ed17060a727df3ef93e226aae448c15d9dd3ad8acd55a9d5f2387cb360bdf72832
DIST libxfce4util-4.15.0.tar.bz2 516074 BLAKE2B 67ba9d34c850d057012a4a2c76acce55e3afd606ab379eadc6873a62651affd69cb5d2ecd6be5e03f11b81d7bdb9ff43e39b04886f9c2c214b898b7b0dcf6b09 SHA512 f47194c999d5c4b0fd44abf392ea40ea2c3f07064e15b900821e30adc58c791e533ae2df20927037bad9db5e94981621716c743522b6daad579badd0094cffaf
+DIST libxfce4util-4.15.1.tar.bz2 520249 BLAKE2B 94a2d84d5e930cb590b87cd27d2a68e8a2d885fc783b9939adbb1af364cf84a0f2663920de5ae697e31e27c53f5665891733546d3e27e5f8cc01a56d9499ea03 SHA512 813269669df3b6b3d99f83142b4e0fbbc884306e467a3de34cd7e26e2dbe67e8cef769cab165e5f68838ead3ebd0d3895cc58e515c8e253b52a512298690acbf
diff --git a/xfce-base/libxfce4util/libxfce4util-4.15.1.ebuild b/xfce-base/libxfce4util/libxfce4util-4.15.1.ebuild
new file mode 100644
index 000000000000..dd5b8e34dae7
--- /dev/null
+++ b/xfce-base/libxfce4util/libxfce4util-4.15.1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vala
+
+DESCRIPTION="A basic utility library for the Xfce desktop environment"
+HOMEPAGE="https://git.xfce.org/xfce/libxfce4util/"
+SRC_URI="https://archive.xfce.org/src/xfce/${PN}/${PV%.*}/${P}.tar.bz2"
+
+LICENSE="LGPL-2+ GPL-2+"
+SLOT="0/7"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~x64-solaris ~x86-solaris"
+IUSE="introspection vala"
+REQUIRED_USE="vala? ( introspection )"
+
+RDEPEND=">=dev-libs/glib-2.42
+ introspection? ( dev-libs/gobject-introspection:= )"
+DEPEND="${RDEPEND}
+ dev-util/intltool
+ dev-util/gtk-doc-am
+ sys-devel/gettext
+ virtual/pkgconfig
+ vala? ( $(vala_depend) )"
+
+src_prepare() {
+ # stupid vala.eclass...
+ default
+}
+
+src_configure() {
+ local myconf=(
+ $(use_enable introspection)
+ $(use_enable vala)
+ )
+
+ use vala && vala_src_prepare
+ econf "${myconf[@]}"
+}
+
+src_install() {
+ default
+
+ find "${D}" -name '*.la' -delete || die
+}